View Issue Details

IDProjectCategoryView StatusLast Update
0004028SOGoWeb Address Bookpublic2017-03-29 10:35
Reporterjmalvarez Assigned Tofrancis  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSRHEL/CentOSOS Version7
Product Version3.2.6 
Fixed in Version3.2.8 
Summary0004028: LDAP Entries with multiple Organization fails
Description

With an LDAP address book, when you search for a contact, the contact list appears correctly, but when the contact is selected, if the contact has more than one O (organization) field, the interface fails and returns to the contacts home page.
The logs are:

Additional Information

Logs:

Feb 13 11:15:21 sogod [5089]: 192.168.102.46 "GET /SOGo/so/------------/Contacts/directorio/view?asc=1&partial=1&search=name_or_address&sort=c_cn&value= HTTP/1.1" 200 79/0 0.023 - - -84K
Feb 13 11:15:27 sogod [5089]: <0x0x7ff8f427e910[NGLdapConnection]> Using ldap_initialize for LDAP URL: ldap://ldapserver:389
2017-02-13 11:15:27.017 sogod[5089:5089] -[NGLdapConnection _searchAtBaseDN:qualifier:attributes:scope:]: search at base '' filter '(objectClass=)' for attrs 'subschemaSubentry'
2017-02-13 11:15:27.018 sogod[5089:5089] -[NGLdapConnection _searchAtBaseDN:qualifier:attributes:scope:]: search at base 'cn=Subschema' filter '(objectClass=
)' for attrs 'objectclasses'
2017-02-13 11:15:27.025 sogod[5089:5089] -[NGLdapConnection _searchAtBaseDN:qualifier:attributes:scope:]: search at base 'ou=usuarios,ou=auth,dc=example,dc=com' filter '(|(sn=aal)(displayname=aal)(telephonenumber=aal)(mail=aal)(cn=aal))' for attrs ''
Feb 13 11:15:27 sogod [5089]: 192.168.102.46 "GET /SOGo/so/------------/Contacts/directorio/view?asc=1&partial=1&search=name_or_address&sort=c_cn&value=aal HTTP/1.1" 200 1529/0 0.041 - - 604K
Feb 13 11:15:33 sogod [5089]: <0x0x7ff8f42bada0[NGLdapConnection]> Using ldap_initialize for LDAP URL: ldap://ldapserver:389
2017-02-13 11:15:33.270 sogod[5089:5089] -[NGLdapConnection _searchAtBaseDN:qualifier:attributes:scope:]: search at base 'ou=usuarios,ou=auth,dc=example,dc=com' filter '(cn=CONTACT WITH MULTIPLE ORGANIZATION PROPERTY)' for attrs '
'
EXCEPTION: <NSException: 0x7ff8f432c8f0> NAME:NSInvalidArgumentException REASON:GSInlineArray(instance) does not recognize canBeConvertedToEncoding: INFO:(null)
Feb 13 11:15:33 sogod [5047]: <0x0x7ff8f40d8dd0[WOWatchDogChild]> child 5089 exited
Feb 13 11:15:33 sogod [5047]: <0x0x7ff8f40d8dd0[WOWatchDogChild]> (terminated due to signal 6)
Feb 13 11:15:33 sogod [5047]: <0x0x7ff8f3f9f5b0[WOWatchDog]> child spawned with pid 5090
Feb 13 11:15:33 sogod [5088]: <0x0x7ff8f41da490[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
Feb 13 11:15:33 sogod [5088]: <0x0x7ff8f41da490[SOGoCache]> Using host(s) '127.0.0.1' as server(s)
Feb 13 11:15:33 sogod [5088]: 192.168.102.46 "GET /SOGo/so/------------/Contacts/personal/view?asc=1&partial=1&search=name_or_address&sort=c_cn&value=aal HTTP/1.1" 200 142/0 0.066 - - 1M
Feb 13 11:15:33 sogod [5090]: <0x0x7ff8f40cf920[WOHttpAdaptor]> notified the watchdog that we are ready

TagsNo tags attached.

Relationships

related to 0003750 resolvedfrancis LDAP addressbook: Proxy Error when user has more than one descritpion field 
related to 0004086 resolvedludovic Cannot sync global address book 

Activities

There are no notes attached to this issue.

Related Changesets

sogo: master 25430a81

2017-03-03 10:35:23

francis

Details Diff
Fix handling of contact organizations

Fixes 0004028
Affected Issues
0004028
mod - NEWS Diff File
mod - SoObjects/Contacts/NGVCard+SOGo.h Diff File
mod - SoObjects/Contacts/NGVCard+SOGo.m Diff File
mod - UI/Contacts/UIxContactEditor.m Diff File
mod - UI/Contacts/UIxContactView.m Diff File
mod - UI/Templates/ContactsUI/UIxContactEditorTemplate.wox Diff File
mod - UI/WebServerResources/js/Contacts/Card.service.js Diff File
mod - UI/WebServerResources/js/Contacts/CardController.js Diff File

Issue History

Date Modified Username Field Change
2017-02-13 05:18 jmalvarez New Issue
2017-02-15 10:44 ludovic Relationship added related to 0003750
2017-03-03 10:36 francis Changeset attached => sogo master 25430a81
2017-03-03 10:36 francis Assigned To => francis
2017-03-03 10:36 francis Resolution open => fixed
2017-03-03 11:01 francis Status new => resolved
2017-03-03 11:01 francis Fixed in Version => 3.2.8
2017-03-29 10:35 ludovic Relationship added related to 0004086