View Issue Details

IDProjectCategoryView StatusLast Update
0003949SOGoBackend Calendarpublic2016-12-30 10:32
Reporterandre.peters Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version8 (Jessie)
Product Versionnightly master 
Fixed in Version3.2.5 
Summary0003949: MySQL 5.7: Alarms are deleted right after insertion
Description

Hi,

MySQL 5.7 with dynamic row format and full unicode support. Everything works great, but:

sogo-mailcow_1 | 2016-12-18 12:17:59.714 sogod[46] <MySQL4Channel[0x0x7fb664ec9d30] connection=0x0x7fb664eca480> SQL: INSERT INTO sogo_alarms_folder (c_uid, c_recurrence_id, c_path, c_name, c_alarm_number, c_alarm_date) VALUES ('2E-58567080-5-6411B180', 0, '/Users/andre@develcow.de/Calendar/personal', '2E-58567080-5-6411B180.ics', 0, 1482066600);
sogo-mailcow_1 | 2016-12-18 12:17:59.717 sogod[46] <MySQL4Channel[0x0x7fb664ec9d30] connection=0x0x7fb664eca480> query has no results.
sogo-mailcow_1 | 2016-12-18 12:17:59.717 sogod[46] <MySQL4Channel[0x0x7fb664ec9d30] connection=0x0x7fb664eca480> SQL: COMMIT;
sogo-mailcow_1 | 2016-12-18 12:17:59.718 sogod[46] <MySQL4Channel[0x0x7fb664ec9d30] connection=0x0x7fb664eca480> query has no results.
sogo-mailcow_1 | 2016-12-18 12:17:59.719 sogod[46] <MySQL4Channel[0x0x7fb6647ca640] connection=0x0x7fb6646c9f70> SQL: BEGIN;
sogo-mailcow_1 | 2016-12-18 12:17:59.719 sogod[46] <MySQL4Channel[0x0x7fb6647ca640] connection=0x0x7fb6646c9f70> query has no results.
sogo-mailcow_1 | 2016-12-18 12:17:59.719 sogod[46] <MySQL4Channel[0x0x7fb6647ca640] connection=0x0x7fb6646c9f70> SQL: DELETE FROM sogo_alarms_folder WHERE c_path='/Users/andre@develcow.de/Calendar/personal' AND c_name='2E-58567080-5-6411B180.ics';
sogo-mailcow_1 | 2016-12-18 12:17:59.720 sogod[46] <MySQL4Channel[0x0x7fb6647ca640] connection=0x0x7fb6646c9f70> query has no results.
sogo-mailcow_1 | 2016-12-18 12:17:59.721 sogod[46] <MySQL4Channel[0x0x7fb6647ca640] connection=0x0x7fb6646c9f70> SQL: COMMIT;
sogo-mailcow_1 | 2016-12-18 12:17:59.722 sogod[46] <MySQL4Channel[0x0x7fb6647ca640] connection=0x0x7fb6646c9f70> query has no results.
sogo-mailcow_1 | 2016-12-18 12:17:59.722 sogod[46] <MySQL4Channel[0x0x7fb6647ca640] connection=0x0x7fb6646c9f70> SQL: BEGIN;
sogo-mailcow_1 | 2016-12-18 12:17:59.722 sogod[46] <MySQL4Channel[0x0x7fb6647ca640] connection=0x0x7fb6646c9f70> query has no results.
sogo-mailcow_1 | 2016-12-18 12:17:59.722 sogod[46] <MySQL4Channel[0x0x7fb664ec9d30] connection=0x0x7fb664eca480> SQL: BEGIN;
sogo-mailcow_1 | 2016-12-18 12:17:59.722 sogod[46] <MySQL4Channel[0x0x7fb664ec9d30] connection=0x0x7fb664eca480> query has no results.

Thanks! :-)

TagsNo tags attached.

Relationships

has duplicate 0003972 resolvedludovic Email Task Reminders probably not work in 3.2.4 

Activities

ckreutzer

ckreutzer

2016-12-20 02:13

reporter   ~0011041

I think I'm experiencing the same - how did you get this logging? Would try to reproduce this.

andre.peters

andre.peters

2016-12-20 03:10

reporter   ~0011042

Just set "MySQL4DebugEnabled = ON" in your configuration. :-)

Tried it with MariaDB 10.0/1 MySQL 5.6/7 and always encounter the same problem.

ckreutzer

ckreutzer

2016-12-20 05:19

reporter   ~0011043

Ah, thanks :)

It's the same for me:

2016-12-20 11:08:50.226 sogod[20740] <MySQL4Channel[0x0x7fdfbb4d8290] connection=0x0x7fdfbb4d89e0> SQL: INSERT INTO sogo_alarms_folder (c_uid, c_recurrence_id, c_path, c_name, c_alarm_number, c_alarm_date) VALUES ('5107-58590300-1-4C1A1F00', 0, '/Users/no-reply@example.com/Calendar/personal', '5107-58590300-1-4C1A1F00.ics', 0, 1482231300);
2016-12-20 11:08:50.226 sogod[20740] <MySQL4Channel[0x0x7fdfbb4d8290] connection=0x0x7fdfbb4d89e0> query has no results.
2016-12-20 11:08:50.226 sogod[20740] <MySQL4Channel[0x0x7fdfbb4d8290] connection=0x0x7fdfbb4d89e0> SQL: COMMIT;
2016-12-20 11:08:50.277 sogod[20740] <MySQL4Channel[0x0x7fdfbb4d8290] connection=0x0x7fdfbb4d89e0> query has no results.
2016-12-20 11:08:50.277 sogod[20740] <MySQL4Channel[0x0x7fdfbae95c70] connection=0x0x7fdfbab3dc00> SQL: BEGIN;
2016-12-20 11:08:50.277 sogod[20740] <MySQL4Channel[0x0x7fdfbae95c70] connection=0x0x7fdfbab3dc00> query has no results.
2016-12-20 11:08:50.277 sogod[20740] <MySQL4Channel[0x0x7fdfbae95c70] connection=0x0x7fdfbab3dc00> SQL: DELETE FROM sogo_alarms_folder WHERE c_path='/Users/no-reply@example.com/Calendar/personal' AND c_name='5107-58590300-1-4C1A1F00.ics';
2016-12-20 11:08:50.278 sogod[20740] <MySQL4Channel[0x0x7fdfbae95c70] connection=0x0x7fdfbab3dc00> query has no results.
2016-12-20 11:08:50.278 sogod[20740] <MySQL4Channel[0x0x7fdfbae95c70] connection=0x0x7fdfbab3dc00> SQL: COMMIT;
2016-12-20 11:08:50.380 sogod[20740] <MySQL4Channel[0x0x7fdfbae95c70] connection=0x0x7fdfbab3dc00> query has no results.
2016-12-20 11:08:50.380 sogod[20740] <MySQL4Channel[0x0x7fdfbae95c70] connection=0x0x7fdfbab3dc00> SQL: BEGIN;
2016-12-20 11:08:50.380 sogod[20740] <MySQL4Channel[0x0x7fdfbae95c70] connection=0x0x7fdfbab3dc00> query has no results.
2016-12-20 11:08:50.380 sogod[20740] <MySQL4Channel[0x0x7fdfbb4d8290] connection=0x0x7fdfbb4d89e0> SQL: BEGIN;
2016-12-20 11:08:50.381 sogod[20740] <MySQL4Channel[0x0x7fdfbb4d8290] connection=0x0x7fdfbb4d89e0> query has no results.
2016-12-20 11:08:50.381 sogod[20740] <MySQL4Channel[0x0x7fdfbae95c70] connection=0x0x7fdfbab3dc00> SQL: INSERT INTO sogo_quick_appointment (c_folder_id, c_iscycle, c_orgmail, c_uid, c_nextalarm, c_name, c_category, c_priority, c_sequence, c_isallday, c_title, c_description, c_status, c_classification, c_startdate, c_participants, c_partmails, c_component, c_partstates, c_location, c_isopaque, c_enddate) VALUES (20, 0, 'no-reply@example.com', '5107-58590300-1-4C1A1F00', 0, '5107-58590300-1-4C1A1F00.ics', null, 0, 0, 0, 'Reminder Check', '', 1, 0, 1482231600, 'K, C', 'ck@example.com', 'vevent', '0', '', 1, 1482235200);
2016-12-20 11:08:50.381 sogod[20740] <MySQL4Channel[0x0x7fdfbae95c70] connection=0x0x7fdfbab3dc00> query has no results.
2016-12-20 11:08:50.382 sogod[20740] <MySQL4Channel[0x0x7fdfbb4d8290] connection=0x0x7fdfbb4d89e0> SQL: INSERT INTO sogo_store (c_folder_id, c_content, c_version, c_lastmodified, c_name, c_creationdate) VALUES (20, 'BEGIN:VCALENDAR...

I already found out that the alarms_folder table was always empty, but thought the problem was that I invited a group to the event and there was no account which could accept the invitation, because my groups can't authenticate. But I can reproduce the problem with normal users, too.

Related Changesets

sogo: master 479b5348

2016-12-30 10:31:29

ludovic

Details Diff
(fix) properly save email alarms in the db (fixes 0003949) Affected Issues
0003949
mod - NEWS Diff File
mod - SoObjects/Appointments/iCalEntityObject+SOGo.m Diff File

Issue History

Date Modified Username Field Change
2016-12-18 06:23 andre.peters New Issue
2016-12-20 02:13 ckreutzer Note Added: 0011041
2016-12-20 03:10 andre.peters Note Added: 0011042
2016-12-20 05:19 ckreutzer Note Added: 0011043
2016-12-30 10:32 ludovic Changeset attached => sogo master 479b5348
2016-12-30 10:32 ludovic Assigned To => ludovic
2016-12-30 10:32 ludovic Resolution open => fixed
2016-12-30 10:32 ludovic Status new => resolved
2016-12-30 10:32 ludovic Fixed in Version => 3.2.5
2016-12-30 10:32 ludovic Relationship added has duplicate 0003972