View Issue Details

IDProjectCategoryView StatusLast Update
0003945SOGoWeb Generalpublic2017-02-09 06:37
Reporterbrunt82 Assigned Tofrancis  
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version8 (Jessie)
Target Version3.2.5Fixed in Version3.2.5 
Summary0003945: Reminder-labels confuse
Description

The response labels for the web client reminders confuse (me). See attached picture.

I'm able to select a reminder (here e.g. 10 minutes) and the two options "OK" and "Cancel" are available. But I'm unable to recognize immediately, what happens while clicking on the labels. Which button should be clicked for a new (or no) reminder again?

Here are my interpretations:
1) "OK, remind me again in 10 minutes."
or
2) "OK, I know it, close the reminder."
And the same for "Cancel":
3) "Cancel, I know the reminder."
4) "The reminder appears in 10 minutes again, therefore I cancel it."

Because the SOGo design remembers for the Google Android material design, here the best practice from Google:
https://material.google.com/components/dialogs.html#dialogs-behavior

Therefore I could imagine that the labels "Close" and "Snooze" should fit it better.
Google recommend

Steps To Reproduce
  1. Create a calendar appointment with reminder.
  2. Wait until the reminder appears in browser.
TagsNo tags attached.

Activities

brunt82

brunt82

2016-12-14 08:00

reporter  

reminder.png (8,282 bytes)   
reminder.png (8,282 bytes)   

Related Changesets

sogo: master e0108088

2016-12-14 16:39:21

francis

Details Diff
(js) Rename buttons of alarm toast

Fixes 0003945
Affected Issues
0003945
mod - NEWS Diff File
mod - UI/Common/English.lproj/Localizable.strings Diff File
mod - UI/WebServerResources/js/Common/Alarm.service.js Diff File

Issue History

Date Modified Username Field Change
2016-12-14 08:00 brunt82 New Issue
2016-12-14 08:00 brunt82 File Added: reminder.png
2016-12-14 09:07 francis Assigned To => francis
2016-12-14 09:07 francis Status new => assigned
2016-12-14 09:07 francis Target Version => 3.2.5
2016-12-14 17:57 francis Changeset attached => sogo master e0108088
2016-12-14 17:57 francis Resolution open => fixed
2016-12-14 21:22 francis Status assigned => resolved
2016-12-14 21:22 francis Fixed in Version => 3.2.5