View Issue Details

IDProjectCategoryView StatusLast Update
0003944SOGoWeb Mailpublic2017-03-22 15:36
Reporterearthian Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.4 
Fixed in Version3.2.8 
Summary0003944: Mail copies are not sent when CC recipients are entered at the end
Description

Mail to CC is not sent when recipient in Carbon Copy (CC) field is entered right before clicking "Send" button.

Steps To Reproduce

1) Enter a recipient into "To" field, eg. "test@fostral.net"
2) Enter Subject, eg. "Test message"
3) Enter some text, eg. "Second recipient will not receive email"
4) Click on "CC" button to show "CC" field
5) Enter recipient into "CC" field, eg. "admin@fostral.net"
6) Click on "Send" button (but not anywhere else)

Additional Information

The email will be received by test@fostral.net, but not by admin@fostral.net.

The same email in "Sent" folder will not have admin@fostral.net in the CC field.

TagsNo tags attached.

Relationships

related to 0004096 new recipient email address is validated only if Subject field is edited/clicked 

Activities

earthian

earthian

2016-12-13 16:30

reporter   ~0010994

Workaround:
Before clicking on "Send" button, click on any of the To/Subject/Text fields.

ludovic

ludovic

2016-12-15 14:59

administrator   ~0011006

I cannot reproduce this issue. Which browser are you using?

earthian

earthian

2016-12-15 15:53

reporter   ~0011007

Chromium 55.0.2883.75 (Developer Build) Built on 8.6, running on Debian 8.6 (64-bit)
Revision ea46662d4008c9fcfb8a3ee1933dd2f5e90a9c3b
OS Linux
JavaScript V8 5.5.372.29
Flash 21.0.0.242
User Agent Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.75 Safari/537.36
Command Line /usr/lib/chromium/chromium --ppapi-flash-path=/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so --ppapi-flash-version=21.0.0.242 --flag-switches-begin --allow-insecure-localhost --enable-devtools-experiments --enable-fast-unload --enable-lcd-text --flag-switches-end

earthian

earthian

2016-12-15 15:53

reporter   ~0011008

Also this was reported to me from a customer also on Google Chrome on Windows 10, current version.

Related Changesets

sogo: master b463fd4e

2017-03-22 15:35:05

francis

Details Diff
(js) Drop sgTransformOnBlur directive

The md-chips component has now a functional "md-add-on-blur" functionality.

Fixes 0003944
Affected Issues
0003944
mod - UI/Templates/MailerUI/UIxMailEditor.wox Diff File
mod - UI/Templates/MailerUI/UIxMailMainFrame.wox Diff File
rm - UI/WebServerResources/js/Common/sgTransformOnBlur.directive.js Diff File

Issue History

Date Modified Username Field Change
2016-12-13 16:18 earthian New Issue
2016-12-13 16:30 earthian Note Added: 0010994
2016-12-15 14:59 ludovic Note Added: 0011006
2016-12-15 14:59 ludovic Assigned To => francis
2016-12-15 14:59 ludovic Status new => assigned
2016-12-15 14:59 ludovic Severity major => minor
2016-12-15 15:53 earthian Note Added: 0011007
2016-12-15 15:53 earthian Note Added: 0011008
2017-03-21 08:29 francis Relationship added related to 0004096
2017-03-22 15:36 francis Changeset attached => sogo master b463fd4e
2017-03-22 15:36 francis Resolution open => fixed
2017-03-22 15:36 francis Status assigned => resolved
2017-03-22 15:36 francis Fixed in Version => 3.2.8