View Issue Details

IDProjectCategoryView StatusLast Update
0000389SOGoWeb Mailpublic2010-04-09 17:18
Reporteriongigi Assigned Towsourdeau 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionnightly v2 
Target Version1.2.2Fixed in Version1.2.2 
Summary0000389: Sogo courier-imap shared folders
Description

The monotone version does not display anything in Shared Folders.When I click on a folder from Shared Folders sogod restarts itself

The error is:

EXCEPTION: <NSException: 0x1115140> NAME:NSInvalidArgumentException REASON:NSException(instance) does not recognize allKeys INFO:(nil)
Jan 25 13:09:31 sogod [23944]: <0x0xae5700[WOWatchDogChild]> received SIGCHLD from pid 23945
Jan 25 13:09:31 sogod [23944]: <0x0xae5700[WOWatchDogChild]> (terminated due to signal 6)
Jan 25 13:09:31 sogod [23944]: <0x0xac4e80[WOWatchDog]> child spawned with pid 23958

Version 1.1.0 looks ok

TagsNo tags attached.

Relationships

duplicate of 0000344 resolvedwsourdeau Sogo + Courier-Imap #shared namespace 

Activities

wsourdeau

wsourdeau

2010-01-25 13:06

viewer   ~0000513

The hacks enabling Courier IMAP to work with SOGo have been removed recently. Actually the bug really is in Courier and seems to have present for a long time.

wsourdeau

wsourdeau

2010-04-07 10:34

viewer   ~0000879

Can you try with the latest nightlies?

iongigi

iongigi

2010-04-07 17:38

reporter   ~0000892

still the same error using '.' or "/" as the IMAP4 folder separator.

EXCEPTION: <NSException: 0xb74b10> NAME:NSInvalidArgumentException REASON:NSException(instance) does not recognize allKeys INFO:(nil)
Apr 08 00:35:39 sogod: SOGo watchdog [15084]: <0x0x88f940[WOWatchDogChild]> child 15166 exited
Apr 08 00:35:39 sogod: SOGo watchdog [15084]: <0x0x88f940[WOWatchDogChild]> (terminated due to signal 6)
Apr 08 00:35:39 sogod: SOGo watchdog [15084]: <0x0x88f940[WOWatchDogChild]> avoiding to respawn child before 2010-04-08 00:35:44 +0300

wsourdeau

wsourdeau

2010-04-08 14:05

viewer   ~0000904

As I noted in 0000344, you probable have not rebuilt SOPE with the latest patchset.

wsourdeau

wsourdeau

2010-04-09 17:18

viewer   ~0000920

Fixed in previous commit.

Issue History

Date Modified Username Field Change
2010-01-25 06:11 iongigi New Issue
2010-01-25 13:06 wsourdeau Note Added: 0000513
2010-02-15 11:50 wsourdeau Relationship added duplicate of 0000344
2010-03-16 16:51 ludovic Target Version => 1.2.2
2010-04-07 10:34 wsourdeau Note Added: 0000879
2010-04-07 10:34 wsourdeau Assigned To => wsourdeau
2010-04-07 10:34 wsourdeau Status new => feedback
2010-04-07 17:38 iongigi Note Added: 0000892
2010-04-08 14:05 wsourdeau Note Added: 0000904
2010-04-09 17:18 wsourdeau Note Added: 0000920
2010-04-09 17:18 wsourdeau Status feedback => resolved
2010-04-09 17:18 wsourdeau Fixed in Version => 1.2.2
2010-04-09 17:18 wsourdeau Resolution open => fixed