View Issue Details

IDProjectCategoryView StatusLast Update
0003865SOGoWeb Mailpublic2016-11-08 15:21
Reporterrevanx Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.1 
Fixed in Version3.2.2 
Summary0003865: IMAP folder subscription not working
Description

There are several problems when using web interface for managing IMAP folders subscripions (reproduced on demo.sogo.nu):

  • Unsubscribed folders are not visible in "Manage subscriptions" pop-up menu, also, when subscribed folder gets unsubscribed, it is no longer visible, therefore it can't be subscribed again.
  • Subscribed folders are not ticked in "Manage subscriptions" pop-up menu. Clicking on unticked folder in Firefox will not tick folder and causes immediate unsubscription. Clicking on unticked folder under Chromium will tick folder but does nothing, clicking on (now ticked) folder again will unscubscribe folder.
Steps To Reproduce
  1. Go to "Settings" -> "Mail" -> tick "Show subscribed mailboxes only"
  2. Open "Mail" interface a click on options near sogo1@sogo-demo.inverse.ca and choose "New folder...". Insert name for new folder.
  3. Click on same options and choose "Subscribe...". Unsubscribe created folder by clicking on unticked square box. Folder disappears.
  4. Go to "Subscribe.." again and folder is not visible.
TagsNo tags attached.

Activities

sentosa

sentosa

2016-11-07 04:20

reporter   ~0010819

I'm able to reproduce the same problem. After folder disappears for "Unsubscribe", it not possibile to subscribe again because system does not see it but it is on the filesystem.
Please fix it.

Related Changesets

sogo: master 62a30576

2016-11-08 15:20:41

francis

Details Diff
(js, html) Fix IMAP folder subscriptions manager

Fixes 0003865
Affected Issues
0003865
mod - NEWS Diff File
mod - UI/Templates/MailerUI/UIxMailFolderSubscriptions.wox Diff File
mod - UI/WebServerResources/js/Mailer/Account.service.js Diff File
mod - UI/WebServerResources/js/Mailer/Mailbox.service.js Diff File
mod - UI/WebServerResources/js/Mailer/MailboxesController.js Diff File

Issue History

Date Modified Username Field Change
2016-10-24 04:18 revanx New Issue
2016-11-07 04:20 sentosa Note Added: 0010819
2016-11-08 15:21 francis Changeset attached => sogo master 62a30576
2016-11-08 15:21 francis Assigned To => francis
2016-11-08 15:21 francis Resolution open => fixed
2016-11-08 15:21 francis Status new => resolved
2016-11-08 15:21 francis Fixed in Version => 3.2.2
2016-11-08 15:21 francis Product Version nightly v2 => 3.2.1