View Issue Details

IDProjectCategoryView StatusLast Update
0003793SOGoWeb Preferencespublic2017-06-20 15:26
ReporterDana Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Client] MicrosoftOSWindowsOS Version7
Product Version3.1.4 
Fixed in Version3.2.10 
Summary0003793: Unable to save a vacation auto reply when the "Auto Reply Subject" option is used
Description

Sogo upgraded from v2 to v3.1.4

When trying to save vacation auto replies, "connection error" is notified.

sogo.log :

Aug 16 16:06:03 sogod [11213]: |SOGo| request took 0.436218 seconds to execute
Aug 16 16:06:03 sogod [11213]: xxx.xxx.xxx.xxx "POST /SOGo/so/USER/Preferences/save HTTP/1.1" 502 31/4613 0.438 - - 0
Aug 16 16:06:04 sogod [2679]: <0x0x7f7ecae72e70[SOGoActiveSyncDispatcher]> Sleeping 5 seconds while detecting changes in Ping...
Aug 16 16:06:04 sogod [11213]: |SOGo| starting method 'POST' on uri '/SOGo/so/USER/Preferences/save'
Aug 16 16:06:04 sogod [11213]: <0x0x7f7ecad4c6a0[SOGoSieveManager]> WARNING: Could not delete Sieve script - continuing...: {RawResponse = "{ok = 0; }"; result = 0; }
Aug 16 16:06:05 sogod [11213]: <0x0x7f7ecad4c6a0[SOGoSieveManager]> Could not upload Sieve script: {RawResponse = "{ok = 0; reason = \"sogo: line 5: error: expected end of command ';' or the beginning of a compound block '{', but found tag.
sogo: error: parse failed.
\"; }"; result = 0; }

When the customized subject option is disabled, nothing goes wrong, and the sieve file is properly created.

Steps To Reproduce

Can always reproduce by enabling the customized subject option and trying to save.
(tested with different users)

TagsNo tags attached.

Activities

Dana

Dana

2016-08-16 10:41

reporter  

sogo_error.jpg (83,830 bytes)   
sogo_error.jpg (83,830 bytes)   
Christian Mack

Christian Mack

2016-08-24 09:54

developer   ~0010616

What sieve server are you using?

Dana

Dana

2016-08-25 03:29

reporter   ~0010620

As I'm running Dovecot as MDA, Sieve is integrated as dovecot-managesieved ( v2.2.13)

Is this the information you needed ?

Christian Mack

Christian Mack

2016-08-25 03:51

developer   ~0010621

Yes, thanks.

francis

francis

2016-08-29 09:26

administrator   ~0010625

Does it work when you actually specify a subject?

Dana

Dana

2016-09-10 08:34

reporter   ~0010639

No, still not working.

francis

francis

2016-10-18 10:32

administrator   ~0010752

I would need you to gather one of those two informations:

  1. Ether the JSON payload when submitting /SOGo/so/USER/Preferences/save (you can get it from the developer tools of your browser);
  2. Or the Sieve traffic that you could sniff with tcpflow.
sberthelot

sberthelot

2016-12-19 05:53

reporter   ~0011012

I've got the exact same error on 3.2.4 freshly upgraded.

In fact seing what the user does helped a lot, they think the "Custom subject" checkbox is self-sufficient and they don't naturally enter the real subject content in it. They think maybe the "auto reply message" box contains the subject and message.

We are using the French translation which doesn't even mention the "${subject}" variable and is really misleading.

Maybe you could just check that the subject is not empty when checking the checkbox ? (I've tried putting a subject and this makes the error disappear)

francis

francis

2016-12-19 10:35

administrator   ~0011019

Your Sieve server probably doesn't support variables.

Open your JavaScript console from the Preferences page and type:

<pre>sieveCapabilities</pre>

Show me the result.

3.2.4 does validate the subject (see https://github.com/inverse-inc/sogo/commit/c9467e1ce3258ecc8f8b36447b94c30165368f55).

brunt82

brunt82

2017-02-08 08:42

reporter   ~0011282

I tested it with 3.2.6a: I always have to save the settings twice: The first time I get the described http 502 error (and the sieve filter will not work although it is created correctly on the dovecote server). The second time the settings will be saved successfully and the filer works as expected. It does not matter, if a subject is set or not.

Which information/files do you need?

francis

francis

2017-03-03 16:03

administrator   ~0011427

Please capture the Sieve traffic to see the full conversation with the server.

<pre>tcpflow -i lo -c tcp port sieve</pre>

francis

francis

2017-05-22 21:59

administrator   ~0011821

It's probably because you enabled the "auto reply subject" checkbox but haven't specify an actual subject. This is no longer possible in the latest versions of SOGo.

cwright

cwright

2017-06-14 11:04

reporter   ~0011931

I just ran into this issue with a user who enabled "Auto Reply Subject" but didn't enter any text.

In this case the option to save the vacation message is grayed out (which is good) but if the user navigates away from the page they get the dialog "Unsaved Changes Do you want to save your changes made to the configuration?"

If the user selects "Save", a connection error dialog is displayed but the vacation message appears enabled in the web GUI even though the sogo.sieve file is not updated on the mail server.

cwright

cwright

2017-06-14 11:05

reporter   ~0011932

I'm running SOGo 3.2.9 201705100648

Thank you.

Related Changesets

sogo: master e1bc458d

2017-06-20 15:25:07

francis

Details Diff
(js) Don't save form when invalid

Fixes 0003793
Affected Issues
0003793
mod - UI/WebServerResources/js/Preferences/PreferencesController.js Diff File

Issue History

Date Modified Username Field Change
2016-08-16 10:41 Dana New Issue
2016-08-16 10:41 Dana File Added: sogo_error.jpg
2016-08-24 09:54 Christian Mack Note Added: 0010616
2016-08-25 03:29 Dana Note Added: 0010620
2016-08-25 03:51 Christian Mack Note Added: 0010621
2016-08-29 09:26 francis Note Added: 0010625
2016-09-10 08:34 Dana Note Added: 0010639
2016-10-18 10:32 francis Note Added: 0010752
2016-12-19 05:53 sberthelot Note Added: 0011012
2016-12-19 10:35 francis Note Added: 0011019
2017-02-08 08:42 brunt82 Note Added: 0011282
2017-03-03 16:03 francis Note Added: 0011427
2017-05-22 21:59 francis Note Added: 0011821
2017-06-14 11:04 cwright Note Added: 0011931
2017-06-14 11:05 cwright Note Added: 0011932
2017-06-20 15:25 francis Changeset attached => sogo master e1bc458d
2017-06-20 15:25 francis Assigned To => francis
2017-06-20 15:25 francis Resolution open => fixed
2017-06-20 15:25 francis Status new => resolved
2017-06-20 15:25 francis Fixed in Version => 3.2.10