View Issue Details

IDProjectCategoryView StatusLast Update
0003775SOGoActiveSyncpublic2016-07-25 06:23
Reporterm_emelchenkov Assigned Toludovic  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformiPhoneOSiOSOS Version9
Product Version3.1.4 
Fixed in Version3.1.5 
Summary0003775: Latest trunk exception — no mail via ActiveSync
Description

In sogo.log:
EXCEPTION: <NSException: 0x7fd0dcca0888> NAME:NSInvalidArgumentException REASON:GSCBufferString(instance) does not recognize getElementsByTagName: INFO:(null)

This message repeats. iPhone does not produce any error but stop receiving new mails (Just updated, but no mails). Also if try to delete message it will be deleted from iphone but will not be synced. It syncs after reboot iPhone, then stop again with this EXCEPTION. It worked with previous SOGO versions.

TagsNo tags attached.

Activities

sn0

sn0

2016-07-25 03:04

reporter   ~0010541

Same here:

Jul 23 20:54:03 sogod [26102]: 10.196.62.90 "POST
/SOGo/Microsoft-Server-ActiveSync?Cmd=Sync&User=xxxxxxxxx&DeviceId=E58D4901322E45B4BF08C7D13Cxxxxxx&DeviceType=WindowsOutlook15
HTTP/1.1" 200 98/138 1.990 - - 20M

Jul 23 20:54:03 sogod [26102]:
<0x0x7f3daea9fed0[SOGoActiveSyncDispatcher]> EAS - request for device
E58D4901322E45B4BF08C7D13Cxxxxxx: <?xml version="1.0"?>
<!DOCTYPE ActiveSync PUBLIC "-//MICROSOFT//DTD ActiveSync//EN"
"http://www.microsoft.com/&quot;>
<MoveItems xmlns="Move:">
<Move>
<SrcMsgId>5208</SrcMsgId>
<SrcFldId>mail%2F1735d22c15a51e57f87c00000e29239f</SrcFldId>
<DstFldId>mail%2F1635d22c15a51e57f87c00000e29239f</DstFldId>
</Move>
</MoveItems>

EXCEPTION: <NSException: 0x7f3daedc0ab0> NAME:NSInvalidArgumentException
REASON:GSCBufferString(instance) does not recognize
getElementsByTagName: INFO:(null)

Jul 23 20:54:03 sogod [26062]: <0x0x7f3daed6fe30[WOWatchDogChild]> child
26102 exited

Jul 23 20:54:03 sogod [26062]: <0x0x7f3daed6fe30[WOWatchDogChild]>
(terminated due to signal 6)

ludovic

ludovic

2016-07-25 06:23

administrator   ~0010544

Fixed in both v3 and v2.

Related Changesets

sogo: master 4ed10632

2016-07-25 06:17:17

ludovic

Details Diff
Correctly get the collection/key IDs (fixes 0003775) Affected Issues
0003775
mod - ActiveSync/SOGoActiveSyncDispatcher+Sync.m Diff File

sogo: v2 8545f89b

2016-07-25 06:17:17

ludovic

Details Diff
Correctly get the collection/key IDs (fixes 0003775) Affected Issues
0003775
mod - ActiveSync/SOGoActiveSyncDispatcher+Sync.m Diff File

Issue History

Date Modified Username Field Change
2016-07-24 14:26 m_emelchenkov New Issue
2016-07-25 03:04 sn0 Note Added: 0010541
2016-07-25 06:21 ludovic Changeset attached => sogo master 4ed10632
2016-07-25 06:21 ludovic Assigned To => ludovic
2016-07-25 06:21 ludovic Resolution open => fixed
2016-07-25 06:22 ludovic Changeset attached => sogo v2 8545f89b
2016-07-25 06:23 ludovic Note Added: 0010544
2016-07-25 06:23 ludovic Status new => resolved
2016-07-25 06:23 ludovic Fixed in Version => 3.1.5