View Issue Details

IDProjectCategoryView StatusLast Update
0003735SOGoWeb Calendarpublic2016-06-17 09:28
Reporterfrust Assigned Tofrancis  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformAppleOSOS XOS Version10.11.5
Product Version3.1.2 
Fixed in Version3.1.3 
Summary0003735: Web Calendar Entries are one day off
Description

When entering an all-day event in web calendar, the resulting event is one day too early.

Steps To Reproduce

Go to web calendar, Click on New-Icon
Enter All-Day Event over one or more days
press save
view wrong result

OR
click on existing all-day event,
click on edit
don't change the date, modify something else
click on save
wie wrong result

Additional Information

I did two screenshots and merged them together in the attachment.

TagsNo tags attached.

Relationships

duplicate of 0003457 resolvedfrancis All-day event ist not displayed correctly while transitioning Into Daylight Saving Time (Timezone Europe/Berlin) 

Activities

frust

frust

2016-06-16 18:15

reporter  

Bildschirmfoto.jpg (231,923 bytes)   
Bildschirmfoto.jpg (231,923 bytes)   
frust

frust

2016-06-17 00:32

reporter   ~0010389

Sorry -- Platform is wrong. Probably the platform of the SOGo machine is asked, not the platform of the client machine.

Platform is: Linux,
Distributor ID: Debian
Description: Debian GNU/Linux 8.5 (jessie)
Release: 8.5
Codename: jessie

frust

frust

2016-06-17 02:35

reporter   ~0010390

Additional info which might be helpful:
machine Timezone is Europe/Berlin
SOGo timezone is Europe/Berlin
mysql timezone is 'SYSTEM'

When investigating the SOGo database I can see that short events are stored in local time
in sogo<name><xxx>_quick tables (as unix-timestamp)
so an event starting today 13:30 CEST has the entry 1466163000:
FROM_UNIXTIME(1466163000) = 2016-06-17 13:30:00
but an all-day event always starts at UTC:
an event starting at 2016-06-20 has the entry 1466380800:
FROM_UNIXTIME(1466380800) = 2016-06-20 02:00:00
but probably should be
UNIX_TIMESTAMP('2016-06-20 00:00:00') = 1466373600

francis

francis

2016-06-17 06:25

administrator   ~0010392

Can you reproduce the problem on demo.sogo.nu?

frust

frust

2016-06-17 09:16

reporter   ~0010393

No, the demo does it correctly -- even if I set to timezone eorope/berlin
If setting the calendar from my Mac Calendar App it works correctly too.
Its only the web frontend.
It seems to occur since I upgraded from 3.1.0 to 3.1.2

I have no clue what could cause the problem

Issue History

Date Modified Username Field Change
2016-06-16 18:15 frust New Issue
2016-06-16 18:15 frust File Added: Bildschirmfoto.jpg
2016-06-17 00:32 frust Note Added: 0010389
2016-06-17 02:35 frust Note Added: 0010390
2016-06-17 06:25 francis Note Added: 0010392
2016-06-17 09:16 frust Note Added: 0010393
2016-06-17 09:28 francis Relationship added duplicate of 0003457
2016-06-17 09:28 francis Status new => resolved
2016-06-17 09:28 francis Fixed in Version => 3.1.3
2016-06-17 09:28 francis Resolution open => fixed
2016-06-17 09:28 francis Assigned To => francis