View Issue Details

IDProjectCategoryView StatusLast Update
0003733SOGoWeb Mailpublic2016-06-17 14:36
Reportersentosa Assigned Toludovic  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version16.04 64bit
Product Version3.1.2 
Fixed in Version3.1.3 
Summary0003733: "Other Users" folder not showing who shared folder except for postmaster user
Description

Installed iRedMail 0.9.5-1 which download and install Sogo 3.1.2.
First user created is postmaster@domain which is the master email admin.
Created other two users (@domain).
If user1 shares "Sent" folder to user2 and postmaster shares "Sent" folder to user2, then user2 is able to see both "Sent" folders under "Other users" folder, is able to see postmaster name but is not able to see user1 name (field is blank) with its "Sent" folder under it.
Under RoundCube (installed togheter with SOGo in iRedMail), I can see correctly names and shared folders.

TagsNo tags attached.

Activities

francis

francis

2016-06-16 11:08

administrator   ~0010385

I assume you're using Dovecot? Could you sniff the IMAP traffic and post the result of the LIST/LSUB commands?

sentosa

sentosa

2016-06-16 11:18

reporter   ~0010386

Thank you, you're right about Dovecot. I've finally found the problem testing on the SOGo demo from official site. The problem is that I have not set Display Name when creating the two new users: SOGo uses it for displaying under Other Users but not by RoundCube which takes and show the email address in place of the Display Name.
Thank you again and be patience for fake alarm.

Related Changesets

sogo: master c8c8d12d

2016-06-17 14:28:03

ludovic

Details Diff
(fix) fallback to email address if no CN is found (fixes 0003733) Affected Issues
0003733
mod - SoObjects/Mailer/SOGoMailAccount.m Diff File

Issue History

Date Modified Username Field Change
2016-06-16 10:15 sentosa New Issue
2016-06-16 11:08 francis Note Added: 0010385
2016-06-16 11:18 sentosa Note Added: 0010386
2016-06-17 14:29 ludovic Changeset attached => sogo master c8c8d12d
2016-06-17 14:29 ludovic Assigned To => ludovic
2016-06-17 14:29 ludovic Resolution open => fixed
2016-06-17 14:36 ludovic Status new => resolved
2016-06-17 14:36 ludovic Fixed in Version => 3.1.3