View Issue Details

IDProjectCategoryView StatusLast Update
0003723SOGoWeb Calendarpublic2016-06-09 13:27
ReporterDirk Egert Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version8 (Jessie)
Product Version3.1.2 
Fixed in Version3.1.3 
Summary0003723: 502 Bad Gateway when accessing web calendar
Description

Since today we have 2 users which can't access their calendar anymore in the Web UI.
Just before this happend for the first time, a shared calendar were removed by an other user (maybe this could be related).
In the sogo.log I'm seeing:

Jun 09 12:33:29 sogod [2858]: 192.168.12.12 "GET /SOGo/so/test.user@sample.de/Calendar HTTP/1.0" 302 0/0 0.006 - - 0
EXCEPTION: <NSException: 0x7fc9d2ab4520> NAME:NSInvalidArgumentException REASON:GSMutableString(instance) does not recognize displayName INFO:(null)
Jun 09 12:33:30 sogod [2783]: <0x0x7fc9d224c850[WOWatchDogChild]> child 2858 exited
Jun 09 12:33:30 sogod [2783]: <0x0x7fc9d224c850[WOWatchDogChild]> (terminated due to signal 6)
Jun 09 12:33:30 sogod [2783]: <0x0x7fc9d1f61de0[WOWatchDog]> child spawned with pid 3127
Jun 09 12:00:17 sogod [2783]: <0x0x7fc9d224c850[WOWatchDogChild]> (terminated due to signal 6)
Jun 09 12:00:17 sogod [2783]: <0x0x7fc9d1f61de0[WOWatchDog]> child spawned with pid 2858

And in the error.log from nginx

2016/06/09 12:33:29 [error] 421#0: *438 upstream prematurely closed connection while reading response header from upstream, client: 192.168.12.1, server: _, request: "GET /SOGo/so/test.user@sample.de/Calendar/view HTTP/1.1", upstream: "http://127.0.0.1:20000/SOGo/so/test.user@sample.de/Calendar/view&quot;, host: "test.sample.de", referrer: "https://test.sample.de/SOGo/so/test.user@sample.de/Mail/view&quot;

Other users have no problems with their calendars.

Which Debug Option can be used to find the cause of this error?

TagsNo tags attached.

Activities

ludovic

ludovic

2016-06-09 07:09

administrator   ~0010324

Try this: https://sogo.nu/nc/support/faq/article/how-do-i-debug-sogo.html

Dirk Egert

Dirk Egert

2016-06-09 07:16

reporter   ~0010325

Here's the output from gdb

(gdb) bt
#0 __GI_abort () at abort.c:51
0000001 0x000055555555c5eb in -[SOGo handleException:inContext:] (self=<optimized out>, _cmd=<optimized out>, _exc=<optimized out>, _ctx=<optimized out>)
at SOGo.m:449
0000002 0x00007ffff6c8ef4d in ?? () from /usr/lib/libNGObjWeb.so.4.9
0000003 0x00007ffff6c5633c in ?? () from /usr/lib/libNGObjWeb.so.4.9
0000004 0x000055555555c99e in -[SOGo dispatchRequest:] (self=0x5555558b7ac0, _cmd=<optimized out>, _request=0x5555560f10c0) at SOGo.m:565
0000005 0x00007ffff6ce99fd in ?? () from /usr/lib/libNGObjWeb.so.4.9
0000006 0x00007ffff6ceaec8 in ?? () from /usr/lib/libNGObjWeb.so.4.9
0000007 0x00007ffff6ce5f5a in ?? () from /usr/lib/libNGObjWeb.so.4.9
0000008 0x00007ffff6ce6da6 in ?? () from /usr/lib/libNGObjWeb.so.4.9
0000009 0x00007ffff6ce713a in ?? () from /usr/lib/libNGObjWeb.so.4.9
0000010 0x00007ffff6ce71c4 in ?? () from /usr/lib/libNGObjWeb.so.4.9
0000011 0x00007ffff5456d07 in ?? () from /usr/lib/libgnustep-base.so.1.24
0000012 0x00007ffff5561b3b in ?? () from /usr/lib/libgnustep-base.so.1.24
0000013 0x00007ffff549f840 in ?? () from /usr/lib/libgnustep-base.so.1.24
0000014 0x00007ffff549fcf2 in ?? () from /usr/lib/libgnustep-base.so.1.24
0000015 0x00007ffff6c5771e in ?? () from /usr/lib/libNGObjWeb.so.4.9
0000016 0x000055555555c2bf in -[SOGo run] (self=0x5555558b7ac0, _cmd=<optimized out>) at SOGo.m:326
0000017 0x00007ffff6c7bf54 in WOApplicationMain () from /usr/lib/libNGObjWeb.so.4.9
0000018 0x00007ffff6c97c8f in WOWatchDogApplicationMain () from /usr/lib/libNGObjWeb.so.4.9
0000019 0x000055555555a7ab in main (argc=13, argv=0x7fffffffec58, env=<optimized out>) at sogod.m:51

ludovic

ludovic

2016-06-09 07:16

administrator   ~0010326

This not useful, reread the documentation.

Dirk Egert

Dirk Egert

2016-06-09 07:42

reporter   ~0010327

You mean there were some more *-dbg packages missing..

#0 -[NSException raise] (self=0x55555629a4b0, _cmd=0x7ffff58fcfc0 <_OBJC_SELECTOR_TABLE+384>) at NSException.m:960
0000001 0x00007ffff54137a3 in +[NSException raise:format:] (self=0x7ffff58fd2c0 <_OBJC_Class_NSException>, _cmd=<optimized out>,
name=0x7ffff58fd950 <_OBJC_INSTANCE_4>, format=0x7ffff592c7b0 <_OBJC_INSTANCE_10>) at NSException.m:840
0000002 0x00007ffff54677f6 in -[NSObject doesNotRecognizeSelector:] (self=0x555555ea1b60, _cmd=<optimized out>, aSelector=<optimized out>) at NSObject.m:1765
0000003 0x00007ffff5527fd3 in GSFFIInvocationCallback (cif=0x55555629a4b0, retp=0x7fffffffba40, args=0x55555629c9f0, user=0x55555629cbc0)
at GSFFIInvocation.m:629
0000004 0x00007ffff18b1baf in ffi_closure_unix64_inner () from /usr/lib/x86_64-linux-gnu/libffi.so.6
0000005 0x00007ffff18b1f28 in ffi_closure_unix64 () from /usr/lib/x86_64-linux-gnu/libffi.so.6
0000006 0x00007fffe984d6cb in -[UIxCalendarSelector calendars] (self=0x55555614fd30, _cmd=<optimized out>) at UIxCalendarSelector.m:167
0000007 0x00007ffff6ca4bd5 in _getComponentValue (self=self@entry=0x55555620b8e0, object=0x55555614fd30, info=info@entry=0x555556153c90)
at WOKeyPathAssociation.m:537
0000008 0x00007ffff6ca9080 in _getValueN (root=<optimized out>, _count=2, self=0x55555620b8e0) at WOKeyPathAssociation.m:737
0000009 _getValue (root=<optimized out>, self=0x55555620b8e0) at WOKeyPathAssociation.m:750
0000010 -[WOKeyPathAssociation valueInComponent:] (self=0x55555620b8e0, _cmd=<optimized out>, _component=<optimized out>) at WOKeyPathAssociation.m:1004
0000011 0x00007ffff6cd8e53 in -[_WOComplexString appendToResponse:inContext:] (self=0x55555607c840, _cmd=<optimized out>, _response=0x555555f968e0,
_ctx=0x555555f5d3d0) at WOString.m:561
0000012 0x00007ffff6cc29a2 in -[WOCompoundElement appendToResponse:inContext:] (self=0x5555561541f0, _cmd=<optimized out>, _response=0x555555f968e0,
_ctx=0x555555f5d3d0) at WOCompoundElement.m:247
0000013 0x00007ffff6cc8c07 in -[WOGenericContainer appendToResponse:inContext:] (self=0x55555616ba60, _cmd=<optimized out>, _response=0x555555f968e0,
_ctx=0x555555f5d3d0) at WOGenericContainer.m:121
0000014 0x00007ffff6cc29a2 in -[WOCompoundElement appendToResponse:inContext:] (self=0x55555611ee10, _cmd=<optimized out>, _response=0x555555f968e0,
_ctx=0x555555f5d3d0) at WOCompoundElement.m:247
0000015 0x00007ffff6c5c3d2 in -[WOComponent appendToResponse:inContext:] (self=0x55555614fd30, _cmd=<optimized out>, _response=0x555555f968e0,
_ctx=0x555555f5d3d0) at WOComponent.m:928
0000016 0x00007ffff6c7c887 in -[WOChildComponentReference appendToResponse:inContext:] (self=0x555555f7c2a0, _cmd=0x7ffff6fe9950 <_OBJC_SELECTOR_TABLE+720>,
_response=0x555555f968e0, _ctx=0x555555f5d3d0) at WOChildComponentReference.m:181
0000017 0x00007ffff6cc29a2 in -[WOCompoundElement appendToResponse:inContext:] (self=0x5555562182a0, _cmd=<optimized out>, _response=0x555555f968e0,
_ctx=0x555555f5d3d0) at WOCompoundElement.m:247
0000018 0x00007ffff6cc1001 in -[WOComponentContent appendToResponse:inContext:] (self=<optimized out>, _cmd=0x7ffff6fe9950 <_OBJC_SELECTOR_TABLE+720>,
_response=0x555555f968e0, _ctx=0x555555f5d3d0) at WOComponentContent.m:149
0000019 0x00007ffff6cc29a2 in -[WOCompoundElement appendToResponse:inContext:] (self=0x5555560a7c10, _cmd=<optimized out>, _response=0x555555f968e0,
_ctx=0x555555f5d3d0) at WOCompoundElement.m:247
0000020 0x00007ffff6cc39d0 in -[WOConditional appendToResponse:inContext:] (self=<optimized out>, _cmd=<optimized out>, _response=0x555555f968e0,
---Type <return> to continue, or q <return> to quit---
_ctx=0x555555f5d3d0) at WOConditional.m:242
0000021 0x00007ffff6cc29a2 in -[WOCompoundElement appendToResponse:inContext:] (self=0x555556071200, _cmd=<optimized out>, _response=0x555555f968e0,
_ctx=0x555555f5d3d0) at WOCompoundElement.m:247
0000022 0x00007ffff6cbd394 in -[WOBody appendToResponse:inContext:] (self=<optimized out>, _cmd=<optimized out>, _response=0x555555f968e0, _ctx=0x555555f5d3d0)
at WOBody.m:157
0000023 0x00007ffff6cc29a2 in -[WOCompoundElement appendToResponse:inContext:] (self=0x55555618f740, _cmd=<optimized out>, _response=0x555555f968e0,
_ctx=0x555555f5d3d0) at WOCompoundElement.m:247
0000024 0x00007ffff6cc8c07 in -[WOGenericContainer appendToResponse:inContext:] (self=0x555555f8e390, _cmd=<optimized out>, _response=0x555555f968e0,
_ctx=0x555555f5d3d0) at WOGenericContainer.m:121
0000025 0x00007ffff6cc29a2 in -[WOCompoundElement appendToResponse:inContext:] (self=0x555555f91760, _cmd=<optimized out>, _response=0x555555f968e0,
_ctx=0x555555f5d3d0) at WOCompoundElement.m:247
0000026 0x00007ffff6cc39d0 in -[WOConditional appendToResponse:inContext:] (self=<optimized out>, _cmd=<optimized out>, _response=0x555555f968e0,
_ctx=0x555555f5d3d0) at WOConditional.m:242
0000027 0x00007ffff6cc29a2 in -[WOCompoundElement appendToResponse:inContext:] (self=0x555555eb3960, _cmd=<optimized out>, _response=0x555555f968e0,
_ctx=0x555555f5d3d0) at WOCompoundElement.m:247
0000028 0x00007ffff6c5c3d2 in -[WOComponent appendToResponse:inContext:] (self=0x555556054500, _cmd=<optimized out>, _response=0x555555f968e0,
_ctx=0x555555f5d3d0) at WOComponent.m:928
0000029 0x00007ffff6c7c887 in -[WOChildComponentReference appendToResponse:inContext:] (self=0x555556218240, _cmd=0x7ffff6fc91a0 <_OBJC_SELECTOR_TABLE+352>,
_response=0x555555f968e0, _ctx=0x555555f5d3d0) at WOChildComponentReference.m:181
0000030 0x00007ffff6c5c3d2 in -[WOComponent appendToResponse:inContext:] (self=0x55555623ceb0, _cmd=<optimized out>, _response=0x555555f968e0,
_ctx=0x555555f5d3d0) at WOComponent.m:928
0000031 0x00007ffff6cf12eb in -[SoDefaultRenderer renderComponent:inContext:] () from /usr/lib/libNGObjWeb.so.4.9
0000032 0x00007ffff6cf8412 in -[SoObjectRequestHandler renderObject:inContext:] () from /usr/lib/libNGObjWeb.so.4.9
0000033 0x00007ffff6cf8f6d in -[SoObjectRequestHandler handleRequest:inContext:session:application:] () from /usr/lib/libNGObjWeb.so.4.9
0000034 0x00007ffff6c8e85e in -[WORequestHandler handleRequest:] (self=0x555555b48d50, _cmd=<optimized out>, _request=0x55555614c340) at WORequestHandler.m:237
0000035 0x00007ffff6c5633c in -[WOCoreApplication dispatchRequest:usingHandler:] (self=0x5555558b7ac0, _cmd=<optimized out>, _request=0x55555614c340,
handler=0x555555b48d50) at WOCoreApplication.m:712
0000036 0x000055555555c99e in -[SOGo dispatchRequest:] (self=0x5555558b7ac0, _cmd=<optimized out>, _request=0x55555614c340) at SOGo.m:565
0000037 0x00007ffff6ce99fd in -[WOHttpTransaction _run] (self=0x555555ea28a0, _cmd=<optimized out>) at WOHttpTransaction.m:596
0000038 0x00007ffff6ceaec8 in -[WOHttpTransaction run] (self=0x555555ea28a0, _cmd=<optimized out>) at WOHttpTransaction.m:649
0000039 0x00007ffff6ce5f5a in -[WOHttpAdaptor runConnection:] (self=0x555555c242b0, _cmd=<optimized out>, _socket=<optimized out>) at WOHttpAdaptor.m:367
0000040 0x00007ffff6ce6da6 in -[WOHttpAdaptor _handleAcceptedConnection:] (self=0x555555c242b0, _cmd=<optimized out>, _connection=0x5555561686e0)
at WOHttpAdaptor.m:401
---Type <return> to continue, or q <return> to quit---
0000041 0x00007ffff6ce713a in -[WOHttpAdaptor _handleConnection:] (self=0x555555c242b0, _cmd=<optimized out>, connection=0x5555561686e0) at WOHttpAdaptor.m:460
0000042 0x00007ffff6ce71c4 in -[WOHttpAdaptor acceptConnection:] (self=0x555555c242b0, _cmd=<optimized out>, _notification=<optimized out>)
at WOHttpAdaptor.m:521
0000043 0x00007ffff5456d07 in -[NSNotificationCenter _postAndRelease:] (self=0x555555898e00, _cmd=<optimized out>, notification=0x555556020350)
at NSNotificationCenter.m:1307
0000044 0x00007ffff5561b3b in -[GSRunLoopCtxt pollUntil:within:] (self=<optimized out>, _cmd=0x7ffff5946900 <_OBJC_SELECTOR_TABLE+1216>,
milliseconds=<optimized out>, contexts=<optimized out>) at GSRunLoopCtxt.m:642
0000045 0x00007ffff549f840 in -[NSRunLoop acceptInputForMode:beforeDate:] (self=0x555555b8f220, _cmd=0x7ffff58fcfc0 <_OBJC_SELECTOR_TABLE+384>,
mode=0x7ffff5947770 <_OBJC_INSTANCE_2>, limit_date=0x555555b375c0) at NSRunLoop.m:1217
0000046 0x00007ffff549fcf2 in -[NSRunLoop runMode:beforeDate:] (self=0x555555b8f220, _cmd=0x555555b39930, mode=0x7ffff5947770 <_OBJC_INSTANCE_2>,
date=0x555555abcca0) at NSRunLoop.m:1288
0000047 0x00007ffff6c5771e in -[WOCoreApplication run] (self=0x5555558b7ac0, _cmd=<optimized out>) at WOCoreApplication.m:584
0000048 0x000055555555c2bf in -[SOGo run] (self=0x5555558b7ac0, _cmd=<optimized out>) at SOGo.m:326
0000049 0x00007ffff6c7bf54 in WOApplicationMain (_appClassName=_appClassName@entry=0x555555761600 <_OBJC_INSTANCE_0>, argc=argc@entry=13,
argv=argv@entry=0x7fffffffec58) at WOApplicationMain.m:42
0000050 0x00007ffff6c97c8f in WOWatchDogApplicationMain (appName=0x555555761600 <_OBJC_INSTANCE_0>, argc=13, argv=0x7fffffffec58)
at WOWatchDogApplicationMain.m:1043
0000051 0x000055555555a7ab in main (argc=13, argv=0x7fffffffec58, env=<optimized out>) at sogod.m:51

ludovic

ludovic

2016-06-09 07:54

administrator   ~0010328

What is the URL of the web calendar?

Dirk Egert

Dirk Egert

2016-06-09 08:01

reporter   ~0010329

The error occurs when you click on the calendar

https://test.sample.de/SOGo/so/test.user@sample.de/Calendar/view

But I've anonymised the domain and the email address.

ludovic

ludovic

2016-06-09 08:20

administrator   ~0010330

That's NOT a ICS-based URL from SOGo. Ask for the calendar properties to know the real URL to use.

ludovic

ludovic

2016-06-09 08:22

administrator   ~0010331

Or do you mean the user is simply trying to enable/disable the calendar from the SOGo web interface?

The use of "web calendar" can be confusing, since web calendars in SOGo are ICS subscriptions.

ludovic

ludovic

2016-06-09 08:33

administrator   ~0010332

Try to reproduce the issue and in gdb, when the exception occurs, do:

f 6
po folder
po NSStringFromClass([folder class])

Paste the result of the 3 commands here.

Dirk Egert

Dirk Egert

2016-06-09 08:34

reporter   ~0010333

The problem is - I cannot access the properties from the user, because of the "Bad gateway" error.
But from a admin account it's shown as:

https://test.sample.de/SOGo/dav/test.user@sample.de/Calendar/personal.ics

And from my browser I can download it.

Dirk Egert

Dirk Egert

2016-06-09 08:36

reporter   ~0010334

The user wants to access his calendar in the Browser.

Dirk Egert

Dirk Egert

2016-06-09 08:41

reporter   ~0010335

Last edited: 2016-06-09 09:33

Here's the output of the 3 commands:

Breakpoint 1, -[NSException raise] (self=0x5555566f5340, _cmd=0x7ffff58fcfc0 <_OBJC_SELECTOR_TABLE+384>) at NSException.m:960
960 NSException.m: Datei oder Verzeichnis nicht gefunden.
(gdb) f 6
0000006 0x00007fffe984d6cb in -[UIxCalendarSelector calendars] (self=0x5555560fd020, _cmd=<optimized out>) at UIxCalendarSelector.m:167
167 UIxCalendarSelector.m: Datei oder Verzeichnis nicht gefunden.
(gdb) po folder
svetlana_D_iliaeva_A_sample_D_de_AE6-5755F280-1-4092D880
(gdb) po NSStringFromClass([folder class])
GSMutableString

svetlana_D_iliaeva_A_sample_D_de_AE6-5755F280-1-4092D880 is a shared calendar from an other user.
And this is maybe the deleted calendar.

ludovic

ludovic

2016-06-09 10:41

administrator   ~0010336

I cannot reproduce this...

When doing f 6, also do:

po sortedFolders
po folderName

Dirk Egert

Dirk Egert

2016-06-09 11:07

reporter   ~0010340

Here's the output:

Breakpoint 1, -[NSException raise] (self=0x5555562974e0, _cmd=0x7ffff58fcfc0 <_OBJC_SELECTOR_TABLE+384>) at NSException.m:960
960 NSException.m: Datei oder Verzeichnis nicht gefunden.
(gdb) f 6
0000006 0x00007fffe984d6cb in -[UIxCalendarSelector calendars] (self=0x55555606c750, _cmd=<optimized out>) at UIxCalendarSelector.m:167
167 UIxCalendarSelector.m: Datei oder Verzeichnis nicht gefunden.
(gdb) po folder
svetlana_D_iliaeva_A_sample_D_de_AE6-5755F280-1-4092D880
(gdb) po sortedFolders
("<0x555556026db0[SOGoAppointmentFolder]: name=personal container=0x5555561450f0/Calendar ocs=/Users/jochen.becker-gruell@sample.de/Calendar/personal>", "<0x55555615b6c0[SOGoAppointmentFolder]: name=enver_D_oezguer_A_sample_D_de_personal container=0x5555561450f0/Calendar ocs=/Users/enver.oezguer@sample.de/Calendar/personal>", "<0x5555560732b0[SOGoAppointmentFolder]: name=fevzi_D_cebe_A_sample_D_de_personal container=0x5555561450f0/Calendar ocs=/Users/fevzi.cebe@sample.de/Calendar/personal>", "<0x555555f4c290[SOGoAppointmentFolder]: name=maggie_D_berg_A_sample_D_de_personal container=0x5555561450f0/Calendar ocs=/Users/maggie.berg@sample.de/Calendar/personal>",
"<0x555556175f90[SOGoAppointmentFolder]: name=pascal_D_marquardt_A_sample_D_de_personal container=0x5555561450f0/Calendar ocs=/Users/pascal.marquardt@sample.de/Calendar/personal>", "<0x5555561c8350[SOGoAppointmentFolder]: name=sarah_D_ince-kemen_A_sample_D_de_personal container=0x5555561450f0/Calendar ocs=/Users/sarah.ince-kemen@sample.de/Calendar/personal>", "<0x555556160980[SOGoAppointmentFolder]: name=svetlana_D_iliaeva_A_sample_D_de_personal container=0x5555561450f0/Calendar ocs=/Users/svetlana.iliaeva@sample.de/Calendar/personal>", "<0x55555617e3d0[SOGoAppointmentFolder]: name=uwe_D_dannert_A_sample_D_de_personal container=0x5555561450f0/Calendar ocs=/Users/uwe.dannert@sample.de/Calendar/personal>", "<0x555555ea1080[SOGoAppointmentFolder]: name=vera_D_bausch_A_sample_D_de_personal container=0x5555561450f0/Calendar ocs=/Users/vera.bausch@sample.de/Calendar/personal>", "<0x5555561dd4e0[SOGoAppointmentFolder]: name=volker_D_brenn_A_sample_D_de_personal container=0x5555561450f0/Calendar ocs=/Users/volker.brenn@sample.de/Calendar/personal>", "svetlana_D_iliaeva_A_sample_D_de_AE6-5755F280-1-4092D880", "<0x5555561d2610[SOGoWebAppointmentFolder]: name=6420-57583380-1-75E74100 container=0x5555561450f0/Calendar ocs=/Users/jochen.becker-gruell@sample.de/Calendar/6420-57583380-1-75E74100>", "<0x555556184910[SOGoWebAppointmentFolder]: name=641E-57583400-1-1A80C240 container=0x5555561450f0/Calendar ocs=/Users/jochen.becker-gruell@sample.de/Calendar/641E-57583400-1-1A80C240>", "<0x555556175a40[SOGoWebAppointmentFolder]: name=6420-57583400-3-75E74100 container=0x5555561450f0/Calendar ocs=/Users/jochen.becker-gruell@sample.de/Calendar/6420-57583400-3-75E74100>")
(gdb) po folderName
Cannot access memory at address 0x0
(gdb) po folder
svetlana_D_iliaeva_A_sample_D_de_AE6-5755F280-1-4092D880
(gdb) po NSStringFromClass([folder class])
GSMutableString

Dirk Egert

Dirk Egert

2016-06-09 12:21

reporter   ~0010343

Last edited: 2016-06-09 12:23

Tomorrow I will tell you how I fixed the problem - but I think it's still a bug and should be fixed in the code.

ludovic

ludovic

2016-06-09 13:27

administrator   ~0010344

No need, found and fixed the bug.

Related Changesets

sogo: master 0b1e7ad8

2016-06-09 13:26:22

ludovic

Details Diff
(fix) properly handle sorted/deleted calendars (fixes 0003723) Affected Issues
0003723
mod - NEWS Diff File
mod - UI/Scheduler/UIxCalendarSelector.m Diff File

Issue History

Date Modified Username Field Change
2016-06-09 06:44 Dirk Egert New Issue
2016-06-09 07:09 ludovic Note Added: 0010324
2016-06-09 07:10 ludovic Severity major => minor
2016-06-09 07:16 Dirk Egert Note Added: 0010325
2016-06-09 07:16 ludovic Note Added: 0010326
2016-06-09 07:42 Dirk Egert Note Added: 0010327
2016-06-09 07:54 ludovic Note Added: 0010328
2016-06-09 08:01 Dirk Egert Note Added: 0010329
2016-06-09 08:20 ludovic Note Added: 0010330
2016-06-09 08:22 ludovic Note Added: 0010331
2016-06-09 08:33 ludovic Note Added: 0010332
2016-06-09 08:34 Dirk Egert Note Added: 0010333
2016-06-09 08:36 Dirk Egert Note Added: 0010334
2016-06-09 08:41 Dirk Egert Note Added: 0010335
2016-06-09 09:33 Dirk Egert Note Edited: 0010335
2016-06-09 10:41 ludovic Note Added: 0010336
2016-06-09 11:07 Dirk Egert Note Added: 0010340
2016-06-09 12:21 Dirk Egert Note Added: 0010343
2016-06-09 12:23 Dirk Egert Note Edited: 0010343
2016-06-09 13:27 ludovic Note Added: 0010344
2016-06-09 13:27 ludovic Changeset attached => sogo master 0b1e7ad8
2016-06-09 13:27 ludovic Assigned To => ludovic
2016-06-09 13:27 ludovic Resolution open => fixed
2016-06-09 13:27 ludovic Status new => resolved
2016-06-09 13:27 ludovic Fixed in Version => 3.1.3