View Issue Details

IDProjectCategoryView StatusLast Update
0003720SOGoWeb Mailpublic2016-06-13 10:46
Reportercnaumer Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSRHEL/CentOSOS Version7
Product Version3.1.2 
Fixed in Version3.1.3 
Summary0003720: Delegation function is not working
Description

I (user2) can delegate email to a user (user1) with the appropriate menu but when I login as that user I can not send Email as user1. There is a drop down menu but it only contains the normal (user2) address.
Further the delegation was already set up in SOGo V2 but needs to be setup in V3 again. As we are using the same DB for both version can this lead to problems?

TagsNo tags attached.

Activities

cnaumer

cnaumer

2016-06-08 04:12

reporter   ~0010313

I can reproduce this on the demo site as well.

tfu

tfu

2016-06-13 04:30

reporter   ~0010351

Problem seems to be that SOGoUser.m->mailAccounts ignores identities of delegators.

Related Changesets

sogo: master 4f64994f

2016-06-13 10:44:49

francis

Details Diff
Add missing delegators identities in mail editor

Fixes 0003720
Affected Issues
0003720
mod - NEWS Diff File
mod - SoObjects/SOGo/SOGoUser.h Diff File
mod - SoObjects/SOGo/SOGoUser.m Diff File

Issue History

Date Modified Username Field Change
2016-06-08 04:11 cnaumer New Issue
2016-06-08 04:12 cnaumer Note Added: 0010313
2016-06-13 04:30 tfu Note Added: 0010351
2016-06-13 10:45 francis Changeset attached => sogo master 4f64994f
2016-06-13 10:45 francis Assigned To => francis
2016-06-13 10:45 francis Resolution open => fixed
2016-06-13 10:46 francis Status new => resolved
2016-06-13 10:46 francis Fixed in Version => 3.1.3