View Issue Details

IDProjectCategoryView StatusLast Update
0003697SOGoWeb Mailpublic2016-12-09 15:20
ReporterCliff Assigned Tofrancis  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSRHEL/CentOSOS Version7
Product Version3.1.0 
Fixed in Version3.2.5 
Summary0003697: Web mail filter with cyrillic folder name
Description

After upgrade from Sogo 2 to Sogo 3, when creating new filter with action "move to folder" using cyrillic folder name, it creates wrong sieve script and moves mail to folder with wrong encode.
It was fine in Sogo 2.
Here is screenshot with web mail rule and 2 sieve scripts: first from sogo 2 (correct folder name), second from sogo 3 (incorrect encode).

TagsNo tags attached.

Relationships

has duplicate 0003904 resolvedfrancis Sieve script: fileinto folder with umlauts uses IMAP folder name instead of umlaut 

Activities

Cliff

Cliff

2016-05-26 00:42

reporter  

1.png (38,777 bytes)   
1.png (38,777 bytes)   
lacek

lacek

2016-08-11 08:00

reporter   ~0010597

A small side note: The documentation mentions a SOGoSieveFolderEncoding parameter, which is supposed to alter this behaviour. According to the documentation, when SOGoSieveFolderEncoding is set to UTF-8, no conversion should be made to folders containing special characters.
However, this configuration parameter seems to be ignored by SOGo completely.

Cliff

Cliff

2016-08-24 21:30

reporter   ~0010619

This error was in sogo 2.2.8 and got fixed in 2.2.10 by adding SOGoSieveFolderEncoding parameter.
https://sogo.nu/bugs/view.php?id=2622

But seems got broken in SOGo 3.

Issue History

Date Modified Username Field Change
2016-05-26 00:42 Cliff New Issue
2016-05-26 00:42 Cliff File Added: 1.png
2016-08-11 08:00 lacek Note Added: 0010597
2016-08-24 21:30 Cliff Note Added: 0010619
2016-12-09 15:20 francis Relationship added has duplicate 0003904
2016-12-09 15:20 francis Status new => resolved
2016-12-09 15:20 francis Fixed in Version => 3.2.5
2016-12-09 15:20 francis Resolution open => fixed
2016-12-09 15:20 francis Assigned To => francis