View Issue Details

IDProjectCategoryView StatusLast Update
0003659SOGoWeb Calendarpublic2016-05-09 14:49
Reporterjaragunde Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSFedoraOS Version23
Product Version3.0.2 
Fixed in Version3.1.0 
Summary0003659: Typing a time without semicolon (:) does not properly enter the field
Description

In the web calendar UI, when a date is created or edited, if you type the time fields without semicolon (e.g. 1100 instead of 11:00) you are exposed to an unexpected behavior.

Some users have reported events that disappear from the UI after they are saved, and had to be removed directly from the DB. I could not reproduce that behavior but I could see the time values I typed replaced with the original value of the form after the save operation finished, with little feedback to the user.

Steps To Reproduce
  1. Create an event in the web calendar UI
  2. Click, or tab to the the "From" time field and type "1100", type "1200" in the "To" time field.
  3. Save the task.

Result: task is created but times "1100", "1200" are ignored.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

sogo: master 8cf8ce86

2016-05-09 14:48:22

francis

Details Diff
(js) Improved input parsing of time picker

Fixes 0003659
Affected Issues
0003659
mod - NEWS Diff File
mod - UI/WebServerResources/js/Common/sgTimepicker.directive.js Diff File
mod - UI/WebServerResources/scss/components/timepicker/timepicker.scss Diff File

Issue History

Date Modified Username Field Change
2016-05-06 08:03 jaragunde New Issue
2016-05-09 14:49 francis Changeset attached => sogo master 8cf8ce86
2016-05-09 14:49 francis Assigned To => francis
2016-05-09 14:49 francis Resolution open => fixed
2016-05-09 14:49 francis Status new => resolved
2016-05-09 14:49 francis Fixed in Version => 3.1.0