View Issue Details

IDProjectCategoryView StatusLast Update
0003630SOGowith SOGopublic2016-05-11 12:33
Reporterserdar Assigned Toludovic  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version8 (Jessie)
Fixed in Version3.1.0 
Summary0003630: Error synchronization address book
Description

Hello everyone !

Since I updated Sogo to the version 3.0, I can't synchronise anymore the public address book. I have a message when I try : "no change".
However, the personal address book works.

On the web interface of Sogo, in address book, when I choose someone to show information about him, I have a error message : "Proxy Error" (cf. picture).

Can you help me please ?

Regards,
Serdar

Additional Information

System version :

  • sogo:amd64 3.0.1-1 amd64 a modern and scalable groupware
  • Debian 8.3

Configurations :

sogo.conf :

SOGoProfileURL = "mysql://sogo:pass@127.0.0.1:3306/sogo/sogo_user_profile";
OCSFolderInfoURL = "mysql://sogo:pass@127.0.0.1:3306/sogo/sogo_folder_info";
OCSSessionsFolderURL = "mysql://sogo:pass@127.0.0.1:3306/sogo/sogo_sessions_folder";

SOGoIMAPServer = "imaps://myaddress";
SOGoSieveServer = "sieve://myaddress";
SOGoSMTPServer = myaddress;
SOGoMailDomain = example.com;
SOGoMailingMechanism = smtp;

SOGoAppointmentSendEMailNotifications = YES;
SOGoFoldersSendEMailNotifications = NO;
SOGoPasswordChangeEnabled = NO;

SOGoUserSources = (
{
type = ldap;
CNFieldName = cn;
UIDFieldName = uid;
IDFieldName = mail; // first field of the DN for direct binds
bindFields = (uid, mail, cn); // array of fields to use for indirect binds
baseDN = "dc=example,dc=com";
bindAsCurrentUser= YES;
filter = "(o='example' OR ou='example' OR ou='sogo')";
MultipleBookingsFieldName = "MultipleBookings";
KindFieldName = "Kind";
canAuthenticate = YES;
displayName = "Shared Addresses";
hostname = ldap://myldap:389;
id = public;
isAddressBook = YES;
IMAPLoginFieldName = mail;
}
);

SOGoCalendarDefaultRoles = (PublicViewer,ConfidentialDAndTViewer,PrivateDAndTViewer);

SOGoVacationEnabled = YES;
SOGoSieveScriptsEnabled = YES;
SOGoLoginModule = Calendar;

SOGoLanguage = French;
SOGoTimeZone = Europe/Paris;
SOGoSuperUsernames = (myuser);
WOPidFile = "/var/run/sogo/sogo.pid";

SOGo.conf

Alias /SOGo.woa/WebServerResources/ \
/usr/lib/GNUstep/SOGo/WebServerResources/
Alias /SOGo/WebServerResources/ \
/usr/lib/GNUstep/SOGo/WebServerResources/

ErrorLog /var/log/apache2/sogo.example.com-error.log
LogLevel warn

<Directory /usr/lib/GNUstep/SOGo/>
AllowOverride None

&lt;IfVersion &lt; 2.4>
    Order deny,allow
    Allow from all
&lt;/IfVersion>
&lt;IfVersion >= 2.4>
    Require all granted
&lt;/IfVersion>

&lt;IfModule expires_module>
  ExpiresActive On
  ExpiresDefault &quot;access plus 1 year&quot;
&lt;/IfModule>

</Directory>

ProxyRequests Off
SetEnv proxy-nokeepalive 1
ProxyPreserveHost On

ProxyPass /SOGo http://127.0.0.1:20000/SOGo retry=0

Proxy http://127.0.0.1:20000/SOGo>
RequestHeader set "x-webobjects-server-port" "443"
RequestHeader set "x-webobjects-server-name" "sogo.example.com"
RequestHeader set "x-webobjects-server-url" "https://sogo.example.com&quot;

RequestHeader unset "x-webobjects-remote-user"
RequestHeader set "x-webobjects-server-protocol" "HTTP/1.0"
AddDefaultCharset UTF-8
Order allow,deny
Allow from all
</Proxy>

RewriteEngine On
RewriteRule ^/.well-known/caldav /SOGo/dav [R,L]
RewriteRule ^/.well-known/carddav /SOGo/dav [R,L]

TagsNo tags attached.

Activities

serdar

serdar

2016-04-11 12:25

reporter  

contacts.jpg (90,823 bytes)   
contacts.jpg (90,823 bytes)   
Christian Mack

Christian Mack

2016-04-12 03:25

developer   ~0009962

Did you reinstall SOPE?

serdar

serdar

2016-04-12 05:10

reporter   ~0009963

Thank you for your help.
Yes I reinstalled SOPE.
With another serveur Debian 8, I tried to install directly Sogo v3 and I had the same problem.

Christian Mack

Christian Mack

2016-04-12 05:35

developer   ~0009964

By default global LDAP address books are not listed. You only can search in those.
You can change that by setting within your SOGoUserSources:
listRequiresDot = NO;

This should only be done for small user base, because it will be synchronized to all mobiles too.

But that does not explain the proxy error.
Do you get any error messages in your sogo.log while trying to display the details?

serdar

serdar

2016-04-13 04:39

reporter   ~0009969

This is the log when I'm trying to get addresse book from Thunderbird :

Apr 12 18:23:20 sogod [30231]: <0x0x7f7585ae6900[WOWatchDog]> child spawned with pid 30274
Apr 12 18:23:20 sogod [30231]: <0x0x7f7585ae6900[WOWatchDog]> child spawned with pid 30276
Apr 12 18:23:20 sogod [30231]: <0x0x7f7585ae6900[WOWatchDog]> child spawned with pid 30278
Apr 12 18:23:35 sogod [30271]: |SOGo| starting method 'PROPFIND' on uri '/SOGo/dav/myname/Contacts/public/'
Apr 12 18:23:35 sogod [30271]: <0x0x7f7585d5c930[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
Apr 12 18:23:35 sogod [30271]: <0x0x7f7585d5c930[SOGoCache]> Using host(s) 'localhost' as server(s)
Apr 12 18:23:35 sogod [30271]: [obj-dav-dispatch] constructed root-url:
Apr 12 18:23:35 sogod [30271]: |SOGo| constructed root-url: /SOGo/
Apr 12 18:23:35 sogod [30271]: |SOGo| setting root-url in context: /SOGo/dav/
Apr 12 18:23:35 sogod [30271]: |SOGo| ROOT baseURL(no container, name=(null)):
own: /SOGo/dav/
Apr 12 18:23:35 sogod [30271]: <0x8581DEE0[SOGoUserFolder]:myname> baseURL: name=myname (container=SOGo)
container: /SOGo -- https://sogo-preprod.int.example.fr/SOGo/dav/myname/Contacts/public/
own: /SOGo/dav/myname
Apr 12 18:23:35 sogod [30271]: |SOGo| using root-url from context: /SOGo/dav/
Apr 12 18:23:35 sogod [30271]: |SOGo| ROOT baseURL(no container, name=(null)):
own: /SOGo/dav/
Apr 12 18:23:35 sogod [30271]: <0x8581DEE0[SOGoUserFolder]:myname> baseURL: name=myname (container=SOGo)
container: /SOGo -- https://sogo-preprod.int.example.fr/SOGo/dav/myname/Contacts/public/
own: /SOGo/dav/myname
Apr 12 18:23:35 sogod [30271]: <0x85846320[SOGoContactFolders]:Contacts> baseURL: name=Contacts (container=SOGoUserFolder)
container: /SOGo/dav/myname/
own: /SOGo/dav/myname/Contacts
Apr 12 18:23:35 sogod [30271]: |SOGo| using root-url from context: /SOGo/dav/
Apr 12 18:23:35 sogod [30271]: |SOGo| ROOT baseURL(no container, name=(null)):
own: /SOGo/dav/
Apr 12 18:23:35 sogod [30271]: <0x8581DEE0[SOGoUserFolder]:myname> baseURL: name=myname (container=SOGo)
container: /SOGo -- https://sogo-preprod.int.example.fr/SOGo/dav/myname/Contacts/public/
own: /SOGo/dav/myname
Apr 12 18:23:35 sogod [30271]: |SOGo| using root-url from context: /SOGo/dav/
Apr 12 18:23:35 sogod [30271]: |SOGo| ROOT baseURL(no container, name=(null)):
own: /SOGo/dav/
Apr 12 18:23:35 sogod [30271]: <0x8581DEE0[SOGoUserFolder]:myname> baseURL: name=myname (container=SOGo)
container: /SOGo -- https://sogo-preprod.int.example.fr/SOGo/dav/myname/Contacts/public/
own: /SOGo/dav/myname
Apr 12 18:23:35 sogod [30271]: <0x85846320[SOGoContactFolders]:Contacts> baseURL: name=Contacts (container=SOGoUserFolder)
container: /SOGo/dav/myname/
own: /SOGo/dav/myname/Contacts
Apr 12 18:23:35 sogod [30271]: <0x85DB1C10[SOGoContactSourceFolder]:public> baseURL: name=public (container=SOGoContactFolders)
container: /SOGo/dav/myname/Contacts/
own: /SOGo/dav/myname/Contacts/public
Apr 12 18:23:35 sogod [30271]: |SOGo| request took 0.013023 seconds to execute
Apr 12 18:23:35 sogod [30271]: 46.218.250.234, 192.168.72.12 "PROPFIND /SOGo/dav/myname/Contacts/public/ HTTP/1.1" 207 1069/175 0.016 - - 2M
Apr 12 18:23:35 sogod [30271]: |SOGo| starting method 'PROPFIND' on uri '/SOGo/dav/myname/Contacts/public/'
Apr 12 18:23:35 sogod [30271]: [obj-dav-dispatch] constructed root-url:
Apr 12 18:23:35 sogod [30271]: <0x0x7f7585dd2f70[NGLdapConnection]> Using ldap_initialize for LDAP URL: ldap://ldap01.int.example.fr:389
2016-04-12 18:23:35.259 sogod[30271] -[NGLdapConnection _searchAtBaseDN:qualifier:attributes:scope:]: search at base '' filter '(objectClass=)' for attrs 'subschemaSubentry'
2016-04-12 18:23:35.260 sogod[30271] -[NGLdapConnection _searchAtBaseDN:qualifier:attributes:scope:]: search at base 'cn=Subschema' filter '(objectClass=
)' for attrs 'objectclasses'
2016-04-12 18:23:35.268 sogod[30271] -[NGLdapConnection _searchAtBaseDN:qualifier:attributes:scope:]: search at base 'dc=example,dc=fr' filter '(&(cn=)(|(o=example)(ou=example)(ou=sogo)))' for attrs 'uid'
Apr 12 18:23:35 sogod [30271]: <0x0x7f7585f4f580[NGLdapConnection]> Using ldap_initialize for LDAP URL: ldap://ldap01.int.example.fr:389
2016-04-12 18:23:35.292 sogod[30271] -[NGLdapConnection _searchAtBaseDN:qualifier:attributes:scope:]: search at base 'dc=example,dc=fr' filter '(uid=sylvain.coti)' for attrs '
'
EXCEPTION: <NSException: 0x7f7585f7b580> NAME:NSInvalidArgumentException REASON:GSInlineArray(instance) does not recognize escapedForCards INFO:(null)
Apr 12 18:23:35 sogod [30231]: <0x0x7f7585abc770[WOWatchDogChild]> child 30271 exited
Apr 12 18:23:35 sogod [30231]: <0x0x7f7585abc770[WOWatchDogChild]> (terminated due to signal 6)
Apr 12 18:23:35 sogod [30231]: <0x0x7f7585ae6900[WOWatchDog]> child spawned with pid 30312
Apr 12 18:23:35 sogod [30312]: |SOGo| starting method 'PROPFIND' on uri '/SOGo/dav/myname/Contacts/public/'
Apr 12 18:23:35 sogod [30312]: <0x0x7f7585ba13a0[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
Apr 12 18:23:35 sogod [30312]: <0x0x7f7585ba13a0[SOGoCache]> Using host(s) 'localhost' as server(s)
Apr 12 18:23:35 sogod [30312]: [obj-dav-dispatch] constructed root-url:
Apr 12 18:23:35 sogod [30312]: <0x0x7f7585dcfbc0[NGLdapConnection]> Using ldap_initialize for LDAP URL: ldap://ldap01.int.example.fr:389
2016-04-12 18:23:35.348 sogod[30312] -[NGLdapConnection _searchAtBaseDN:qualifier:attributes:scope:]: search at base '' filter '(objectClass=)' for attrs 'subschemaSubentry'
2016-04-12 18:23:35.349 sogod[30312] -[NGLdapConnection _searchAtBaseDN:qualifier:attributes:scope:]: search at base 'cn=Subschema' filter '(objectClass=
)' for attrs 'objectclasses'
2016-04-12 18:23:35.356 sogod[30312] -[NGLdapConnection _searchAtBaseDN:qualifier:attributes:scope:]: search at base 'dc=example,dc=fr' filter '(&(cn=)(|(o=example)(ou=example)(ou=sogo)))' for attrs 'uid'
Apr 12 18:23:35 sogod [30312]: <0x0x7f7585f51c10[NGLdapConnection]> Using ldap_initialize for LDAP URL: ldap://ldap01.int.example.fr:389
2016-04-12 18:23:35.377 sogod[30312] -[NGLdapConnection _searchAtBaseDN:qualifier:attributes:scope:]: search at base 'dc=example,dc=fr' filter '(uid=sylvain.coti)' for attrs '
'
EXCEPTION: <NSException: 0x7f7585f7dc10> NAME:NSInvalidArgumentException REASON:GSInlineArray(instance) does not recognize escapedForCards INFO:(null)
Apr 12 18:23:35 sogod [30231]: <0x0x7f7585abc770[WOWatchDogChild]> child 30312 exited
Apr 12 18:23:35 sogod [30231]: <0x0x7f7585abc770[WOWatchDogChild]> (terminated due to signal 6)
Apr 12 18:23:35 sogod [30231]: <0x0x7f7585abc770[WOWatchDogChild]> avoiding to respawn child before 2016-04-12 18:23:40 +0200
Apr 12 18:23:40 sogod [30231]: <0x0x7f7585ae6900[WOWatchDog]> child spawned with pid 30427
root@sogo-preprod:/etc/sogo#

Now the log when I'm trying to display the details :

Apr 12 18:44:57 sogod [1225]: |SOGo| starting method 'GET' on uri '/SOGo/so/myname/Contacts/public/view?asc=1&search=name_or_address&sort=c_cn&value=alexandre'
Apr 12 18:44:57 sogod [1225]: <0x0x7f5a9cada030[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
Apr 12 18:44:57 sogod [1225]: <0x0x7f5a9cada030[SOGoCache]> Using host(s) 'localhost' as server(s)
Apr 12 18:44:57 sogod [1225]: <0x0x7f5a9ce6bd80[NGLdapConnection]> Using ldap_initialize for LDAP URL: ldap://ldap01.intexample.fr:389
2016-04-12 18:44:57.531 sogod[1225] -[NGLdapConnection _searchAtBaseDN:qualifier:attributes:scope:]: search at base '' filter '(objectClass=)' for attrs 'subschemaSubentry'
2016-04-12 18:44:57.532 sogod[1225] -[NGLdapConnection _searchAtBaseDN:qualifier:attributes:scope:]: search at base 'cn=Subschema' filter '(objectClass=
)' for attrs 'objectclasses'
2016-04-12 18:44:57.539 sogod[1225] -[NGLdapConnection _searchAtBaseDN:qualifier:attributes:scope:]: search at base 'dc=example,dc=fr' filter '(&(|(sn=alexandre)(displayname=alexandre)(telephonenumber=alexandre)(mail=alexandre)(cn=alexandre))(|(o=example)(ou=example)(ou=sogo)))' for attrs ''
Apr 12 18:44:57 sogod [1225]: |SOGo| request took 0.044703 seconds to execute
Apr 12 18:44:57 sogod [1225]: 192.168.123.211 "GET /SOGo/so/myname/Contacts/public/view?asc=1&search=name_or_address&sort=c_cn&value=alexandre HTTP/1.1" 200 3243/0 0.047 - - 3M
Apr 12 18:45:03 sogod [1225]: |SOGo| starting method 'GET' on uri '/SOGo/so/myname/Contacts/public/alexandre.beaugosse/view'
Apr 12 18:45:03 sogod [1225]: <0x0x7f5a9ced6cb0[NGLdapConnection]> Using ldap_initialize for LDAP URL: ldap://ldap01.intexample.fr:389
2016-04-12 18:45:03.031 sogod[1225] -[NGLdapConnection _searchAtBaseDN:qualifier:attributes:scope:]: search at base 'dc=example,dc=fr' filter '(uid=alexandre.beaugosse)' for attrs '
'
EXCEPTION: <NSException: 0x7f5a9cf6fcf0> NAME:NSInvalidArgumentException REASON:GSInlineArray(instance) does not recognize canBeConvertedToEncoding: INFO:(null)
Apr 12 18:45:03 sogod [1119]: <0x0x7f5a9cb36830[WOWatchDogChild]> child 1225 exited
Apr 12 18:45:03 sogod [1119]: <0x0x7f5a9cb36830[WOWatchDogChild]> (terminated due to signal 6)
Apr 12 18:45:03 sogod [1119]: <0x0x7f5a9cb80900[WOWatchDog]> child spawned with pid 1231

Option listRequiresDot change nothing.
Actually, I us this url to get adresse book with thunderbird : https://sogo.example.fr/SOGo/dav/myname/Contacts/public/

ludovic

ludovic

2016-04-14 09:19

administrator   ~0009981

Use the debugger to create a stack trace:

http://sogo.nu/nc/support/faq/article/how-do-i-debug-sogo-2.html

serdar

serdar

2016-04-25 09:02

reporter  

1.sogo-installation.txt (919 bytes)   
#---------- SOGo installation ----------#

echo "deb http://http.debian.net/debian jessie-backports main" > /etc/apt/sources.list.d/backports.list

echo -e "deb http://inverse.ca/debian-v3 jessie jessie\n\
deb-src http://inverse.ca/debian-v3 jessie jessie" > /etc/apt/sources.list.d/SOGo.list

apt-key adv --keyserver keys.gnupg.net --recv-key 0x810273C4

apt-get update
apt-get install mysql-server sogo sope4.9-gdl1-mysql apache2 libapache2-mod-wsgi memcached

mysqladmin -u root -pazerty create sogo;
mysql -u root -pazerty -e "CREATE USER 'sogo'@'localhost' IDENTIFIED BY 'sogo';"
mysql -u root -pazerty -e "GRANT ALL PRIVILEGES ON sogo.* TO 'sogo'@'localhost';"
mysqladmin -u root -pazerty flush-privileges

a2enmod headers
a2enmod proxy
a2enmod proxy_http
a2enmod ssl
a2enmod rewrite
a2dismod reqtimeout

a2ensite default-ssl.conf

/etc/init.d/apache2 restart; /etc/init.d/sogo restart
1.sogo-installation.txt (919 bytes)   
serdar

serdar

2016-04-25 09:02

reporter  

2.sogo.conf.txt (2,034 bytes)   
{
  /* Database configuration (mysql:// or mysql://) */
  SOGoProfileURL = "mysql://sogo:sogo@localhost:3306/sogo/sogo_user_profile";
  OCSFolderInfoURL = "mysql://sogo:sogo@localhost:3306/sogo/sogo_folder_info";
  OCSSessionsFolderURL = "mysql://sogo:sogo@localhost:3306/sogo/sogo_sessions_folder";

  /* Mail */
  SOGoIMAPServer = "imaps://mail.example.fr:993";
  SOGoSieveServer = "sieve://mail.example.fr:4190";
  SOGoSMTPServer = mx.example.fr;
  SOGoMailDomain = example.fr;
  SOGoMailingMechanism = smtp;

  /* Notifications */
  SOGoAppointmentSendEMailNotifications = YES;
  SOGoFoldersSendEMailNotifications = NO;

  /* Authentication */
  SOGoPasswordChangeEnabled = NO;

  /* LDAP authentication example */
  SOGoUserSources = (
    {
      type = ldap;
      CNFieldName = cn;
      UIDFieldName = uid;
      IDFieldName =mail; // first field of the DN for direct binds
      bindFields = (uid, mail, cn); // array of fields to use for indirect binds
      baseDN = "dc=example,dc=fr";
      bindAsCurrentUser= YES;
      filter = "(o='example' OR ou='example' OR ou='sogo')";
      MultipleBookingsFieldName = "MultipleBookings";
      KindFieldName = "Kind";
      canAuthenticate = YES;
      displayName = "Shared Addresses";
      hostname = ldap://ldap.example.fr:389;
      id = public;
      isAddressBook = YES;
      IMAPLoginFieldName = mail;
    }
  );

  /* Web Interface */
  SOGoVacationEnabled = YES;
  SOGoSieveScriptsEnabled = YES;
  SOGoLoginModule = Calendar;
  SOGoCalendarDefaultRoles = (PublicViewer,ConfidentialDAndTViewer,PrivateDAndTViewer);

  /* General */
  SOGoLanguage = French;
  SOGoTimeZone = Europe/Paris;
  SOGoSuperUsernames = (serdar); // This is an array - keep the parens!
  WOPidFile = "/var/run/sogo/sogo.pid";
  
  /* Debug */
  SOGoDebugRequests = YES;
  SoDebugBaseURL = YES;
  ImapDebugEnabled = YES;
  LDAPDebugEnabled = YES;
  PGDebugEnabled = YES;
  MySQL4DebugEnabled = YES;
  SOGoUIxDebugEnabled = YES;
  WODontZipResponse = YES;
  WOLogFile = /var/log/sogo/sogo.log;
}
2.sogo.conf.txt (2,034 bytes)   
serdar

serdar

2016-04-25 09:02

reporter  

3.SOGo-apache2.conf.txt (2,910 bytes)   
Alias /SOGo.woa/WebServerResources/ \
      /usr/lib/GNUstep/SOGo/WebServerResources/
Alias /SOGo/WebServerResources/ \
      /usr/lib/GNUstep/SOGo/WebServerResources/

<Directory /usr/lib/GNUstep/SOGo/>
    AllowOverride None

    <IfVersion < 2.4>      
        Order deny,allow
        Allow from all
    </IfVersion>
    <IfVersion >= 2.4>
        Require all granted
    </IfVersion>

    # Explicitly allow caching of static content to avoid browser specific behavior.
    # A resource's URL MUST change in order to have the client load the new version.
    <IfModule expires_module>
      ExpiresActive On
      ExpiresDefault "access plus 1 year"
    </IfModule>
</Directory>

## Uncomment the following to enable proxy-side authentication, you will then
## need to set the "SOGoTrustProxyAuthentication" SOGo user default to YES and
## adjust the "x-webobjects-remote-user" proxy header in the "Proxy" section
## below.
#
## For full proxy-side authentication:
#<Location /SOGo>
#  AuthType XXX
#  Require valid-user
#  SetEnv proxy-nokeepalive 1
#  Allow from all
#</Location>
#
## For proxy-side authentication only for CardDAV and GroupDAV from external
## clients:
#<Location /SOGo/dav>
#  AuthType XXX
#  Require valid-user
#  SetEnv proxy-nokeepalive 1
#  Allow from all
#</Location>

ProxyRequests Off
SetEnv proxy-nokeepalive 1
ProxyPreserveHost On

# When using CAS, you should uncomment this and install cas-proxy-validate.py
# in /usr/lib/cgi-bin to reduce server overloading
#
# ProxyPass /SOGo/casProxy http://localhost/cgi-bin/cas-proxy-validate.py
# <Proxy http://localhost/app/cas-proxy-validate.py>
#   Order deny,allow
#   Allow from your-cas-host-addr
# </Proxy>

# Enable to use Microsoft ActiveSync support
# Note that you MUST have many sogod workers to use ActiveSync.
# See the SOGo Installation and Configuration guide for more details.
#
#ProxyPass /Microsoft-Server-ActiveSync \
# http://127.0.0.1:20000/SOGo/Microsoft-Server-ActiveSync \
# retry=60 connectiontimeout=5 timeout=360

ProxyPass /SOGo http://127.0.0.1:20000/SOGo retry=0

<Proxy http://127.0.0.1:20000/SOGo>
## adjust the following to your configuration
  RequestHeader set "x-webobjects-server-port" "443"
  RequestHeader set "x-webobjects-server-name" "192.168.123.115"
  RequestHeader set "x-webobjects-server-url" "https://192.168.123.115"

## When using proxy-side autentication, you need to uncomment and
## adjust the following line:
  RequestHeader unset "x-webobjects-remote-user"
#  RequestHeader set "x-webobjects-remote-user" "%{REMOTE_USER}e" env=REMOTE_USER

  RequestHeader set "x-webobjects-server-protocol" "HTTP/1.0"

  AddDefaultCharset UTF-8

  Order allow,deny
  Allow from all
</Proxy>

# For Apple autoconfiguration
<IfModule rewrite_module>
  RewriteEngine On
  RewriteRule ^/.well-known/caldav/?$ /SOGo/dav [R=301]
  RewriteRule ^/.well-known/carddav/?$ /SOGo/dav [R=301]
</IfModule>

3.SOGo-apache2.conf.txt (2,910 bytes)   
serdar

serdar

2016-04-25 09:03

reporter  

stack trace.txt (5,345 bytes)   
sogo@sogo:~$ ps -ef |grep sogo
root       2243   1480  0 14:48 pts/0    00:00:00 su -s /bin/bash - sogo
sogo       2244   2243  0 14:48 pts/0    00:00:00 -su
sogo       2326   2244  0 14:57 pts/0    00:00:00 ps -ef
sogo       2327   2244  0 14:57 pts/0    00:00:00 grep sogo
sogo@sogo:~$
sogo@sogo:~$ gdb --args /usr/sbin/sogod -WOUseWatchDog NO -WONoDetach YES -WOPort 20000 -WOWorkersCount 1 -WOLogFile - -WOPidFile /tmp/sogo.pid
GNU gdb (Debian 7.7.1+dfsg-5) 7.7.1
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/sbin/sogod...Reading symbols from /usr/lib/debug//usr/sbin/sogod...done.
done.
(gdb)
(gdb) run
Starting program: /usr/sbin/sogod -WOUseWatchDog NO -WONoDetach YES -WOPort 20000 -WOWorkersCount 1 -WOLogFile - -WOPidFile /tmp/sogo.pid
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Apr 25 14:57:59 sogod [2356]: version 3.0.2 (build @shiva.inverse 201603051728) -- starting
Apr 25 14:57:59 sogod [2356]: vmem size check enabled: shutting down app when vmem > 384 MB
Apr 25 14:57:59 sogod [2356]: <0x0x555555a681e0[SOGoProductLoader]> SOGo products loaded from '/usr/lib/GNUstep/SOGo':
Apr 25 14:57:59 sogod [2356]: <0x0x555555a681e0[SOGoProductLoader]>   SchedulerUI.SOGo, AdministrationUI.SOGo, MainUI.SOGo, MailPartViewers.SOGo, ContactsUI.SOGo, CommonUI.SOGo, Mailer.SOGo                                                , PreferencesUI.SOGo, Contacts.SOGo, Appointments.SOGo, MailerUI.SOGo
[New Thread 0x7fffe8eec700 (LWP 2360)]
[Thread 0x7fffe8eec700 (LWP 2360) exited]
2016-04-25 14:57:59.487 sogod[2356] MySQL4 connection established 0x0x555555c59d60
2016-04-25 14:57:59.487 sogod[2356] MySQL4 channel 0x0x555555b11d20 opened (connection=0x0x555555c59d60,sogo)
2016-04-25 14:57:59.487 sogod[2356] <MySQL4Channel[0x0x555555b11d20] connection=0x0x555555c59d60> SQL: SELECT count(*) FROM sogo_user_profile;
2016-04-25 14:57:59.488 sogod[2356] <MySQL4Channel[0x0x555555b11d20] connection=0x0x555555c59d60>   query has results, entering fetch-mode.
2016-04-25 14:57:59.488 sogod[2356] <MySQL4Channel[0x0x555555b11d20] connection=0x0x555555c59d60> SQL: SELECT count(*) FROM sogo_folder_info;
2016-04-25 14:57:59.489 sogod[2356] <MySQL4Channel[0x0x555555b11d20] connection=0x0x555555c59d60>   query has results, entering fetch-mode.
2016-04-25 14:57:59.490 sogod[2356] <MySQL4Channel[0x0x555555b11d20] connection=0x0x555555c59d60> SQL: SELECT count(*) FROM sogo_sessions_folder;
2016-04-25 14:57:59.491 sogod[2356] <MySQL4Channel[0x0x555555b11d20] connection=0x0x555555c59d60>   query has results, entering fetch-mode.
Apr 25 14:57:59 sogod [2356]: |SOGo| WOHttpAdaptor listening on address *:20000

^C
Program received signal SIGINT, Interrupt.
0x00007ffff45b6d3d in poll () at ../sysdeps/unix/syscall-template.S:81
81      ../sysdeps/unix/syscall-template.S: Aucun fichier ou dossier de ce type.
(gdb) b
Breakpoint 1 at 0x7ffff45b6d3d: file ../sysdeps/unix/syscall-template.S, line 81.
(gdb) b abort
Breakpoint 2 at 0x7ffff450d300: abort. (2 locations)
(gdb) c
Continuing.

Breakpoint 1, 0x00007ffff45b6d3d in poll () at ../sysdeps/unix/syscall-template.S:81
81      in ../sysdeps/unix/syscall-template.S
(gdb)bt
#0  0x00007ffff45b6d3d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007ffff555411e in poll (__timeout=29955, __nfds=<optimized out>, __fds=<optimized out>) at /usr/include/x86_64-linux-gnu/bits/poll2.h:46
#2  -[GSRunLoopCtxt pollUntil:within:] (self=<optimized out>, _cmd=0x7ffff5939900 <_OBJC_SELECTOR_TABLE+1216>, milliseconds=29955, contexts=<optimized out>) at GSRunLoopCtxt.m:430
#3  0x00007ffff5492840 in -[NSRunLoop acceptInputForMode:beforeDate:] (self=0x555555b6aa00, _cmd=0x2, mode=0x7ffff593a770 <_OBJC_INSTANCE_2>, limit_date=0x555555b50fb0) at NSRunLoop.m:1217
#4  0x00007ffff5492cf2 in -[NSRunLoop runMode:beforeDate:] (self=0x555555b6aa00, _cmd=0x555555b5a3b0, mode=0x7ffff593a770 <_OBJC_INSTANCE_2>, date=0x555555b34cd0) at NSRunLoop.m:1288
#5  0x00007ffff6c4a71e in -[WOCoreApplication run] (self=0x555555b6b120, _cmd=<optimized out>) at WOCoreApplication.m:584
#6  0x000055555555afc1 in -[SOGo run] (self=0x555555b6b120, _cmd=0x7ffff6f823d0 <_OBJC_SELECTOR_TABLE+208>) at SOGo.m:268
#7  0x00007ffff6c6ef54 in WOApplicationMain (_appClassName=_appClassName@entry=0x555555760940 <_OBJC_INSTANCE_0>, argc=argc@entry=13, argv=argv@entry=0x7fffffffec18)
    at WOApplicationMain.m:42
#8  0x00007ffff6c8ac8f in WOWatchDogApplicationMain (appName=0x555555760940 <_OBJC_INSTANCE_0>, argc=13, argv=0x7fffffffec18) at WOWatchDogApplicationMain.m:1043
#9  0x000055555555a279 in main (argc=13, argv=0x7fffffffec18, env=0x7fffffffec88) at sogod.m:51
(gdb)
stack trace.txt (5,345 bytes)   
serdar

serdar

2016-04-25 09:48

reporter   ~0010011

I uploaded 4 files.
1 to 3, to reproduce my install.
Then another file "stack trace.txt" which is what did you ask.

serdar

serdar

2016-05-11 09:04

reporter   ~0010103

I found where come from errors.
On my ldap, when a user has more than one organizational unit, I have a sogo proxy error.
But if I delete all organizational unit and leave only one it's ok.
Is it a bug ?

ludovic

ludovic

2016-05-11 09:11

administrator   ~0010104

Certainly, let me look into this.

ludovic

ludovic

2016-05-11 09:14

administrator   ~0010105

Prior I look into this, shot the complete LDIF output of a user that has two organizational units.

ludovic

ludovic

2016-05-11 09:19

administrator   ~0010106

Nevermind, I can reproduce the issue. Let me fix that.

ludovic

ludovic

2016-05-11 12:33

administrator   ~0010108

https://github.com/inverse-inc/sogo/commit/b5b9d596f0638c89d3815a594cf6c79d13a7c422

Also fixed for 2.3.11

Issue History

Date Modified Username Field Change
2016-04-11 12:25 serdar New Issue
2016-04-11 12:25 serdar File Added: contacts.jpg
2016-04-12 03:25 Christian Mack Note Added: 0009962
2016-04-12 05:10 serdar Note Added: 0009963
2016-04-12 05:35 Christian Mack Note Added: 0009964
2016-04-13 04:39 serdar Note Added: 0009969
2016-04-14 09:19 ludovic Note Added: 0009981
2016-04-25 09:02 serdar File Added: 1.sogo-installation.txt
2016-04-25 09:02 serdar File Added: 2.sogo.conf.txt
2016-04-25 09:02 serdar File Added: 3.SOGo-apache2.conf.txt
2016-04-25 09:03 serdar File Added: stack trace.txt
2016-04-25 09:48 serdar Note Added: 0010011
2016-05-11 09:04 serdar Note Added: 0010103
2016-05-11 09:11 ludovic Note Added: 0010104
2016-05-11 09:14 ludovic Note Added: 0010105
2016-05-11 09:19 ludovic Note Added: 0010106
2016-05-11 12:33 ludovic Project SOGo Connector => SOGo
2016-05-11 12:33 ludovic Note Added: 0010108
2016-05-11 12:33 ludovic Status new => resolved
2016-05-11 12:33 ludovic Fixed in Version => 3.1.0
2016-05-11 12:33 ludovic Resolution open => fixed
2016-05-11 12:33 ludovic Assigned To => ludovic