View Issue Details

IDProjectCategoryView StatusLast Update
0003611SOGoWeb Preferencespublic2016-04-06 14:56
Reporternfg Assigned Toludovic  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.3.9 
Fixed in Version2.3.10 
Summary0003611: Missing calendar_category_labels for norwegian bokmål and nynorsk causes "NSRangeException REASON:Index 19 is out of range 19"
Description

Using NorwegianBokmal or NorwegianNynorsk translation causes a 500 server error on the Preferences page.

From the sogo.log:

EXCEPTION: <NSException: 0x7f0a9e4a37b8> NAME:NSRangeException REASON:Index 19 is out of range 19 (in 'objectAtIndex:') INFO:{Array = (Diverse, Favoritter, "F\U00F8dselsdager", Heligdager, "Id\U00E9er", Jobb, Konkurranser, Kunder, Ledighet, "Leverand\U00
F8rer", "M\U00F8ter", "Oppf\U00F8lging", Personlig, Presentasjoner, Reiser, Prosjekt, Status, Telefonsamtaler, "\U00C6rend"); Count = 19; Index = 19; }

It is caused by calendar_category_labels in UI/PreferencesUI/NorwegianBokmal.lproj/Localizable.strings only having 19 categories, when 22 categories are expected.

References to the code:

This is the same as bug 0003559

TagsNo tags attached.

Activities

francis

francis

2016-04-01 09:55

administrator   ~0009914

Could you update the translations on Transifex?

https://www.transifex.com/inverse/sogo/

Thanks!

nfg

nfg

2016-04-01 11:03

reporter   ~0009915

I have updated the translation on Transifex for both Norwegian Bokmål (nb) and Norwegian Nynorsk (nn).

ludovic

ludovic

2016-04-06 14:56

administrator   ~0009931

Should all be good in v2.3.10.

Issue History

Date Modified Username Field Change
2016-04-01 09:43 nfg New Issue
2016-04-01 09:55 francis Note Added: 0009914
2016-04-01 11:03 nfg Note Added: 0009915
2016-04-06 14:56 ludovic Note Added: 0009931
2016-04-06 14:56 ludovic Status new => resolved
2016-04-06 14:56 ludovic Fixed in Version => 2.3.10
2016-04-06 14:56 ludovic Resolution open => fixed
2016-04-06 14:56 ludovic Assigned To => ludovic