View Issue Details

IDProjectCategoryView StatusLast Update
0003587SOGoBackend Generalpublic2016-03-18 12:44
Reporterjanne Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSUbuntuOS Version14.04 LTS
Product Version3.0.2 
Fixed in Version3.1.0 
Summary0003587: Proxy Error when trying to login after upgrade of SOGo from version 2.3.9-1
Description

My SOGo installation worked without problems before the upgrade.

After having upgraded to version 3.0.2 and when accessing SOGo using FireFox from my Ubuntu Desktop 14.04 LTS machine, I get the SOGo login page, but when logging in, the browser returns 502 Proxy Error with the message:

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /SOGo/so/janne/Calendar/view.

Reason: Error reading from remote server

Downgrading to SOGo 2.3.9-1 makes SOGo work again.

After the error I see the following indications in the server logs:

In the apache error log:

[Thu Mar 17 11:52:05.100300 2016] [proxy_http:error] [pid 18495:tid 139862548129536] (20014)Internal error: [client 83.251.72.18:54508] AH01102: error reading status line from remote server 127.0.0.1:20000
[Thu Mar 17 11:52:05.100385 2016] [proxy:error] [pid 18495:tid 139862548129536] [client 83.251.72.18:54508] AH00898: Error reading from remote server returned by /SOGo/so/janne/Calendar/view

In the sogo log:

Mar 17 11:52:04 sogod [18995]: |SOGo| starting method 'GET' on uri '/SOGo/so/janne/Calendar/view'
Mar 17 11:52:04 sogod [18995]: <0x0x7fd9e9061238[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
Mar 17 11:52:04 sogod [18995]: <0x0x7fd9e9061238[SOGoCache]> Using host(s) 'localhost' as server(s)
Mar 17 11:52:04 sogod [18995]: [WARN] <0x0x7fd9e9115a58[SOGoWebDAVAclManager]> entry '{DAV:}write' already exists in DAV permissions table
Mar 17 11:52:04 sogod [18995]: [WARN] <0x0x7fd9e9115a58[SOGoWebDAVAclManager]> entry '{DAV:}write-properties' already exists in DAV permissions table
Mar 17 11:52:04 sogod [18995]: [WARN] <0x0x7fd9e9115a58[SOGoWebDAVAclManager]> entry '{DAV:}write-content' already exists in DAV permissions table
Mar 17 11:52:04 sogod [18995]: [ERROR] <0x0x7fd9e8c10018[NGBundleManager]> could not create bundle for path: '/usr/share/GNUstep/Libraries/gnustep-base/Versions/1.24/Resources/SSL.bundle'
Mar 17 11:52:04 sogod [18995]: [WARN] <0x0x7fd9e59083c0[WOxElemBuilder]> could not locate builders: WOxExtElemBuilder,WOxExtElemBuilder
EXCEPTION: <NSException: 0x7fd9e95125a8> NAME:NSInvalidArgumentException REASON:init with obj and key arrays of different sizes INFO:(null)
Mar 17 11:52:05 sogod [18984]: <0x0x7fd9e8e00658[WOWatchDogChild]> child 18995 exited
Mar 17 11:52:05 sogod [18984]: <0x0x7fd9e8e00658[WOWatchDogChild]> (terminated due to signal 6, coredump)
Mar 17 11:52:05 sogod [18984]: <0x0x7fd9e8c12388[WOWatchDog]> child spawned with pid 19124

My sogo.conf contains:

{
SOGoLanguage = "Swedish";
SOGoTimeZone = "Europe/Stockholm";
SOGoPageTitle = "My SOGo";
SOGoEnableDomainBasedUID = NO;
SOGoMailDomain = "xxx.yyy.zzz";
SOGoSuperUsernames = (
"sogoadmin"
);
SOGoUserSources = (
{
id = "directory";
type = "sql";
viewURL = "postgresql://sogo:password1@127.0.0.1:5432/sogo_db/sogo_users";
canAuthenticate = YES;
isAddressBook = YES;
displayName = "SOGo Users";
userPasswordAlgorithm = "md5";
}
);
SOGoProfileURL = "postgresql://sogo:password@127.0.0.1:5432/sogo_db/sogo_user_profile";
OCSFolderInfoURL = "postgresql://sogo:password@127.0.0.1:5432/sogo_db/sogo_folder_info";
OCSSessionsFolderURL = "postgresql://sogo:password@127.0.0.1:5432/sogo_db/sogo_sessions_folder";
SOGoIMAPServer = "127.0.0.1";
SOGoMailingMechanism = "smtp";
SOGoSMTPServer = "127.0.0.1";
}

Additional Information

I have to remove the 0xHIGHFLYxSOGo cookie to get back to the SOGo login page.

TagsNo tags attached.

Activities

ludovic

ludovic

2016-03-17 07:15

administrator   ~0009769

Last edited: 2016-03-17 07:15

View 2 revisions

What if you try with: SOGoLanguage = "English"; ?

janne

janne

2016-03-17 07:20

reporter   ~0009770

I did that and restarted SOGo. I get the same error :-(

ludovic

ludovic

2016-03-17 07:29

administrator   ~0009771

Have you also tried to select English from the login window?

janne

janne

2016-03-17 07:37

reporter   ~0009772

Last edited: 2016-03-17 07:44

View 3 revisions

Just did, still having SOGoLanguage = "English" in sogo.conf.

Before I changed, the login page showed "Choose ...". Afterwards it showed "English".

I then logged in successfully and could see my calendar :-)

After logging out the login page showed "Choose ..." again.

I then tried with choosing Swedish (Svenska) on the login page. Got Proxy Error.
Then I changed to SOGoLanguage = "Swedish" in sogo.conf and restarted sogo.
Choosed Svenska at the login page. Got Proxy Error.

ludovic

ludovic

2016-03-17 07:39

administrator   ~0009773

Humm not sure I fully understand.

Can you reproduce in very specific steps which configuration works, and which one doesn't?

It'll help us eradicate this bug.

janne

janne

2016-03-17 07:50

reporter   ~0009774

Last edited: 2016-03-17 08:06

View 3 revisions

I not sure if you saw my updates to my previous comment.

I made one more test. I changed back to to SOGoLanguage = "Swedish", restarted sogo, and then choosed English at the login page. Login was successful.

Also tried with German and French at the login page. Login was successful.

Summarizing: Using the sogo.conf in the Description above, and selecting Svenska at the login page results in Proxy error, selecting English, French, German (and some more languages I tried) works.

ludovic

ludovic

2016-03-18 12:44

administrator   ~0009795

Switch to the v3 nightly builds or wait for 3.0.3.

Issue History

Date Modified Username Field Change
2016-03-17 07:13 janne New Issue
2016-03-17 07:15 ludovic Note Added: 0009769
2016-03-17 07:15 ludovic Note Edited: 0009769 View Revisions
2016-03-17 07:20 janne Note Added: 0009770
2016-03-17 07:29 ludovic Note Added: 0009771
2016-03-17 07:37 janne Note Added: 0009772
2016-03-17 07:38 janne Note Edited: 0009772 View Revisions
2016-03-17 07:39 ludovic Note Added: 0009773
2016-03-17 07:44 janne Note Edited: 0009772 View Revisions
2016-03-17 07:50 janne Note Added: 0009774
2016-03-17 07:59 janne Note Edited: 0009774 View Revisions
2016-03-17 08:06 janne Note Edited: 0009774 View Revisions
2016-03-18 12:44 ludovic Note Added: 0009795
2016-03-18 12:44 ludovic Status new => resolved
2016-03-18 12:44 ludovic Fixed in Version => 3.1.0
2016-03-18 12:44 ludovic Resolution open => fixed
2016-03-18 12:44 ludovic Assigned To => ludovic