View Issue Details

IDProjectCategoryView StatusLast Update
0003567SOGoWeb Address Bookpublic2016-12-09 15:26
Reportertiipichris Assigned Tofrancis  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSUbuntuOS Version14.04 LTS
Product Version3.0.1 
Fixed in Version3.0.2 
Summary0003567: Birthdays recorded incorrectly if before 1 Jan 1970
Description

When a birthday is before 1 Jan 1970 it is recorded incorrectly. Although the web interface displays it correctly, viewing the raw vCard shows a date in the future, and this date is transmitted to clients via ActiveSync and CardDav.

For example, 19 Dec 1966 is recorded as 21030125

Additionally, the calendar UI does not have a January 1970. It has two December 1969s and then goes straight to February 1970. The Unix epoch seems to cause it a lot of difficulty

Steps To Reproduce

Set a contacts birthday to a date prior to 1970.
View the raw vCard. The BDAY field is incorrect.
Sync the contact to another device. The birthday appears incorrectly.

TagsNo tags attached.

Activities

francis

francis

2016-03-07 21:17

administrator   ~0009651

See https://github.com/inverse-inc/sogo/commit/9e905b43ff44255e660fbd5063a1c666c44c3297

tiipichris

tiipichris

2016-03-08 03:29

reporter   ~0009653

The additional issue mentioned, that the datepicker has two Dec 1999s and no Jan 1970, is still present in 3.02

francis

francis

2016-03-08 09:16

administrator   ~0009654

Can you reproduce the problem on http://demo.sogo.nu/SOGo/? What is your browser/system timezone?

tiipichris

tiipichris

2016-03-08 09:38

reporter   ~0009655

Curious. Yes, I can reproduce it on the demo site. But I can't reproduce it in all browsers, or even in the same browser across all OSs. I see the problem with Firefox 44.0.2 on Ubuntu 14.04, but NOT on FF 44.0.2 on Windows 10. I don't see the issue in Chrome 49.0.2623.75 on Ubunut 14.04 either.

In all cases timezone is Europe/London, which is currently GMT. When I have some more time I'll try some other browsers.

francis

francis

2016-12-09 15:26

administrator   ~0010980

Can't reproduce. Reopen if necessary.

Issue History

Date Modified Username Field Change
2016-03-07 17:28 tiipichris New Issue
2016-03-07 21:16 francis Status new => resolved
2016-03-07 21:16 francis Fixed in Version => 3.0.2
2016-03-07 21:16 francis Resolution open => fixed
2016-03-07 21:16 francis Assigned To => francis
2016-03-07 21:17 francis Note Added: 0009651
2016-03-08 03:29 tiipichris Note Added: 0009653
2016-03-08 03:29 tiipichris Status resolved => feedback
2016-03-08 03:29 tiipichris Resolution fixed => reopened
2016-03-08 09:16 francis Note Added: 0009654
2016-03-08 09:38 tiipichris Note Added: 0009655
2016-03-08 09:38 tiipichris Status feedback => assigned
2016-12-09 15:26 francis Note Added: 0010980
2016-12-09 15:26 francis Status assigned => resolved
2016-12-09 15:26 francis Resolution reopened => fixed