View Issue Details

IDProjectCategoryView StatusLast Update
0003560SOGoWeb Mailpublic2018-05-11 03:28
Reporterpeterb Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSUbuntuOS Version14.04 LTS
Product Version3.0.1 
Fixed in Version3.0.2 
Summary0003560: Attachment not included when forwarding messages
Description

When using the WebUI forwarding a message with attachment(s) UI does not include the attachment(s) in the forwarded message. If the preferences are set to forward a message as an attachment rather than inline then the result is a blank message with no attachment

Steps To Reproduce

In WebUI click the "Forward selected message" button on any message with an attachment. The resulting message creation popup does not include the attachments.

Additional Information

A useful addition would be to allow the user to forward inline or as attachment at time of forward rather than for all messages via preferences.

TagsNo tags attached.

Relationships

related to 0004463 new Inline and forwarding issues 

Activities

peterb

peterb

2016-03-03 01:47

reporter  

Sample message with attachment.txt (2,268 bytes)   
Return-Path: <email@peter-b.org>
X-Original-To: personal@peter-b.org
Delivered-To: personal-peter-b.org@host1.fryp.com
Received: from [192.168.0.31] (localhost.localdomain [127.0.0.1])
	by host1.fryp.com (Postfix) with ESMTPA id C5ADAC9
	for <personal@peter-b.org>; Thu,  3 Mar 2016 07:40:22 +0100 (CET)
DKIM-Signature: v=1; a=rsa-sha256; c=simple/simple; d=peter-b.org; s=2016;
	t=1456987223; bh=eexUSRrsqiBwnk8cTNHk8ad+xYD8F2H5loQ3L3u8Tso=;
	h=To:From:Subject:Date:From;
	b=JE/zqPW6G4YXTaMtuS46DFtF6Pt3ySMdLJZK1df0Mhq/wvU2JzvcQj9zqNSZMc2P0
	 0P+N16ZatiVfXXZhrBiLEGZY9+OV73JmUcFPzx/mWYuF2RLocDksmjV3Ikpl/zRMM3
	 fOL0TCyO3QCWyRgCOcvNgzn3aDkPrjoS/HNB0vtwmQWzQO5ndNU4RNndvlfMiWbjvJ
	 sbozMFvYwpaCVif1BSuduyslWqwGUgOeFnKCVoDVM+w8cpukSnqyMXdQiBm8eEy7vl
	 4dHNtr/iyLPMqSUqKpTK0geJPXjjXc9SXejUu4Q1dQBQrfQlJHYBc0xnT5nC5luNzI
	 B8mPrIrYpQWFQ==
Received: from 8.Red-81-39-38.dynamicIP.rima-tde.net ([81.39.38.8]
	helo=[192.168.0.31]) by ASSP.nospam with SMTPSA(TLSv1_2 ECDHE-RSA-AES128-GCM-SHA256) (2.4.7); 3 Mar 2016
	07:40:20 +0100
To: Peter Borg <personal@peter-b.org>
From: Peter Borg <email@peter-b.org>
Subject: Example message with an attachment
Message-ID: <56D7DC53.5060703@peter-b.org>
Disposition-Notification-To: Peter Borg <email@peter-b.org>
Date: Thu, 3 Mar 2016 06:40:19 +0000
User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:38.0) Gecko/20100101
 Thunderbird/38.6.0
MIME-Version: 1.0
Content-Type: multipart/mixed;
 boundary="------------040209060705060700060307"
X-Assp-Version: 2.4.7(16004) on ASSP.nospam
X-Assp-ID: ASSP.nospam m1-87222-03065
X-Assp-Session: 7F3742FB9590 (mail 1)
X-Assp-Envelope-From: email@peter-b.org
X-Assp-Intended-For: personal@peter-b.org
X-Assp-Client-TLS: yes

This is a multi-part message in MIME format.
--------------040209060705060700060307
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Transfer-Encoding: 7bit

This is an example message with an attachment

--------------040209060705060700060307
Content-Type: text/plain; charset=UTF-8;
 name="Sample attachment.txt"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
 filename="Sample attachment.txt"

VGhpcyBpcyBhbiBleGFtcGxlIGF0dGFjaG1lbnQNCg0K
--------------040209060705060700060307--

Related Changesets

sogo: master fd8d7bb6

2016-03-03 15:41:29

francis

Details Diff
(js) Fix attachments display when forwarding a msg

Fixes 0003560
Affected Issues
0003560
mod - UI/WebServerResources/js/Mailer/MessageEditorController.js Diff File

Issue History

Date Modified Username Field Change
2016-03-03 01:47 peterb New Issue
2016-03-03 01:47 peterb File Added: Sample message with attachment.txt
2016-03-03 15:42 francis Changeset attached => sogo master fd8d7bb6
2016-03-03 15:42 francis Assigned To => francis
2016-03-03 15:42 francis Resolution open => fixed
2016-03-03 15:43 francis Status new => resolved
2016-03-03 15:43 francis Fixed in Version => 3.0.2
2018-05-11 03:28 Christian Mack Relationship added related to 0004463