View Issue Details

IDProjectCategoryView StatusLast Update
0003538SOGoBackend Calendarpublic2016-03-14 06:51
Reporterzhb Assigned Toludovic  
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version3.0.1 
Summary0003538: Cannot save new event with iCalendar on Mac OS X 10.11.3
Description

Server is running SOGO 3.0.1 on CentOS 6.

When creating a new calendar event, it always raises error:

The request for “[my calendar content]” in “[category]” in account “zhb@xxx” failed.
The server responded with “502” to operation CalDAVWriteEntityQueueableOperation.

In sogo log file, there's an error when this issue occurs:

EXCEPTION: <NSException: 0x55b2c5ecbe98> NAME:NSInvalidArgumentException REASON:Tried to add nil to array INFO:(null)

Steps To Reproduce

Open iCalendar, create a new event and assign it to a category which is hosted on server.

TagsNo tags attached.

Relationships

related to 0003580 resolvedludovic Cannot save new event with Calendar on Mac OS X 10.11.3 

Activities

Christian Mack

Christian Mack

2016-02-22 05:27

developer   ~0009572

Can you change an event in that calendar?

zhb

zhb

2016-02-22 08:52

reporter   ~0009573

I CAN modify existing event. But, i found a critical issue: i cannot add new event with iCalendar, BlackBerry 10 smartphone, even SOGo web interface. After saving a event with SOGo web, no event created at all.

Packages installed on my server (CentOS 6.7):

sogo-3.0.1-1.centos6.x86_64
sogo-tool-3.0.1-1.centos6.x86_64
sogo-ealarms-notify-3.0.1-1.centos6.x86_64
sogo-activesync-3.0.1-1.centos6.x86_64
sope49-gdl1-4.9-20160205_1664.el6.1.x86_64
sope49-gdl1-contentstore-3.0.1-1.centos6.x86_64
sope49-sbjson-2.3.1-20160205_1664.el6.1.x86_64
sope49-ldap-4.9-20160205_1664.el6.1.x86_64
sope49-gdl1-mysql-4.9-20160205_1664.el6.1.x86_64
sope49-xml-4.9-20160205_1664.el6.1.x86_64
sope49-mime-4.9-20160205_1664.el6.1.x86_64
sope49-core-4.9-20160205_1664.el6.1.x86_64
sope49-appserver-4.9-20160205_1664.el6.1.x86_64
sope49-cards-3.0.1-1.centos6.x86_64

Christian Mack

Christian Mack

2016-02-22 09:07

developer   ~0009574

Do you see any errors or mesages in sogo.log when trying to create an event?

zhb

zhb

2016-02-22 09:18

reporter   ~0009575

No any error when creating with SOGo web.

zhb

zhb

2016-02-22 09:21

reporter   ~0009576

Last edited: 2016-02-22 09:23

View 2 revisions

When creating event with SOGo web, sometimes it says:

EXCEPTION: <NSException: 0x56117eaeeea8> NAME:NSInvalidArgumentException REASON:Tried to add nil to array INFO:(null)
<0x0x56117c941278[WOWatchDogChild]> child 14935 exited
<0x0x56117c941278[WOWatchDogChild]> (terminated due to signal 6)
<0x0x56117c8cca98[WOWatchDog]> child spawned with pid 14936

zhb

zhb

2016-02-22 09:45

reporter   ~0009577

If i create a new event with non-ascii characters (Chinese, in my case) and English, SOGo failed to save it with "Bad Gateway" error popup on top-right corner.

Server log has:

"Feb 22 22:39:17 sogod [15166]: [ERROR] <0x7CB98408[SOGoAppointmentFolder]:personal> DAV property '{http://calendarserver.org/ns/}updated-by' has no matching SQL field, response could be incomplete"

I tried to reproduce the same issue, but seems it occurs randomly.

Christian Mack

Christian Mack

2016-02-22 10:19

developer   ~0009578

Forget those "DAV property" errors. They occur, because Apple decided to 'enhance' its own calDAV standard, without changing the standart itself.
They added 3 properties which are not present in any other implementation of the calDAV standard.
Those are:
{http://calendarserver.org/ns/}created-by
{http://calendarserver.org/ns/}updated-by
{urn:ietf:params:xml:ns:caldav}schedule-tag

As SOGo does not know them, they are ignored, which produces those error messages.

Christian Mack

Christian Mack

2016-02-22 10:20

developer   ~0009579

BTW:
Which language do you use for your tests?
Does those errors also happen when using english?

zhb

zhb

2016-02-22 10:21

reporter   ~0009580

I use Chinese.

English works fine most times, but i cannot remember whether it failed before.

zhb

zhb

2016-02-26 12:21

reporter   ~0009600

Last edited: 2016-02-26 12:22

View 2 revisions

Reproduced this issue today:

1) cannot create new calendar event (not task) with SOGo web UI (v3.0.1) with Chinese characters in event title. But it's fine with English title.

2) Cannot create new calendar event with iCalendar.app on Mac OS X. Cannot update existing event with Chinese characters.

Server error message is: "EXCEPTION: <NSException: 0x5614b7615688> NAME:NSInvalidArgumentException REASON:Tried to add nil to array INFO:(null)".

zhb

zhb

2016-03-02 09:03

reporter   ~0009620

Dear developers,

any update on this issue? i cannot save any calendar event with Chinese in event title, this is critical.

francis

francis

2016-03-02 10:51

administrator   ~0009622

Can you reproduce the problem on http://demo.sogo.nu/?

Is the character encoding of your MySQL database set to UTF-8?

zhb

zhb

2016-03-02 11:24

reporter   ~0009624

Last edited: 2016-03-02 11:26

View 3 revisions

I can reproduce this issue on http://demo.sogo.nu/
The error message is "Proxy Error" on top-right corner.

) Please check attached image: http://imgur.com/xoyy8th
) Mantis cannot save Chinese characters in bug report post.

zhb

zhb

2016-03-04 21:00

reporter   ~0009638

Dear developers,

any update on this issue?

zhb

zhb

2016-03-08 22:21

reporter   ~0009660

Issues was fixed by reinstalling sope + sogo.

I upgraded from sogo-2.3.8 to 3.0, not sure why upgrading sogo didn't cover this.

Issue History

Date Modified Username Field Change
2016-02-20 00:14 zhb New Issue
2016-02-22 05:27 Christian Mack Note Added: 0009572
2016-02-22 08:52 zhb Note Added: 0009573
2016-02-22 09:07 Christian Mack Note Added: 0009574
2016-02-22 09:18 zhb Note Added: 0009575
2016-02-22 09:21 zhb Note Added: 0009576
2016-02-22 09:23 zhb Note Edited: 0009576 View Revisions
2016-02-22 09:45 zhb Note Added: 0009577
2016-02-22 10:19 Christian Mack Note Added: 0009578
2016-02-22 10:20 Christian Mack Note Added: 0009579
2016-02-22 10:21 zhb Note Added: 0009580
2016-02-26 12:21 zhb Note Added: 0009600
2016-02-26 12:22 zhb Note Edited: 0009600 View Revisions
2016-03-02 09:03 zhb Note Added: 0009620
2016-03-02 10:51 francis Note Added: 0009622
2016-03-02 11:24 zhb Note Added: 0009624
2016-03-02 11:25 zhb Note Edited: 0009624 View Revisions
2016-03-02 11:26 zhb Note Edited: 0009624 View Revisions
2016-03-04 21:00 zhb Note Added: 0009638
2016-03-08 22:21 zhb Note Added: 0009660
2016-03-09 07:06 ludovic Status new => resolved
2016-03-09 07:06 ludovic Resolution open => no change required
2016-03-09 07:06 ludovic Assigned To => ludovic
2016-03-14 06:51 Christian Mack Relationship added related to 0003580