View Issue Details

IDProjectCategoryView StatusLast Update
0003523SOGoBackend Address Bookpublic2017-01-09 15:49
Reporteremilio.fonseca Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGoogle Chrome 48.0.2564.103OSUbuntuOS Version14.04
Product Versionnightly v2 
Fixed in Version3.2.5 
Summary0003523: Global AddressBooks not working with multi domains.
Description

I have my sogo.conf configured with multi domains. Each domain has both properties isAddressBook and canAuthenticate set as "YES".
Also, in my sogo.conf, I didn't set up the property SOGoDomainsVisibility because I don't want any visibility between domains.
I'm using the same View URL for all domains and filtering the domain through the property authenticationFilter.

When I'm using Web Address Book logged with one of the domains, my Global Addressbooks shows a different address book domain from the logged domain, as you can see in the attachment.

This doesn't happen when I use only one domain in sogo.conf

Additional Information

My domains configuration in sogo.conf:

domains = {
mavtrial.com.br = {
SOGoMailDomain = mavtrial.com.br;
SOGoUserSources = (
{
type = sql;
id = publicmavtrialcombr;
viewURL = "mysql://<my-URL>/<my-db>/sogo";
canAuthenticate = YES;
isAddressBook = YES;
userPasswordAlgorithm = crypt;
displayName = "mavtrial.com.br";
DomainFieldName = "domain";
authenticationFilter = "domain='mavtrial.com.br'";
}
);
};
mav.com.br = {
SOGoMailDomain = mav.com.br;
SOGoUserSources = (
{
type = sql;
id = publicmavcombr;
viewURL = "mysql://<my-URL>/<my-db>/sogo";
canAuthenticate = YES;
isAddressBook = YES;
userPasswordAlgorithm = crypt;
displayName = "mav.com.br";
DomainFieldName = "domain";
authenticationFilter = "domain='mav.com.br'";
}
);
};
}

TagsNo tags attached.

Activities

emilio.fonseca

emilio.fonseca

2016-02-11 14:32

reporter  

printGlobalAddressBook.png (35,180 bytes)   
printGlobalAddressBook.png (35,180 bytes)   
emilio.fonseca

emilio.fonseca

2016-02-11 14:34

reporter   ~0009511

I'm sorry for the wrong title, but I can't edit it anymore :)

Christian Mack

Christian Mack

2016-02-12 06:11

developer   ~0009518

What shall it be?
I can change it for you.

emilio.fonseca

emilio.fonseca

2016-02-12 06:25

reporter   ~0009519

Hi Christian,

Can you see the error in the attachment? I can give you more information of my sogo.conf, if it is necessary :)

The title: Global AddressBooks not working with multi domains.

Christian Mack

Christian Mack

2016-02-12 07:37

developer   ~0009521

Title changed as requested.

Christian Mack

Christian Mack

2016-02-12 07:39

developer   ~0009523

Could it be, that in both domains there is an account named emilio.fonseca?

emilio.fonseca

emilio.fonseca

2016-02-12 07:45

reporter   ~0009524

Last edited: 2016-02-12 10:33

View 2 revisions

No way.

This problem extends to when I'm trying to share a Calendar.
When I'm typing the name of the contact who I want do share, the sugestions are all of the domain "mavtrial.com.br, but I'm logged with "mav.com.br"

Christian Mack

Christian Mack

2016-02-15 03:22

developer   ~0009538

Are all your id's unique in all domains, or do those both share the same?

emilio.fonseca

emilio.fonseca

2016-02-15 07:50

reporter   ~0009539

We are using the email (user@domain.com.br) as ID. So, every ID is unique even between domains.

Maybe the problem is that we are using the same view for both domains and using the property authenticationFilter for filtering the correct domain.

I'm gonna try to create a separate view for each domain to see if it will work.

Christian Mack

Christian Mack

2016-02-15 10:50

developer   ~0009540

Sorry, I didn't make it clear.
I want to know, if the "id" attributes in SOGoUserSources are unique.

emilio.fonseca

emilio.fonseca

2016-02-15 10:55

reporter   ~0009541

Last edited: 2016-02-15 10:56

View 2 revisions

As you can see in the Additional Information, the "id" attributes are different and unique in each domain.

We made a workaround: using one view for each domain works fine.

vincesn

vincesn

2016-12-02 11:19

reporter   ~0010941

I can confirm that this bug is also impacting us. I can provides files if needed.
I'll try consider using a different mysql view meanwhile (thanks Emilio).

ludovic

ludovic

2016-12-20 11:39

administrator   ~0011053

I can reproduce this - I'll fix it right now.

Related Changesets

sogo: master 06903f83

2016-12-20 13:15:15

ludovic

Details Diff
(fix) use the source's domain if none is defined (fixes 0003523) Affected Issues
0003523
mod - SoObjects/SOGo/SOGoUserManager.m Diff File

sogo: v2 e64b3bc1

2016-12-20 13:15:15

ludovic

Details Diff
(fix) use the source's domain if none is defined (fixes 0003523) Affected Issues
0003523
mod - SoObjects/SOGo/SOGoUserManager.m Diff File

sogo: maint 727c7ed8

2016-12-20 13:15:15

ludovic


Committer: francis Details Diff
(fix) use the source's domain if none is defined (fixes 0003523) Affected Issues
0003523
mod - SoObjects/SOGo/SOGoUserManager.m Diff File

Issue History

Date Modified Username Field Change
2016-02-11 14:32 emilio.fonseca New Issue
2016-02-11 14:32 emilio.fonseca File Added: printGlobalAddressBook.png
2016-02-11 14:34 emilio.fonseca Note Added: 0009511
2016-02-12 06:11 Christian Mack Note Added: 0009518
2016-02-12 06:25 emilio.fonseca Note Added: 0009519
2016-02-12 07:37 Christian Mack Note Added: 0009521
2016-02-12 07:37 Christian Mack Summary Multi domains => Global AddressBooks not working with multi domains.
2016-02-12 07:39 Christian Mack Note Added: 0009523
2016-02-12 07:45 emilio.fonseca Note Added: 0009524
2016-02-12 10:33 emilio.fonseca Note Edited: 0009524 View Revisions
2016-02-15 03:22 Christian Mack Note Added: 0009538
2016-02-15 07:50 emilio.fonseca Note Added: 0009539
2016-02-15 10:50 Christian Mack Note Added: 0009540
2016-02-15 10:55 emilio.fonseca Note Added: 0009541
2016-02-15 10:56 emilio.fonseca Note Edited: 0009541 View Revisions
2016-12-02 11:19 vincesn Note Added: 0010941
2016-12-20 11:39 ludovic Note Added: 0011053
2016-12-20 13:16 ludovic Changeset attached => sogo master 06903f83
2016-12-20 13:16 ludovic Assigned To => ludovic
2016-12-20 13:16 ludovic Resolution open => fixed
2016-12-20 13:16 ludovic Changeset attached => sogo v2 e64b3bc1
2016-12-20 13:18 ludovic Status new => resolved
2016-12-20 13:18 ludovic Fixed in Version => 3.2.5
2017-01-09 15:49 francis Changeset attached => sogo maint 727c7ed8