View Issue Details

IDProjectCategoryView StatusLast Update
0003520SOGoBackend Mailpublic2016-02-11 13:52
Reporteremilio.fonseca Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformGoogle Chrome 48.0.2564.103OSUbuntuOS Version14.04
Product Versionnightly v2 
Summary0003520: Exception throwed when listing onlySubscribedFolders
Description

Hi,

I'm testing sogo v3 and, after I login, I receive a Proxy Error message, due the exception in Additional Information, from my sogo.log.

Using tcpdump I saw that unsubscribed folders were listed correctly.

Note: I can access the others parts of SOGo (Calendar, Address Book) but can't access Mail Web View, due this exception.

Additional Information

Feb 11 11:42:59 sogod [8664]: |SOGo| starting method 'GET' on uri '/SOGo/so/emilio@sogotests.com.br/Mail/0/view'
Feb 11 11:42:59 sogod [8664]: <0x0x7f6e9b1dad10[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
Feb 11 11:42:59 sogod [8664]: <0x0x7f6e9b1dad10[SOGoCache]> Using host(s) 'localhost' as server(s)
EXCEPTION: <NSException: 0x7f6e9b51ca80> NAME:NSInvalidArgumentException REASON:-[NGImap4Connection allFoldersMetadataForURL:onlySubscribedFolders:]: unrecognized selector sent to instance 0x7f6e9b5151c0 INFO:(null)

TagsNo tags attached.

Activities

ludovic

ludovic

2016-02-11 11:28

administrator   ~0009498

Upgrade SOPE.

emilio.fonseca

emilio.fonseca

2016-02-11 11:44

reporter   ~0009499

After upgrade sope, my head is on commit f4241be.
On SOGo project, my head is on commit d7b0105

Now, the exception keeps showing up, but with a new message as this:

2016-02-11 14:43:33.875 sogod[28807] ERROR(-[NSNull(misc) forwardInvocation:]): called selector stringByTrimmingSpaces on NSNull !
EXCEPTION: <NSException: 0x7f9cfd4fa210> NAME:NSInvalidArgumentException REASON:-[NGImap4Connection allFoldersMetadataForURL:onlySubscribedFolders:]: unrecognized selector sent to instance 0x7f9cfd914360 INFO:(null)

ludovic

ludovic

2016-02-11 11:55

administrator   ~0009500

If you get this error, that is because the lastest SOPE is not installed.

Look at this commit:

https://github.com/inverse-inc/sope/commit/f4241bed9caf41d2a53a6adb0e97bf8149634f38

The method was clearly added.

emilio.fonseca

emilio.fonseca

2016-02-11 12:11

reporter   ~0009502

I can see this commit, but I've done these steps:

1- updated sope and sogo repo
2- run "make && make install" on both sope and sogo repo
3- Restarted sogod process by killing it and starting again.

A proof of that is the new message that is showing now.

Is there anything else I can do to install SOPE correctly?

emilio.fonseca

emilio.fonseca

2016-02-11 13:51

reporter   ~0009506

Now it is working fine for me. After updating SOPE and waiting for a while.

Thank you a lot for the help, I'm sorry for this wrong bug.
You can close it now, thank you again.

Issue History

Date Modified Username Field Change
2016-02-11 11:25 emilio.fonseca New Issue
2016-02-11 11:28 ludovic Note Added: 0009498
2016-02-11 11:28 ludovic Status new => closed
2016-02-11 11:28 ludovic Assigned To => ludovic
2016-02-11 11:28 ludovic Resolution open => no change required
2016-02-11 11:44 emilio.fonseca Note Added: 0009499
2016-02-11 11:44 emilio.fonseca Status closed => feedback
2016-02-11 11:44 emilio.fonseca Resolution no change required => reopened
2016-02-11 11:55 ludovic Note Added: 0009500
2016-02-11 12:11 emilio.fonseca Note Added: 0009502
2016-02-11 12:11 emilio.fonseca Status feedback => assigned
2016-02-11 13:51 emilio.fonseca Note Added: 0009506
2016-02-11 13:52 ludovic Status assigned => closed
2016-02-11 13:52 ludovic Resolution reopened => no change required