View Issue Details

IDProjectCategoryView StatusLast Update
0003492SOGoWeb Mailpublic2016-02-04 10:53
Reporteremilio.fonseca Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGoogle Chrome 48.0.2564.97OSDebianOS Version7
Product Versionnightly v2 
Fixed in Version3.0.1 
Summary0003492: md-toolbar is not appearing on Chrome
Description

Hello,

There is a problem with the: <md-toolbar sg-view="dayview" class: "daysView">
which is in Calendar Day View.

As you can see in the attachments, on Chrome it doesn't appear, but on Firefox it does with two unnecessary scrolls.

Best regards,
Emílio Fonseca

Additional Information

Also, everytime you change the calendar view (day view, week view, etc), the md-content below scrolls down.

TagsNo tags attached.

Relationships

duplicate of 0003487 resolvedfrancis Header on the Web Calendar not displayed correctly on Chrome Desktop 

Activities

emilio.fonseca

emilio.fonseca

2016-02-03 06:24

reporter  

OnChrome.png (52,337 bytes)   
OnChrome.png (52,337 bytes)   
emilio.fonseca

emilio.fonseca

2016-02-03 06:25

reporter  

OnFirefox.png (53,044 bytes)   
OnFirefox.png (53,044 bytes)   
emilio.fonseca

emilio.fonseca

2016-02-03 06:32

reporter   ~0009412

Hello Francis,

I have my git repository head on commit cf91004 and still having the problem.

Also, have you seen the additional information on this bug?

"Also, everytime you change the calendar view (day view, week view, etc), the md-content below scrolls down."

francis

francis

2016-02-03 06:35

administrator   ~0009413

Have you rebuilt the CSS?

emilio.fonseca

emilio.fonseca

2016-02-03 06:43

reporter   ~0009414

Doesn't "make" in root directory rebuild CSS by itself?

Also, I have cleared the browser cache.

Is there any command to rebuild CSS?

francis

francis

2016-02-03 08:28

administrator   ~0009415

You first need to install nodejs/npm and then run "npm install" and "grunt build" in UI/WebServerResources.

emilio.fonseca

emilio.fonseca

2016-02-03 08:48

reporter   ~0009417

Last edited: 2016-02-03 08:49

Ok I did it. Still the same.

While "grunt build" was running, I got the following message:

Running "sass:dist" (sass) task

File to import not found or unreadable: breakpoint
Parent style sheet: /usr/src/sogo/UI/WebServerResources/scss/styles.scss
Line 5 Column 1 scss/styles.scss
Warning: Used --force, continuing.
Warning: File to import not found or unreadable: breakpoint
Parent style sheet: /usr/src/sogo/UI/WebServerResources/scss/styles.scss Used --force, continuing.

But I don't think that this is a problem.

francis

francis

2016-02-03 09:10

administrator   ~0009420

You also need the git repo of Angular Material.

From the root of your SOGo repository, run "git submodule init" and "git submodule update".

emilio.fonseca

emilio.fonseca

2016-02-03 10:17

reporter   ~0009423

Did it!

Still the same.

emilio.fonseca

emilio.fonseca

2016-02-03 10:46

reporter   ~0009424

Now I have all the files in angular-material folder, including the new one: angular-material/src/core/style/layout.scss

But "grunt build" still have the same warning.

emilio.fonseca

emilio.fonseca

2016-02-03 11:04

reporter   ~0009426

The problem is that grunt couldn't import 'breakpoint' because it shoud be a file in "UI/WebServerResources/scss", right ?

Also, the parent style sheet is "/usr/src/sogo/UI/WebServerResources/scss/styles.scss", and there is a commented line above the breakpoint import line as this: // Breakpoint (https://github.com/at-import/breakpoint)
Should breakpoint be a submodule?

francis

francis

2016-02-03 11:14

administrator   ~0009427

No. You really need to have a copy of the angular material repo as defined in .gitmodules:

https://github.com/inverse-inc/sogo/blob/master/.gitmodules

francis

francis

2016-02-03 11:15

administrator   ~0009428

We'll enable nightly builds today, so you may as well wait for those.

emilio.fonseca

emilio.fonseca

2016-02-03 11:15

reporter   ~0009429

I have it.

emilio.fonseca

emilio.fonseca

2016-02-03 11:16

reporter   ~0009431

Ok, I will keep looking for the problem from here.

Thank you very much, you helped a lot.

francis

francis

2016-02-03 11:30

administrator   ~0009432

Run "bower install" also from UI/WebServerResources.

emilio.fonseca

emilio.fonseca

2016-02-03 11:43

reporter   ~0009433

Great !!

Now, it is working fine.
Thank you a lot for the help.

Issue History

Date Modified Username Field Change
2016-02-03 06:24 emilio.fonseca New Issue
2016-02-03 06:24 emilio.fonseca File Added: OnChrome.png
2016-02-03 06:25 emilio.fonseca File Added: OnFirefox.png
2016-02-03 06:26 francis Relationship added duplicate of 0003487
2016-02-03 06:26 francis Status new => resolved
2016-02-03 06:26 francis Resolution open => fixed
2016-02-03 06:26 francis Assigned To => francis
2016-02-03 06:26 francis Fixed in Version => 3.0.1
2016-02-03 06:32 emilio.fonseca Note Added: 0009412
2016-02-03 06:32 emilio.fonseca Status resolved => feedback
2016-02-03 06:32 emilio.fonseca Resolution fixed => reopened
2016-02-03 06:35 francis Note Added: 0009413
2016-02-03 06:43 emilio.fonseca Note Added: 0009414
2016-02-03 06:43 emilio.fonseca Status feedback => assigned
2016-02-03 08:28 francis Note Added: 0009415
2016-02-03 08:48 emilio.fonseca Note Added: 0009417
2016-02-03 08:49 emilio.fonseca Note Edited: 0009417
2016-02-03 09:10 francis Note Added: 0009420
2016-02-03 10:17 emilio.fonseca Note Added: 0009423
2016-02-03 10:46 emilio.fonseca Note Added: 0009424
2016-02-03 11:04 emilio.fonseca Note Added: 0009426
2016-02-03 11:14 francis Note Added: 0009427
2016-02-03 11:15 francis Note Added: 0009428
2016-02-03 11:15 emilio.fonseca Note Added: 0009429
2016-02-03 11:16 emilio.fonseca Note Added: 0009431
2016-02-03 11:30 francis Note Added: 0009432
2016-02-03 11:43 emilio.fonseca Note Added: 0009433
2016-02-04 10:53 ludovic Status assigned => resolved
2016-02-04 10:53 ludovic Resolution reopened => fixed