View Issue Details

IDProjectCategoryView StatusLast Update
0003433SOGowith SOGopublic2016-01-11 09:12
Reportergiangiz Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSUbuntuOS Version14.04 LTS
Product Version2.3.5 
Fixed in Version2.3.6 
Summary0003433: Sogo BIG Problem inconsistent folder and mail
Description

Hello. I have installed iredmail with sogo and i connected outlook 2013 in EAS. Work fine, but the BIG PROBLEM is that if i create a new folder by outlook, and i move a email (one or more) in the new folder, the mail isn't visible in webmail sogo and in roundcube.

The folder is correctly visible in webmail, but empty!

In outlook is correctly move. It make all seriously inconsistent.

If i delete account and i make new configuration, this reflect the contents webmail (that work in pure imap!), and the folders created now works correctly.

If i create the folder in webmail, it is present also in outlook and work correctly!

I tried reinstall sogo, reinstall all iredmail (old version, and new version, and version LDAP, Mysql,PGSQL), used two outlook in to two different pc, read dovecot and sogo config, but the issue stay.

Seems that this function isn't completely sent or permitted and/or the server can't return

To you too happening? There is solution?

Thanks

Steps To Reproduce

For find the problem is sufficient make a test with outlook 2013.

TagsNo tags attached.

Activities

andre.peters

andre.peters

2016-01-11 04:04

reporter   ~0009263

Can confirm.
I see the (null) mailbox reference again, this could be related to 0003423 and maybe fixed?

giangiz

giangiz

2016-01-11 07:24

reporter   ~0009265

Hello. Yes, even if i see the problem already at the first subfolder (example: xxx@yyy.zz (account) ---> TEST (subfolder) ).
Strange that nobody has reported this problem. This is a BIG Bug. Thus isn't usable for me.
But the related 0003423 is resolved? But what operation do? Only the link https://github.com/inverse-inc/sogo/commit/67f38e112786f458a4913b8dbb461db7cab42edd is incomprehensible for me.

Thanks

ludovic

ludovic

2016-01-11 07:28

administrator   ~0009266

Try the nightly builds.

giangiz

giangiz

2016-01-11 07:39

reporter   ~0009267

Ok, I wait

andre.peters

andre.peters

2016-01-11 09:10

reporter   ~0009268

ludovic, it is fixed in the nightly build, thank you. I checked moving a message across a multi-layered folder hierarchy, it works fine.

Issue History

Date Modified Username Field Change
2016-01-10 10:28 giangiz New Issue
2016-01-11 04:04 andre.peters Note Added: 0009263
2016-01-11 07:24 giangiz Note Added: 0009265
2016-01-11 07:28 ludovic Note Added: 0009266
2016-01-11 07:39 giangiz Note Added: 0009267
2016-01-11 09:10 andre.peters Note Added: 0009268
2016-01-11 09:12 ludovic Status new => resolved
2016-01-11 09:12 ludovic Fixed in Version => 2.3.6
2016-01-11 09:12 ludovic Resolution open => fixed
2016-01-11 09:12 ludovic Assigned To => ludovic