View Issue Details

IDProjectCategoryView StatusLast Update
0003412SOGoBackend Calendarpublic2016-04-06 15:01
ReporterGunnar Weissmann Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version7 (Wheezy)
Product Version2.3.3a 
Fixed in Version3.1.0 
Summary0003412: High CPU load when creating an event with emoticons in subject
Description

when you create an event with emoticons as subject (e.g. pizza slice) in Thunderbird the server can't process this and create en empty subject instead. Empty subjects are not allowed so the creation of the event fails and produces a hanging child with causes a high cpu load.

Is it possible to sanitize the input before processing the event?

Thanks for your support.

Gunnar Weissmann

TagsNo tags attached.

Relationships

duplicate of 0003616 resolvedludovic Emoji in calendar titles breaks caldav sync 

Activities

Jens Erat

Jens Erat

2016-03-29 03:15

reporter   ~0009867

Could you share an example appointment? I haven't been able to reproduce the issue locally.

Gunnar Weissmann

Gunnar Weissmann

2016-03-29 03:42

reporter   ~0009868

Last edited: 2016-03-29 03:43

View 2 revisions

When you create an event with one or more of the following emoticon (http://www.iemoji.com/view/emoji/605/objects/slice-of-pizza) in the subject the problem occurs.

Jens Erat

Jens Erat

2016-03-29 03:45

reporter   ~0009869

This is what we tried; but it worked fine (you're on an old version of SOGo, though). I remember something else related to text encoding, the issue might already be fixed.

If you'd share an .ics file of the appointment (can be created from both withing SOGo and Thunderbird), I'd gladly try to reproduce the issue on our systems.

ludovic

ludovic

2016-04-06 15:01

administrator   ~0009933

Fixed.

Issue History

Date Modified Username Field Change
2015-12-11 11:07 Gunnar Weissmann New Issue
2016-03-24 09:24 ludovic Severity major => minor
2016-03-29 03:15 Jens Erat Note Added: 0009867
2016-03-29 03:42 Gunnar Weissmann Note Added: 0009868
2016-03-29 03:43 Gunnar Weissmann Note Edited: 0009868 View Revisions
2016-03-29 03:45 Jens Erat Note Added: 0009869
2016-04-06 15:01 ludovic Note Added: 0009933
2016-04-06 15:01 ludovic Relationship added duplicate of 0003616
2016-04-06 15:01 ludovic Status new => resolved
2016-04-06 15:01 ludovic Fixed in Version => 3.1.0
2016-04-06 15:01 ludovic Resolution open => fixed
2016-04-06 15:01 ludovic Assigned To => ludovic