View Issue Details

IDProjectCategoryView StatusLast Update
0000341SOGoWeb Calendarpublic2010-02-13 14:17
Reporterwimmer Assigned To 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Versionnightly v2 
Fixed in Version1.2.1 
Summary0000341: problem with event deleting
Description

Some of our users reported me problem with events deleting, when SOGo writes:
"An error occurred during object publishing
the requested object could not be found! "
Now I tried to do some other thing on http://sogo-demo.inverse.ca/,
I erased some events and it happened to mee too.
You can see this case on your demo web.
Log as sogo1, go to 21-01-10 and try to delete "test" events...

Milos

TagsNo tags attached.

Activities

wsourdeau

wsourdeau

2010-01-20 15:46

viewer   ~0000473

This looks like a timezone handling problem with repetitive all-day events.

wsourdeau

wsourdeau

2010-01-20 15:51

viewer   ~0000474

I think this issue has actually been fixed a couple of days ago. However, this implies that only the new events will be fixed. What you can do to overcome this problem is to backup and restore the user events with the sogo-tool utility. Please try that and get back to us...

wsourdeau

wsourdeau

2010-01-21 16:44

viewer   ~0000491

The sogo-tool bug is unfortunately another issue that we need to fix. Is it possible for you to edit those events via Lightning and see if the problem still occurs in the web interface? Use a recent version of SOGo for that test.

wimmer

wimmer

2010-01-25 16:23

reporter   ~0000514

I'm sorry, it was case of my colleague...
He told me that he created event with repeating in SOGo WebGUI, then he synchronized calendar via Funambol with PDA, he made change in one occurence only and after some other synchronizations he had two same events and it was impossible to delete one of them. After some other synchronizations problem was gone.
Now he cannot reproduce it, because sync doesn't work for this case:
Now when he creates repeating event (every Sun, 10-11, for 2 months), sync with Funambol => sync is OK.
Then he changed day (Sun -> Thu) in one occurence only. Then sync with Funambol => and he sees no change on PDA side.
This is some other bug, I will verify it and if it will works same for me, I will create new issue...

So - I think you can close this one.

Thanks,
Milos

ludovic

ludovic

2010-02-13 14:17

administrator   ~0000549

Request to close the issue from the reporter.

Issue History

Date Modified Username Field Change
2010-01-18 13:26 wimmer New Issue
2010-01-20 15:46 wsourdeau Note Added: 0000473
2010-01-20 15:51 wsourdeau Note Added: 0000474
2010-01-21 16:44 wsourdeau Note Added: 0000491
2010-01-25 16:23 wimmer Note Added: 0000514
2010-02-13 14:17 ludovic Note Added: 0000549
2010-02-13 14:17 ludovic Status new => closed
2010-02-13 14:17 ludovic Resolution open => fixed
2010-02-13 14:17 ludovic Fixed in Version => 1.2.1