View Issue Details

IDProjectCategoryView StatusLast Update
0003392SOGoActiveSyncpublic2015-11-25 15:07
Reportercaspar Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.3.3a 
Fixed in Version2.3.4 
Summary0003392: Wrong Charset in Multipart Non UTF-8 HTML-Mails
Description

In Outlook 2016 via EAS multipart HTML-mails with non UTF-8 charsets are not displayed correctly, e.g. Umlauts are garbled. Plain text mails with non UTF-8 charsets and HTML-Mails with UTF-8 charset are displayed correctly though.

This problem stared to occur with version 2.3.3.

Example 1, Not OK:
####################
To: [...]
From: [...]
Subject: Test-Mail Windows-1252 Multipart
Message-ID: <5650A83B.30107@...>
Date: Sat, 21 Nov 2015 18:22:03 +0100
User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:38.0) Gecko/20100101
Thunderbird/38.3.0
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="------------050601050803060608060403"

This is a multi-part message in MIME format.
--------------050601050803060608060403
Content-Type: text/plain; charset=windows-1252; format=flowed
Content-Transfer-Encoding: 8bit

  • ä
  • ö
  • ü

--------------050601050803060608060403
Content-Type: text/html; charset=windows-1252
Content-Transfer-Encoding: 8bit

<html>
<head>

&lt;meta http-equiv=&quot;content-type&quot; content=&quot;text/html; charset=windows-1252&quot;>

</head>
<body bgcolor="#FFFFFF" text="#000000">

  • ä<br>
  • ö<br>
  • ü<br>
    </body>
    </html>

--------------050601050803060608060403--
####################

Example 2 OK:
####################
To: [...]
From: [...]
Subject: Test-Mail Windows-1252 Plain
Message-ID: <5650A572.7060006@...>
Date: Sat, 21 Nov 2015 18:10:10 +0100
User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:38.0) Gecko/20100101
Thunderbird/38.3.0
MIME-Version: 1.0
Content-Type: text/plain; charset=windows-1252; format=flowed
Content-Transfer-Encoding: 8bit

  • ä
  • ö
  • ü
    ####################

Example 3 OK:
####################
To: [...]
From: [...]
Subject: Test-Mail Windows-1252 HTML
Message-ID: <5650A7B1.7020103@...>
Date: Sat, 21 Nov 2015 18:19:45 +0100
User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:38.0) Gecko/20100101
Thunderbird/38.3.0
MIME-Version: 1.0
Content-Type: text/html; charset=windows-1252
Content-Transfer-Encoding: 8bit

<html>
<head>

&lt;meta http-equiv=&quot;content-type&quot; content=&quot;text/html; charset=windows-1252&quot;>

</head>
<body bgcolor="#FFFFFF" text="#000000">

  • ä<br>
  • ö<br>
  • ü<br>
    </body>
    </html>
    ####################
TagsNo tags attached.

Activities

tfu

tfu

2015-11-21 18:56

reporter   ~0009128

When I send a mail via OL which contains Umlauts it's encoding is quoted-printable and not 8bit as in your examples.
Are you on Windows or Mac?

caspar

caspar

2015-11-22 08:41

reporter   ~0009129

The problem is with reading mails in Outlook 2016 on Windows 10. I sent the sample mails with Thunderbird to myself to reproduce the problem.

tfu

tfu

2015-11-22 16:43

reporter   ~0009130

Are you in the position to test a patch?

caspar

caspar

2015-11-23 13:33

reporter   ~0009134

I'm currently using the binary packages for debian, but I can try to setup a build environment.

tfu

tfu

2015-11-24 04:48

reporter   ~0009135

Fix is included in the nightly build. Please test and provide feedback.
https://github.com/inverse-inc/sogo/commit/9a12fb24a64fe50457c17f7608ba10e0763873bf

caspar

caspar

2015-11-24 17:47

reporter   ~0009138

Great - From what I can tell the problem is fixed :-)

Issue History

Date Modified Username Field Change
2015-11-21 12:31 caspar New Issue
2015-11-21 18:56 tfu Note Added: 0009128
2015-11-22 08:41 caspar Note Added: 0009129
2015-11-22 16:43 tfu Note Added: 0009130
2015-11-23 13:33 caspar Note Added: 0009134
2015-11-24 04:48 tfu Note Added: 0009135
2015-11-24 17:47 caspar Note Added: 0009138
2015-11-25 07:33 ludovic Status new => closed
2015-11-25 07:33 ludovic Assigned To => ludovic
2015-11-25 07:33 ludovic Resolution open => fixed
2015-11-25 07:33 ludovic Fixed in Version => 2.3.4
2015-11-25 15:07 ludovic Status closed => resolved