View Issue Details

IDProjectCategoryView StatusLast Update
0003390SOGoActiveSyncpublic2015-11-25 15:10
Reportervelzi Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version8 (Jessie)
Product Version2.3.3a 
Fixed in Version2.3.4 
Summary0003390: Sending mail from Outlook 2013/2016 with active sync fails
Description

After upgrading from 2.3.2 to 2.3.3a sending mail from Outlook does not work as before. Some part of message get lost.

Message after it arrives:

Return-Path: <from@domain.tld>
Delivered-To: <to@domain.tld>
Received: from mail.domain.tld
by mail.domain.tld (Dovecot) with LMTP id FgefGFa5TlYcaQAAvgKw6Q
for <to@domain.tld>; Fri, 20 Nov 2015 08:11:25 +0200
Received: from localhost (localhost [127.0.0.1])
by mail.domain.tld (Postfix) with ESMTP id 46DC13EC96
for <to@domain.tld>; Fri, 20 Nov 2015 08:11:25 +0200 (EET)
X-Virus-Scanned: Debian amavisd-new at mail.domain.tld
Received: from mail.domain.tld ([127.0.0.1])
by localhost (mail.domain.tld [127.0.0.1]) (amavisd-new, port 10024)
with ESMTP id Vt9zRDFLbx0G for <to@domain.tld>;
Fri, 20 Nov 2015 08:11:22 +0200 (EET)
Received: from localhost (localhost [127.0.0.1])
by mail.domain.tld (Postfix) with ESMTP id BD9B33EC95
for <to@domain.tld>; Fri, 20 Nov 2015 08:11:22 +0200 (EET)
From: =?utf-8?q?Veli-Matti_Lepp=C3=A4nen?= <from@domain.tld>
Message-Id: <20151120061122.BD9B33EC95@mail.domain.tld>
Date: Fri, 20 Nov 2015 08:11:22 +0200 (EET)

from@domain.tld>
To: <to@domain.tld>
Subject: testing
Date: Fri, 20 Nov 2015 08:11:21 +0200
Message-ID: <001301d1235a$46e9c7d0$d4bd5770$@domain.tld>
MIME-Version: 1.0
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: 7bit
X-Mailer: Microsoft Outlook 16.0
Thread-Index: AdEjWkXErWl9rmSPSPuYzbxMH4yXdg==
Content-Language: fi

Test message

Steps To Reproduce

Open Outlook and add Sogo account with active sync protocol. Send message.

TagsNo tags attached.

Activities

tfu

tfu

2015-11-21 17:58

reporter   ~0009127

Sending mails from OL works for me.
Can you please give some more details about the issue?
A sogo.log with SOGoEASDebugEnabled = YES would help to understand the problem.

velzi

velzi

2015-11-23 06:22

reporter  

sogo-20151123.log (12,515 bytes)
velzi

velzi

2015-11-23 06:23

reporter   ~0009131

I attached sogo-20151123.log where you can see what happens when debug logging is enabled.

tfu

tfu

2015-11-23 11:58

reporter   ~0009132

Can you please describe what you think is missing?

tfu

tfu

2015-11-24 08:34

reporter   ~0009136

Ok. Problem occurs when eMail address in From header is qp-encoded.

ludovic

ludovic

2015-11-25 15:10

administrator   ~0009139

https://github.com/inverse-inc/sogo/commit/f7d748ea986bcd9116d02bc99d8f9b5213cda411

Issue History

Date Modified Username Field Change
2015-11-20 01:23 velzi New Issue
2015-11-21 17:58 tfu Note Added: 0009127
2015-11-23 06:22 velzi File Added: sogo-20151123.log
2015-11-23 06:23 velzi Note Added: 0009131
2015-11-23 11:58 tfu Note Added: 0009132
2015-11-24 08:34 tfu Note Added: 0009136
2015-11-25 15:10 ludovic Note Added: 0009139
2015-11-25 15:10 ludovic Status new => resolved
2015-11-25 15:10 ludovic Fixed in Version => 2.3.4
2015-11-25 15:10 ludovic Resolution open => fixed
2015-11-25 15:10 ludovic Assigned To => ludovic