View Issue Details

IDProjectCategoryView StatusLast Update
0003381SOGoWeb Calendarpublic2015-12-01 09:42
ReporterSergey Urushkin Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSxubuntuOS Version14.04 amd64
Product Version2.3.2 
Fixed in Version2.3.4 
Summary0003381: Calendar event dialog is broken on Linux with Firefox
Description

Calendar event dialog is broken on Linux with Firefox, you can see it at screenshot. A workaround is to resize window - make it wider. But the size is reseted every time it's opened.

Reproducible with ubuntu,xubuntu,fedora default installations.

Windows is ok
Linux+Chrome is ok.

It seems it's fonts+language issue. A fix could be increasing default dialog window size.

TagsNo tags attached.

Activities

Sergey Urushkin

Sergey Urushkin

2015-11-06 02:48

reporter  

1.png (39,270 bytes)   
1.png (39,270 bytes)   
Sergey Urushkin

Sergey Urushkin

2015-11-06 02:49

reporter  

2.png (40,340 bytes)   
2.png (40,340 bytes)   
Sergey Urushkin

Sergey Urushkin

2015-11-06 02:49

reporter   ~0009076

2.png is well resized window.

francis

francis

2015-11-06 09:15

administrator   ~0009078

https://github.com/inverse-inc/sogo/commit/ba37353e42163a1411f7b32e74d571d8ad4a5135

Sergey Urushkin

Sergey Urushkin

2015-11-06 15:18

reporter   ~0009084

Last edited: 2015-11-06 15:26

View 2 revisions

That commit fixes popup participants dialog, thanks!
But it doesn't fix "Attach" button and line below buttons (see clip at 1.png and 2.png).

ethoms

ethoms

2015-11-19 08:18

reporter   ~0009110

Mine is fine, but I'm using English locale. Although it's big enough, the dialog window could be made bigger.

francis

francis

2015-11-19 08:54

administrator   ~0009112

Sergey: is this Macedonian? I'm surprised to see the last button of the toolbar wrapped on a second line. Your font kerning seems pretty large. Do you use a custom CSS stylesheet?

Sergey Urushkin

Sergey Urushkin

2015-11-19 09:05

reporter   ~0009113

Last edited: 2015-11-19 09:06

View 2 revisions

francis: it's Russian. And no css or fonts tuning at all.

With English locale it's ok, but with Russian (and may be others) it's definitly should be bigger.
The language patch from here: http://www.sogo.nu/bugs/view.php?id=3383
also fixes this issue with Russian locale ("Attach" translation is shorter there), but there could be similar problem with other languages, I see at least Brazilian:

grep 'Attach" = ".{12,}' UI/Scheduler/.lproj/

BrazilianPortuguese.lproj/Localizable.strings:"Attach" = "Adicionar atalho";
Russian.lproj/Localizable.strings:"Attach" = "?????????? ????????";

So, I think some additional CSS improvement should be made to finaly fix this.

francis

francis

2015-11-19 09:48

administrator   ~0009118

We now force toolbar buttons to not exceed a certain width.

See https://github.com/inverse-inc/sogo/commit/4a27beabddd506c2b43b0cacfad42d8443176394

Sergey Urushkin

Sergey Urushkin

2015-11-19 10:15

reporter   ~0009122

Just tried that patch. It fixes this issue, but after applying many buttons doesn't show full text (In many dialogs), and since buttons don't have popup hints, there could be problems with determining what particular button exactly does... See 3.png. I think the limit should be, but it should be much greater (200 or even more). Can't we determine minimal required window size with js somehow?

Sergey Urushkin

Sergey Urushkin

2015-11-19 10:16

reporter  

3.png (39,842 bytes)   
3.png (39,842 bytes)   
francis

francis

2015-11-19 10:44

administrator   ~0009123

Setting a maximum width of 200px would not fixed the problem as the buttons would wrap on a second line as it was doing.

I suggest to add tooltips to all buttons and set a larger window size for the event and task editors.

Sergey Urushkin

Sergey Urushkin

2015-11-19 11:24

reporter   ~0009124

I see, I've just tried to say that a maximum size of 200 or more would be a fix for a possible long-long translation string in the future. I'm suggesting not to revert your previous fix, just change the size.

Buttons with "..." are really inconvenient for users and don't look good, I think this should be avoided if possible.

But adding tooltips and changing default windows size would be great!

francis

francis

2015-11-23 13:30

administrator   ~0009133

https://github.com/inverse-inc/sogo/commit/2ae8c6f8b2fdadf3fb3ba293f3b3800fa8d8bc27
https://github.com/inverse-inc/sogo/commit/f42d6f5f4ae5502641562961eb14f60ccc205489

Sergey Urushkin

Sergey Urushkin

2015-11-24 10:19

reporter   ~0009137

The last 2 commits works great for me, thanks a lot!
But to leave this report without any downsides, could you, please, increase max-width from the patch above to at least 150px, since many button's titles doesn't fit in 100px with some languages (see 4.png). This affects firefox/chrome/IE on linux/windows. Setting max-width to 150px will fix this (at least for Russian).
And I think there is no need of excluding possible situation when all buttons will be 150px (for this, componentWindowWidth=640 should be set in SchedulerUI.js), since that would be a really rare case.

So, I'm reopening it again, hope the last time:)
Thanks a lot again!

Sergey Urushkin

Sergey Urushkin

2015-11-24 10:19

reporter  

4.png (45,691 bytes)   
4.png (45,691 bytes)   
francis

francis

2015-11-27 08:38

administrator   ~0009170

https://github.com/inverse-inc/sogo/commit/bbdb27e75e9eb12a5ba701677125c2702a195d8f

I'll keep the component window width to 520px for the moment.

Sergey Urushkin

Sergey Urushkin

2015-12-01 09:27

reporter   ~0009179

Great! Works for me. Thanks.

Issue History

Date Modified Username Field Change
2015-11-06 02:48 Sergey Urushkin New Issue
2015-11-06 02:48 Sergey Urushkin File Added: 1.png
2015-11-06 02:49 Sergey Urushkin File Added: 2.png
2015-11-06 02:49 Sergey Urushkin Note Added: 0009076
2015-11-06 09:15 francis Note Added: 0009078
2015-11-06 09:15 francis Status new => resolved
2015-11-06 09:15 francis Fixed in Version => 2.3.3
2015-11-06 09:15 francis Resolution open => fixed
2015-11-06 09:15 francis Assigned To => francis
2015-11-06 15:18 Sergey Urushkin Note Added: 0009084
2015-11-06 15:18 Sergey Urushkin Status resolved => feedback
2015-11-06 15:18 Sergey Urushkin Resolution fixed => reopened
2015-11-06 15:26 Sergey Urushkin Note Edited: 0009084 View Revisions
2015-11-19 08:18 ethoms Note Added: 0009110
2015-11-19 08:54 francis Note Added: 0009112
2015-11-19 09:05 Sergey Urushkin Note Added: 0009113
2015-11-19 09:05 Sergey Urushkin Status feedback => assigned
2015-11-19 09:06 Sergey Urushkin Note Edited: 0009113 View Revisions
2015-11-19 09:48 francis Note Added: 0009118
2015-11-19 09:48 francis Status assigned => resolved
2015-11-19 09:48 francis Fixed in Version 2.3.3 => 2.3.4
2015-11-19 09:48 francis Resolution reopened => fixed
2015-11-19 10:15 Sergey Urushkin Note Added: 0009122
2015-11-19 10:15 Sergey Urushkin Status resolved => feedback
2015-11-19 10:15 Sergey Urushkin Resolution fixed => reopened
2015-11-19 10:16 Sergey Urushkin File Added: 3.png
2015-11-19 10:44 francis Note Added: 0009123
2015-11-19 11:24 Sergey Urushkin Note Added: 0009124
2015-11-19 11:24 Sergey Urushkin Status feedback => assigned
2015-11-23 13:30 francis Note Added: 0009133
2015-11-23 13:30 francis Status assigned => resolved
2015-11-23 13:30 francis Resolution reopened => fixed
2015-11-24 10:19 Sergey Urushkin Note Added: 0009137
2015-11-24 10:19 Sergey Urushkin Status resolved => feedback
2015-11-24 10:19 Sergey Urushkin Resolution fixed => reopened
2015-11-24 10:19 Sergey Urushkin File Added: 4.png
2015-11-27 08:38 francis Note Added: 0009170
2015-12-01 09:27 Sergey Urushkin Note Added: 0009179
2015-12-01 09:27 Sergey Urushkin Status feedback => assigned
2015-12-01 09:42 francis Status assigned => resolved
2015-12-01 09:42 francis Resolution reopened => fixed