View Issue Details

IDProjectCategoryView StatusLast Update
0003356SOGoActiveSyncpublic2015-10-14 09:58
Reporterskasch Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version8 (Jessie)
Product Version2.3.2 
Fixed in Version2.3.3 
Summary0003356: EAS localizes date header from mail
Description

Outlook 2013 and at least iPhone iOS 9 both configured with EAS localize the information within the header section "date"

Steps To Reproduce
  • install sogo-2.3.2.20151001-1 or sogo-2.3.2 stable
  • configure outlook 2013 or iphone with eas
  • send mail
Additional Information

The date header gets rewritten from e.g.,

date: Thu, 01 Oct 2015 14:40:25 +0200

to (german in my case):

date: Do, 01 Okt 2015 14:40:25 +0200

which confuses a variety of other clients that receive these mails.

Thunderbird sort it as 01.01.1970
Some Outlooks sort it as 30.12.1899
Some Spam-Engines sort them out due to being malformed.

Is this a bug or feature? an how to "normalize" this?

TagsNo tags attached.

Activities

skasch

skasch

2015-10-06 04:10

reporter   ~0008977

Dear bugtracker,

for my fellow german users with sogo-activesync on debian jessie:

/etc/init.d/sogo:

DAEMON_OPTS="-WOWorkersCount $PREFORK -WOPidFile $PIDFILE -WOLogFile $LOGFILE -NSLanguages (English)"

I have no idea why GNUstep defaulted to some other (possibly $LANG) language-setting.

Outlook and iPhone over EAS work as expected again.

Kudos to Thomas Fuehrer for helping me out with this!

cheers,
sascha

ps: Bug can be closed

skasch

skasch

2015-10-06 04:11

reporter   ~0008978

-NSLanguages (English) appended as option is the solution for me

ludovic

ludovic

2015-10-14 09:58

administrator   ~0008998

Correct fix should be here:

https://github.com/inverse-inc/sogo/commit/beb484da102196a491c6f0c6332e99af02b0ccf4

Issue History

Date Modified Username Field Change
2015-10-01 08:58 skasch New Issue
2015-10-06 04:10 skasch Note Added: 0008977
2015-10-06 04:11 skasch Note Added: 0008978
2015-10-14 09:58 ludovic Note Added: 0008998
2015-10-14 09:58 ludovic Status new => resolved
2015-10-14 09:58 ludovic Fixed in Version => 2.3.3
2015-10-14 09:58 ludovic Resolution open => fixed
2015-10-14 09:58 ludovic Assigned To => ludovic