View Issue Details

IDProjectCategoryView StatusLast Update
0003354SOGoWeb Preferencespublic2017-05-30 09:44
Reporterrhertel Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version7 (Wheezy)
Product Version2.3.2 
Fixed in Version2.3.21 
Summary0003354: 'Include in free-busy' checkbox not working
Description

Free-Busy information of an user calendar is not calculated correct.
Calendars with a deselected 'Include in free-busy' checkbox are nevertheless shown in the free-busy informations of a user.

TagsNo tags attached.

Relationships

related to 0004012 closedludovic All subscribed calendars are "Included in free-busy" 

Activities

pokotilenko

pokotilenko

2016-08-01 15:48

reporter   ~0010553

I'm seeing described here behaviour in 2.3.13.

My user shows as busy in sogo for other users because of events I have in additional calendars (not personal) for whose I have 'Include in free-busy' checkbox unset.

I have to set 'Show Time as Free' for all events in those additional calendars

Christian Mack

Christian Mack

2017-02-03 08:19

developer   ~0011270

As you reverted teh buggy fix for V2, "Include in free-busy" is now again ignored.
You can set this calendar option, and it is stored in the database and displayed correctly, but ignored.
All calendars owned by you are included in Free/Busy and all calendars subscribed are excluded.

Will this be fixed in V2?

infrasysteme

infrasysteme

2017-03-31 04:58

reporter   ~0011641

Same problem here.
Could you, please, fix it ?

Thanks a lot !

aminet

aminet

2017-04-25 07:58

reporter   ~0011757

Same here with 2.3.20 :

  • steps to reproduce: unset 'include in free-busy', press ok and reopen the properties: checkbox is set.
  • subscribe to a calendar (with events), unset 'include in free-busy' and create an event in an owned calendar, invite people: you can see that your are busy due to event in the subscribed calendar.

A good default behavior would be to have 'include in free-busy' unset by default for all subscribed calendar.

Related Changesets

sogo: master eed56790

2016-12-23 11:36:44

ludovic

Details Diff
(fix) properly honor "include in freebusy" (fixes 0003354) Affected Issues
0003354
mod - SoObjects/Appointments/SOGoAppointmentFolder.m Diff File

sogo: v2 42c2c66c

2016-12-23 11:36:44

ludovic

Details Diff
(fix) properly honor "include in freebusy" (fixes 0003354) Affected Issues
0003354
mod - SoObjects/Appointments/SOGoAppointmentFolder.m Diff File

sogo: maint 4f9d514c

2016-12-23 11:36:44

ludovic


Committer: francis Details Diff
(fix) properly honor "include in freebusy" (fixes 0003354) Affected Issues
0003354
mod - SoObjects/Appointments/SOGoAppointmentFolder.m Diff File

sogo: v2 9a1f91ea

2017-01-30 08:40:01

ludovic

Details Diff
Revert "(fix) properly honor "include in freebusy" (fixes 0003354)"

This reverts commit 42c2c66caa557b381944a8abb60bdd5b9dc036be.
Affected Issues
0003354
mod - SoObjects/Appointments/SOGoAppointmentFolder.m Diff File

sogo: v2 3f698447

2017-04-27 09:02:46

francis

Details Diff
Properly honor "include in freebusy"

Fixes 0003354
Affected Issues
0003354
mod - NEWS Diff File
mod - SoObjects/Appointments/SOGoAppointmentFolder.m Diff File
mod - SoObjects/Appointments/SOGoFreeBusyObject.m Diff File
mod - SoObjects/SOGo/SOGoParentFolder.m Diff File

sogo: master ef5728dc

2017-04-27 09:02:46

francis

Details Diff
Properly honor "include in freebusy"

Fixes 0003354
Affected Issues
0003354
mod - NEWS Diff File
mod - SoObjects/Appointments/SOGoAppointmentFolder.m Diff File
mod - SoObjects/Appointments/SOGoFreeBusyObject.m Diff File
mod - SoObjects/SOGo/SOGoParentFolder.m Diff File

sogo: master af2507a6

2017-05-30 09:26:30

francis

Details Diff
Newly subscribed calendars are excluded from FB

Fixes 0003354
Affected Issues
0003354
mod - NEWS Diff File
mod - SoObjects/Appointments/SOGoAppointmentFolder.m Diff File
mod - SoObjects/SOGo/SOGoGCSFolder.m Diff File

sogo: v2 95d08c01

2017-05-30 09:26:30

francis

Details Diff
Newly subscribed calendars are excluded from FB

Fixes 0003354
Affected Issues
0003354
mod - NEWS Diff File
mod - SoObjects/Appointments/SOGoAppointmentFolder.m Diff File
mod - SoObjects/SOGo/SOGoGCSFolder.m Diff File

Issue History

Date Modified Username Field Change
2015-09-30 08:04 rhertel New Issue
2016-08-01 15:48 pokotilenko Note Added: 0010553
2016-12-23 11:37 ludovic Changeset attached => sogo master eed56790
2016-12-23 11:37 ludovic Assigned To => ludovic
2016-12-23 11:37 ludovic Resolution open => fixed
2016-12-23 11:38 ludovic Changeset attached => sogo v2 42c2c66c
2016-12-23 11:39 ludovic Status new => resolved
2016-12-23 11:39 ludovic Fixed in Version => 3.2.5
2017-01-09 15:49 francis Changeset attached => sogo maint 4f9d514c
2017-01-30 08:40 ludovic Changeset attached => sogo v2 9a1f91ea
2017-02-03 08:19 Christian Mack Note Added: 0011270
2017-02-03 08:19 Christian Mack Status resolved => feedback
2017-02-03 08:19 Christian Mack Resolution fixed => reopened
2017-03-29 08:55 ludovic Relationship added related to 0004012
2017-03-31 04:58 infrasysteme Note Added: 0011641
2017-04-25 07:58 aminet Note Added: 0011757
2017-04-27 09:03 francis Changeset attached => sogo v2 3f698447
2017-04-27 09:03 francis Status feedback => resolved
2017-04-27 09:03 francis Fixed in Version 3.2.5 => 2.3.21
2017-04-27 09:03 francis Resolution reopened => fixed
2017-04-27 09:38 francis Changeset attached => sogo master ef5728dc
2017-05-30 09:27 francis Changeset attached => sogo master af2507a6
2017-05-30 09:44 francis Changeset attached => sogo v2 95d08c01