View Issue Details

IDProjectCategoryView StatusLast Update
0003352SOGoActiveSyncpublic2015-10-14 15:40
Reportermfasolo Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version8 (Jessie)
Product Version2.3.2 
Fixed in Version2.3.3 
Summary0003352: Default Operating System locale and MIME date header
Description

When Operating System default locale is not en_US.UTF8 MIME header date attribute is written using OS locale.
For example if OS locale is it_IT.UTF8

Mail header looks like:
content-type: text/plain; charset="us-ascii"
to: fasolom@comune.padova.it
date: Mar, 22 Set 2015 16:44:57 +0200

This cause addressed mail client to view date as:
Gio, 1 Gennaio 1970 1:00 am

Steps To Reproduce

Set default OS locale as it_IT.UTF8 (Debian dpkg-reconfigure locales), then sent mail using ActiveSync via smartphone (tested on IOS9 and Android 4.4).

The receiver view date as Gio, 1 Gennaio 1970 1:00 am

TagsNo tags attached.

Activities

Issue History

Date Modified Username Field Change
2015-09-22 11:29 mfasolo New Issue
2015-10-14 15:40 ludovic Note Added: 0009002
2015-10-14 15:40 ludovic Status new => closed
2015-10-14 15:40 ludovic Assigned To => ludovic
2015-10-14 15:40 ludovic Resolution open => fixed
2015-10-14 15:40 ludovic Fixed in Version => 2.3.3