View Issue Details

IDProjectCategoryView StatusLast Update
0003332SOGoBackend Calendarpublic2016-08-05 16:52
ReporterJacek Assigned Toludovic  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSRHEL/CentOSOS Version7
Product Version2.3.1 
Fixed in Version3.1.5 
Summary0003332: MultipleBookings not respected for weekly events
Description

We use "resources" feature of SOGo to manage conference room bookings (MultipleBookings: 1) - yet some duplicates started appearing, even though we have updated SOGo to the latest stable version (2.3.1).

Steps To Reproduce
  1. Create new resource account ("conference_roomtest@...").
  2. Create new weekly event ("Test September") starting on Tuesday, September 1st 2015 8:00 AM (1 hour long) and ending on September 30th - invite the resource.
  3. Create new one time event on Tuesday, September 1st 2015 8:00 AM and invite the resource - it approves the invitation even though the conference room should not be available.
  4. Create new weekly event starting on Tuesday, September 8th 2015 8:00 AM - it fails due to an error:

"Maximum number of simultaneous bookings (1) reached for resource "conference_roomtest@...". The conflicting event is "Test September", and starts on 2015-09-15 08:00:00 +0200"

Additional Information

Timezone: Europe/Warsaw

TagsNo tags attached.

Activities

ludovic

ludovic

2016-08-05 16:52

administrator   ~0010575

Try with the upcoming nightly builds (available in 12 hours from now) or with the upcoming v2.3.14 / v3.1.5 releases - we fixed something that can be related - reopen if necessary.

Issue History

Date Modified Username Field Change
2015-09-03 06:44 Jacek New Issue
2016-08-05 16:52 ludovic Note Added: 0010575
2016-08-05 16:52 ludovic Status new => resolved
2016-08-05 16:52 ludovic Fixed in Version => 3.1.5
2016-08-05 16:52 ludovic Resolution open => fixed
2016-08-05 16:52 ludovic Assigned To => ludovic