View Issue Details

IDProjectCategoryView StatusLast Update
0003313SOGoWeb Preferencespublic2016-06-06 15:19
Reportertifenn.legoff Assigned Tofrancis  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version7 (Wheezy)
Product Version2.3.1 
Fixed in Version3.1.2 
Summary0003313: Signatures non modifiable en cas d'édition avec Microsoft Word
Description

Bonjour,
Lorsque l'on édite une signature avec Microsoft Word, que l'on fait un copier-coller sur SOGo et que l'on enregistre, le bouton pour modifier la signature disparaît.

Pour palier au problème, nous sommes obligé d'éditer une sauvegarde sogo-tool, vider le paramètre de signature (SOGoMailSignature = "";) et de restaurer la sauvegarde avec sogo-tool restore -p

Si l'on regarde le code de la signature, on observe des balises XML de MS Office (OLE).

Est-il prévu dans les versions à venir d'intégrer un bouton pour permettre aux utilisateurs de réinitialiser leurs signatures ?

Merci.

Cordialement,
Tifenn LE GOF

Steps To Reproduce

Créer une signature complexe (avec une image, des couleurs, des liens, ...), copier le contenu et le coller sur l'éditeur de signature puis enregistrer.

Additional Information

Veuillez trouver en pièce jointe l'archive "probleme signature.7z" comprenant les fichiers suivants :

  • signature.txt : code html de la signature avec les balises XML de MS Office
  • sogo probleme signautre.jpeg : capture d'écran du bouton qui disparaît
TagsNo tags attached.

Relationships

duplicate of 0002295 resolvedfrancis Signature link is not there 
related to 0003609 resolvedfrancis Cannot change the signature 

Activities

tifenn.legoff

tifenn.legoff

2015-08-18 07:15

reporter  

probleme signature.7z (113,405 bytes)
francis

francis

2016-06-03 10:13

administrator   ~0010287

I integrated this CKEditor plugin to solve the problem:

http://ckeditor.com/addon/pastefromword

Can somebody who has Microsoft Word try the next nightly build or demo.sogo.nu and let me know if it works? Thanks!

Related Changesets

sogo: master 568e4380

2016-06-03 10:07:04

francis

Details Diff
(js) Add the "Paste from word" CKEditor plugin

Fixes 0002295
Fixes 0003313
Affected Issues
0002295, 0003313
mod - NEWS Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/build-config.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/ckeditor.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/ar.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/ca.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/cs.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/cy.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/da.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/de.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/en.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/es.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/eu.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/fi.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/fr.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/hr.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/hu.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/is.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/it.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/lt.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/mk.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/nb.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/nl.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/no.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/pl.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/pt-br.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/pt.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/ru.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/sk.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/sl.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/sv.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/tr.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/uk.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/zh-cn.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/lang/zh.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/plugins/icons.png Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/plugins/icons_hidpi.png Diff File
add - UI/WebServerResources/js/vendor/ckeditor/plugins/pastefromword/filter/default.js Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/skins/minimalist/editor.css Diff File
mod - UI/WebServerResources/js/vendor/ckeditor/skins/minimalist/editor_gecko.css Diff File

Issue History

Date Modified Username Field Change
2015-08-18 07:15 tifenn.legoff New Issue
2015-08-18 07:15 tifenn.legoff File Added: probleme signature.7z
2016-06-02 02:47 Christian Mack Relationship added related to 0003609
2016-06-02 02:48 Christian Mack Relationship added duplicate of 0002295
2016-06-03 10:08 francis Changeset attached => sogo master 568e4380
2016-06-03 10:08 francis Assigned To => francis
2016-06-03 10:08 francis Resolution open => fixed
2016-06-03 10:13 francis Note Added: 0010287
2016-06-06 15:19 francis Status new => resolved
2016-06-06 15:19 francis Fixed in Version => 3.1.2