View Issue Details

IDProjectCategoryView StatusLast Update
0003309SOGoActiveSyncpublic2015-09-09 15:00
Reporterdaniel.colchete Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Client] MicrosoftOSWindowsOS Version8
Product Version2.3.1 
Target Version2.3.2Fixed in Version2.3.2 
Summary0003309: Malformed email Subject shows on web interface but not on Outlook
Description

I have a case here of a billing system generating invoice emails using special UTF-8 chars on the Subject, but without any quoted-printable/base64 codification.

I know it is wrong and malformed but the web interface is showing the email correctly. When we try to open it on outlook we can't see the subject. This different is generating a bad user experience.

I was wondering if we could also make it work on Outlook 2013, interpreting it as ISO-8859-1 just like the web interface does.

If you configure Outlook 2013 with IMAP, or try Roundcube or Thunderbird, they you also interpret the special char as ISO-8859-1. Even though this is not RFC compliant.

Steps To Reproduce

I attached a file with the original email. O test it use

cat m1.eml | ssmtp youaccount@domain.com

TagsNo tags attached.

Activities

daniel.colchete

daniel.colchete

2015-08-17 10:18

reporter  

m1.eml (22,919 bytes)
Christian Mack

Christian Mack

2015-08-18 05:31

developer   ~0008825

Sorry, but subjects are per email standard in ASCII, so no UTF-8 without coding allowed.
Because of this, that email is invalid.
It is not even guaranteed, that it will be delivered to the recipient.

ludovic

ludovic

2015-09-09 15:00

administrator   ~0008907

https://github.com/inverse-inc/sope/commit/e870145b7ed381c1bdef5945075ed48948b86d5b

Issue History

Date Modified Username Field Change
2015-08-17 10:18 daniel.colchete New Issue
2015-08-17 10:18 daniel.colchete File Added: m1.eml
2015-08-18 05:31 Christian Mack Note Added: 0008825
2015-09-09 14:59 ludovic Target Version => 2.3.2
2015-09-09 15:00 ludovic Note Added: 0008907
2015-09-09 15:00 ludovic Status new => resolved
2015-09-09 15:00 ludovic Fixed in Version => 2.3.2
2015-09-09 15:00 ludovic Resolution open => fixed
2015-09-09 15:00 ludovic Assigned To => ludovic