View Issue Details

IDProjectCategoryView StatusLast Update
0003301SOGoWeb Mailpublic2015-09-03 14:16
Reportercnaumer Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.3.1 
Target Version2.3.2Fixed in Version2.3.2 
Summary0003301: If "displayname" in LDAP has a comma between firstname and lastname sender address in the webinterface is wrong
Description

If "displayname" in LDAP has a comma between firstname and lastname (Firstname, lastname) sender address in the webinterface is wrong. The address is split in two like firstname@ and lastname <firstname.lastname@domain.com> . See Screeshots.
In the "Sent" Folder the mail appears as Fistname@unspecified-domain Lastname <firstname.lastname@domain.com>
The recipient gets Fistname@domain.com Lastname <firstname.lastname@domain.com>. This is probably due to our postfix config.
But SOGo should not split the name up in the first place. Or is this correct behaviour?

Steps To Reproduce

Have a comma in displayname in LDAP write an email as that user.

TagsNo tags attached.

Relationships

has duplicate 0003306 resolvedfrancis Comma in display name of meeting organiser not handled correctly. 

Activities

cnaumer

cnaumer

2015-08-05 07:24

reporter  

Send_Folder.png (12,471 bytes)   
Send_Folder.png (12,471 bytes)   
cnaumer

cnaumer

2015-08-05 07:24

reporter  

recieved_Email.png (12,149 bytes)   
recieved_Email.png (12,149 bytes)   
heupink

heupink

2015-08-26 11:09

reporter   ~0008859

We are also seeing similar behaviour:

When replying to an email like:
From: "external_user, Sharon" <external@otherdomain.com>

the reply composition window looks like this:
To: external_user, Sharon <external@otherdomain.com>

And this is incorrectly SPLIT into two addresses:
To: external_user@MISSING_DOMAIN, Sharon <external@otherdomain.com>

Then, the missing domain is replaced with out default domain, and the final result is that the email is sent to TWO addresses: Sharon <external@otherdomain.com> and external_user@ourdomain.com.

As you can image, this causes various problems. :-)

francis

francis

2015-09-03 14:16

administrator   ~0008887

Fixed.

https://github.com/inverse-inc/sope/commit/7dcb6a244b5cdf5812541d5ddba9c63994ec7eb7

Issue History

Date Modified Username Field Change
2015-08-05 07:24 cnaumer New Issue
2015-08-05 07:24 cnaumer File Added: Send_Folder.png
2015-08-05 07:24 cnaumer File Added: recieved_Email.png
2015-08-26 11:09 heupink Note Added: 0008859
2015-08-26 11:16 francis Target Version => 2.3.2
2015-08-27 04:37 Christian Mack Relationship added has duplicate 0003306
2015-09-03 14:16 francis Note Added: 0008887
2015-09-03 14:16 francis Status new => resolved
2015-09-03 14:16 francis Fixed in Version => 2.3.2
2015-09-03 14:16 francis Resolution open => fixed
2015-09-03 14:16 francis Assigned To => francis