View Issue Details

IDProjectCategoryView StatusLast Update
0003300SOGoBackend Calendarpublic2016-09-27 14:46
Reporteramay82 Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionsuspended 
Product Version2.2.10 
Summary0003300: Creating a repeating event creates wrong DTSTART
Description

Creating a repeating event creates wrong DTSTART values.

Steps To Reproduce
  1. Create a new repeating event
    Custom: daily, 5 occurrences
  2. Fetch the event with CalDAV (GET)

It's:

BEGIN:VCALENDAR[\r][\n]
PRODID:-//Inverse inc./SOGo 2.2.10//EN[\r][\n]
VERSION:2.0[\r][\n]
BEGIN:VEVENT[\r][\n]
UID:4AC-55BF7100-31-3B0C5A00[\r][\n]
SUMMARY:Recurring event[\r][\n]
DESCRIPTION:l[0xc3][0xb6][0xc3][0xb6]l[\r][\n]
CLASS:PUBLIC[\r][\n]
CREATED:20150803T134717Z[\r][\n]
DTSTAMP:20150803T134717Z[\r][\n]
LAST-MODIFIED:20150803T134724Z[\r][\n]
DTSTART;:20150803T084500Z[\r][\n]
DTEND;:20150803T094500Z[\r][\n]
TRANSP:OPAQUE[\r][\n]
RRULE:FREQ=DAILY;COUNT=5[\r][\n]
END:VEVENT[\r][\n]
END:VCALENDAR

The DTSTART can't be parsed because of the ";:".

Additional Information

See http://tools.ietf.org/html/rfc5545#section-3.1: when there's a ";", there must also be a param

contentline = name *(";" param ) ":" value CRLF

TagsNo tags attached.

Activities

francis

francis

2015-08-03 09:55

administrator   ~0008800

The timezone is missing. Any errors in the log file?

ludovic

ludovic

2016-09-27 14:46

administrator   ~0010698

No feedback provided, closing.

Issue History

Date Modified Username Field Change
2015-08-03 09:52 amay82 New Issue
2015-08-03 09:55 francis Note Added: 0008800
2016-09-27 14:46 ludovic Note Added: 0010698
2016-09-27 14:46 ludovic Status new => closed
2016-09-27 14:46 ludovic Assigned To => ludovic
2016-09-27 14:46 ludovic Resolution open => suspended