View Issue Details

IDProjectCategoryView StatusLast Update
0003261SOGoWeb Calendarpublic2015-06-23 09:26
ReporterDavid Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSRHEL/CentOSOS Version6
Product Version2.3.0 
Fixed in Version2.3.1 
Summary0003261: Event start and description misplaced
Description

In list of events in Calendar view an event 'Start' column contains event Description and event 'End' column contains event Start value.

Steps To Reproduce

Create an event in Personal calendar: Title -> 'Test Event', Location -> 'Room A', Start -> '10:00', End -> '11:00', Description -> 'Meeting'. After 'Save and Close' in Calendar view I can see 'Meeting' in Start column and '10:00' in End column. Other values (Title, Location) are placed correctly.

TagsNo tags attached.

Activities

David

David

2015-06-21 19:48

reporter  

sogo-cal.png (64,046 bytes)   
sogo-cal.png (64,046 bytes)   
francis

francis

2015-06-21 23:05

administrator   ~0008657

I can't reproduce this problem on the demo instance (http://sogo-demo.inverse.ca/).

David

David

2015-06-22 02:45

reporter   ~0008658

Hmm, strange, we have two independent instances (RHEL 5 & PostgreSQL, RHEL 6 & MySQL), both running 2.3.0 and both authenticating against LDAP - both have the same symptoms. Any suggestion what to look for?

David

David

2015-06-22 02:52

reporter   ~0008659

But that demo instance mentioned above is running 2.2.17, isn't it?

David

David

2015-06-23 03:46

reporter   ~0008660

Tried to downgrade one of our servers to 2.2.17a today. Result - everything is displayed correctly. After upgrading back to 2.3.0 values are shuffled again.

francis

francis

2015-06-23 06:46

administrator   ~0008663

Have you update your databse schema for 2.3.0?

https://github.com/inverse-inc/sogo/blob/SOGo-2.3.0/Documentation/SOGoInstallationGuide.asciidoc#L2716

tfu

tfu

2015-06-23 08:09

reporter   ~0008664

Problem can be reproduced with ZEG-2.3.0

francis

francis

2015-06-23 09:26

administrator   ~0008666

https://github.com/inverse-inc/sogo/commit/b5270999070251be966fd226bf38b8f595982944

Issue History

Date Modified Username Field Change
2015-06-21 19:48 David New Issue
2015-06-21 19:48 David File Added: sogo-cal.png
2015-06-21 23:05 francis Note Added: 0008657
2015-06-22 02:45 David Note Added: 0008658
2015-06-22 02:52 David Note Added: 0008659
2015-06-23 03:46 David Note Added: 0008660
2015-06-23 06:46 francis Note Added: 0008663
2015-06-23 08:09 tfu Note Added: 0008664
2015-06-23 09:26 francis Note Added: 0008666
2015-06-23 09:26 francis Status new => resolved
2015-06-23 09:26 francis Fixed in Version => 2.3.1
2015-06-23 09:26 francis Resolution open => fixed
2015-06-23 09:26 francis Assigned To => francis