View Issue Details

IDProjectCategoryView StatusLast Update
0003260SOGoWeb Address Bookpublic2021-05-26 17:49
Reporterfsayd Assigned Tofrancis  
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.3.0 
Fixed in Version5.1.1 
Summary0003260: Unable to import contact lists from ldif files
Description

Currently SOGo does not allow to import contacts lists from ldif. A addressbook with the next representation of a list:

dn: cn=my-list
objectclass: top
objectclass: groupOfNames
cn: my-list
member: cn=,user1@example.com
member: cn=,user2@example.com

Is imported as a blank card without data.

Even from the Web AddessBook if you export a addressbook that includes a list to a ldif file and then try to import the same ldif in SOGo, the contact list is imported as a blank card.

Steps To Reproduce

Create a addressbook from WebUI and add a list.
Choose the addressbook and select "Export Address Book"
Save the ldif file to your PC
Create a second addressbook and select it.
Choose "Import cards"
Select the file previously exported
The list is imported as a blank card

TagsNo tags attached.

Relationships

duplicate of 0001651 resolvedfrancis Contact lists are not imported correctly 

Activities

There are no notes attached to this issue.

Related Changesets

sogo: master e1d8d70e

2021-05-26 17:47:15

francis

Details Diff
fix(addressbook): import contact lists from LDIF file

Fixes 0003260
Affected Issues
0003260
mod - SOPE/NGCards/NGVList.m Diff File
mod - SoObjects/Contacts/NGVList+SOGo.h Diff File
mod - SoObjects/Contacts/NGVList+SOGo.m Diff File
mod - SoObjects/Contacts/SOGoContactGCSEntry.m Diff File
mod - SoObjects/Contacts/SOGoContactLDIFEntry.h Diff File
mod - SoObjects/Contacts/SOGoContactLDIFEntry.m Diff File
mod - UI/Contacts/UIxContactFolderActions.h Diff File
mod - UI/Contacts/UIxContactFolderActions.m Diff File

Issue History

Date Modified Username Field Change
2015-06-18 11:59 fsayd New Issue
2015-07-15 06:15 Christian Mack Relationship added duplicate of 0001651
2021-05-26 17:48 francis Changeset attached => sogo master e1d8d70e
2021-05-26 17:48 francis Assigned To => francis
2021-05-26 17:48 francis Resolution open => fixed
2021-05-26 17:49 francis Status new => resolved
2021-05-26 17:49 francis Resolution fixed => duplicate
2021-05-26 17:49 francis Fixed in Version => 5.1.1