View Issue Details

IDProjectCategoryView StatusLast Update
0003258SOGoBackend Address Bookpublic2016-12-30 16:00
ReporterRoKoInfo Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Platform[Server] LinuxOSDebianOS Version7 (Wheezy)
Product Version2.3.0 
Summary0003258: Missing Base64 Encoding for One Liners in Description (LDIF Export/Import)
Description

This is a small bug related to 0001251.

An LDIF export of a one liner in the notes (field description of the LDIF file), which contains only "base64 letters" and a colon, does not have a base64 encoding. An import of such an LDIF file produces an empty card due to two colons in one line.

A LF at the end forces base64 encoding.

Steps To Reproduce

Please try it with a card, it is simple to reproduce, e.g. attached file, which is an LDIF export from a small card.

Additional Information

None

TagsNo tags attached.

Relationships

duplicate of 0001760 resolvedludovic LDIF entries with ": " in an attribute value aren't imported into the address book 

Activities

RoKoInfo

RoKoInfo

2015-06-16 14:27

reporter  

tester.ldif (186 bytes)   
dn: cn=RoKoInfo Tester
objectClass: top
objectClass: inetOrgPerson
objectClass: mozillaAbPersonAlpha
description: alpha:beta
givenname: RoKoInfo
sn: Tester
displayname: RoKoInfo Tester

tester.ldif (186 bytes)   
ludovic

ludovic

2016-12-30 16:00

administrator   ~0011157

Bug fixed yesterday.

Issue History

Date Modified Username Field Change
2015-06-16 14:27 RoKoInfo New Issue
2015-06-16 14:27 RoKoInfo File Added: tester.ldif
2016-12-30 16:00 ludovic Note Added: 0011157
2016-12-30 16:00 ludovic Relationship added duplicate of 0001760
2016-12-30 16:00 ludovic Status new => resolved
2016-12-30 16:00 ludovic Resolution open => duplicate
2016-12-30 16:00 ludovic Assigned To => ludovic