View Issue Details

IDProjectCategoryView StatusLast Update
0000320SOGoWeb Calendarpublic2010-01-21 16:59
Reportercwright Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Versionnightly v2 
Fixed in Version1.2.0 
Summary0000320: Can't choose calendar for events via Web
Description

When creating or modifying an event in the Web interface, the calendar choice drop-down list is locked on Personal Calendar. The list of available calendars also doesn't display correctly in the drop-down list (which doesn't drop down any more).

See the attached screenshot.

Additional Information

I've noticed this in the nightly builds for the last several days. Currently I'm using 201001120651.

Also noticed this on the SOGo demo site (201001060936). Accounts for sogo2 and sogo3 are affected, but not sogo1.

TagsNo tags attached.

Activities

2010-01-13 16:13

 

calendar.png (31,117 bytes)   
calendar.png (31,117 bytes)   
wsourdeau

wsourdeau

2010-01-13 17:12

viewer   ~0000428

This issue happens on GNU/Linux systems because the appointment window is not large enough anymore. The general issue should be handled though.

cwright

cwright

2010-01-13 19:58

reporter   ~0000429

Indeed. I'd been using Firefox 3.5.7 on 64-bit Ubuntu when I noticed this issue. Firefox on Windows works fine. Thank you.

ludovic

ludovic

2010-01-14 12:53

administrator   ~0000435

The list of available calendars displays just fine for me - ie., the list that I'm allowed to create events into.

Does that work for you too under Windows? If so, that bug's description should be updated to better describe the problem.

cwright

cwright

2010-01-14 14:15

reporter   ~0000437

Yes, everything is working normally with Firefox on Windows. It's only in Firefox on Ubuntu that I see this issue. I agree on the update to the description, and I'd change it but my login doesn't have that ability. Thank you.

francis

francis

2010-01-14 14:20

administrator   ~0000438

The CSS block to play with, in UIxComponentEditor.css:

SELECT#calendarList
{ width: 16em; }

cwright

cwright

2010-01-14 14:46

reporter   ~0000439

Great. The slight change below has it working fine for me in Ubuntu now.

SELECT#calendarList
{ width: 15em; }

Thanks!

francis

francis

2010-01-21 16:59

administrator   ~0000494

See http://mtn.inverse.ca/revision/info/6c3ab3f69b066603f5ac7caffee043e67c1ab883

Issue History

Date Modified Username Field Change
2010-01-13 16:13 cwright New Issue
2010-01-13 16:13 cwright File Added: calendar.png
2010-01-13 17:12 wsourdeau Note Added: 0000428
2010-01-13 19:58 cwright Note Added: 0000429
2010-01-14 12:53 ludovic Note Added: 0000435
2010-01-14 14:15 cwright Note Added: 0000437
2010-01-14 14:20 francis Note Added: 0000438
2010-01-14 14:46 cwright Note Added: 0000439
2010-01-21 16:59 francis Note Added: 0000494
2010-01-21 16:59 francis Status new => resolved
2010-01-21 16:59 francis Fixed in Version => 1.2.0
2010-01-21 16:59 francis Resolution open => fixed
2010-01-21 16:59 francis Assigned To => francis