View Issue Details

IDProjectCategoryView StatusLast Update
0003157SOGoActiveSyncpublic2015-04-03 17:42
ReporterSigurd Holter Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSRHEL/CentOSOS Version7
Product Version2.2.17 
Fixed in Version2.3.0 
Summary0003157: Child exits with signal 6 : GSInlineArray(instance) does not recognize hasPrefix: INFO:(null)
Description

We get this error in our logs :

Mar 31 09:32:27 sogod [33323]: ip "POST /SOGo/Microsoft-Server-ActiveSync?Cmd=Ping&User=user&DeviceId=D68F2ED3D99342ECAC09DEA41601A821&DeviceType=WindowsOutlook15 HTTP/1.1" 200 101/764 2.199 - - 6M
Mar 31 09:32:27 sogod [33323]: |SOGo| starting method 'POST' on uri '/SOGo/Microsoft-Server-ActiveSync?Cmd=Sync&User=usero&DeviceId=D68F2ED3D99342ECAC09DEA41601A821&DeviceType=WindowsOutlook15'
Mar 31 09:32:27 sogod [33323]: <0x0x7faeb879e470[NGImap4Client]> TLS started successfully.
Mar 31 09:32:27 sogod [33323]: <0x0x7faeb879e470[NGImap4Client]> Note: no key found for sorting, using 'DATE': (null)
EXCEPTION: <NSException: 0x7faebae0f220> NAME:NSInvalidArgumentException REASON:GSInlineArray(instance) does not recognize hasPrefix: INFO:(null)
Mar 31 09:32:29 sogod [33193]: <0x0x7faeb8395760[WOWatchDogChild]> child 33323 exited
Mar 31 09:32:29 sogod [33193]: <0x0x7faeb8395760[WOWatchDogChild]> (terminated due to signal 6)

This appeared in 2.2.17 and is still there in 2.2.17a

TagsNo tags attached.

Activities

ludovic

ludovic

2015-03-31 16:14

administrator   ~0008384

Fix pushed: https://github.com/inverse-inc/sogo/commit/b2d7eb40c2d86b9c536477170eebe68716212b60

Try the upcoming nightly builds.

ludovic

ludovic

2015-04-03 17:42

administrator   ~0008389

No feedback receiving after fix being pushed, closing.

Issue History

Date Modified Username Field Change
2015-03-31 03:35 Sigurd Holter New Issue
2015-03-31 16:14 ludovic Note Added: 0008384
2015-04-03 17:42 ludovic Note Added: 0008389
2015-04-03 17:42 ludovic Status new => resolved
2015-04-03 17:42 ludovic Fixed in Version => 2.3.0
2015-04-03 17:42 ludovic Resolution open => fixed
2015-04-03 17:42 ludovic Assigned To => ludovic