View Issue Details

IDProjectCategoryView StatusLast Update
0003123SOGoActiveSyncpublic2015-05-12 09:54
ReporterJinH Assigned Toludovic  
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Platform[Client] MicrosoftOSWindowsOS Version7
Target Version2.3.0Fixed in Version2.3.0 
Summary0003123: sogo may incorrectly decode the calendar event reply coming from outlook
Description

In outlook we create a new calendar event and send it to an attendee. The attendee accepts the event and sends back the reply email. The outlook updates the participation status to server. Sogo server may incorrectly decode the quoted-printable encoding in the calendar data.
For example, in the following event, the uid
UID:040000008200E00074C5B7101A82E00800000000A05674ECA751D00100000000000=000
010000000B96A981D686420428899E34B62CCD963

is wrong. Because "=" is part of quoted-printable encoding. It should my
removed from data.

PRODID:-//Inverse inc./SOGo 2.2.15//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:America/Montreal
X-LIC-LOCATION:America/Montreal
BEGIN:DAYLIGHT
TZOFFSETFROM:-0500
TZOFFSETTO:-0400
TZNAME:EDT
DTSTART:19700308T020000
RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=2SU
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:-0400
TZOFFSETTO:-0500
TZNAME:EST
DTSTART:19701101T020000
RRULE:FREQ=YEARLY;BYMONTH=11;BYDAY=1SU
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
UID:040000008200E00074C5B7101A82E00800000000A05674ECA751D00100000000000=000
010000000B96A981D686420428899E34B62CCD963
SUMMARY:test from a102 to a101
CLASS:PUBLIC
LOCATION:2nd floor
DTSTART;VALUE=DATE:20150228
DTEND;VALUE=DATE:20150301
ORGANIZER;CN=a102@felab.net;PARTSTAT=ACCEPTED:mailto:a102@felab.net
ATTENDEE;CN=a101@felab.net;PARTSTAT=ACCEPTED:mailto:a101@felab.net
END:VEVENT
END:VCALENDAR

TagsNo tags attached.

Relationships

duplicate of 0003113 resolvedludovic Outlook 2013 MeetingResponse 

Activities

tfu

tfu

2015-03-07 16:25

reporter   ~0008252

Outlook sends following mail via EAS:

From: "xx XX" <nnn@xxx.yyy.zzz>
To: <mmm@kkk.xx>
Subject: einladung
Date: Fri, 6 Mar 2015 20:35:19 +0100
Message-ID: <012701d05844$ae1fe290$0a5fa7b0$@xxx.yyy.zzz>
MIME-Version: 1.0
Content-Type: text/calendar; method=REQUEST;
charset="UTF-8"
Content-Transfer-Encoding: 7bit
X-Mailer: Microsoft Outlook 15.0
Thread-Index: AdBYRKYVy92arwhaQ5iTBsYkRh+97AAAAeVg
Content-Language: de

BEGIN:VCALENDAR
PRODID:-//Microsoft Corporation//Outlook 15.0 MIMEDIR//EN
VERSION:2.0
METHOD:REQUEST
X-MS-OLK-FORCEINSPECTOROPEN:TRUE
BEGIN:VEVENT
ATTENDEE;CN=mmm@kkk.xx;RSVP=TRUE:mailto:mmm@kkk.xx
CLASS:PUBLIC
CREATED:20150306T193518Z
DESCRIPTION:\n\n
DTEND;VALUE=DATE:20150308
DTSTAMP:20150306T193518Z
DTSTART;VALUE=DATE:20150307
LAST-MODIFIED:20150306T193518Z
ORGANIZER;CN="xx XX":mailto:nnn@xxx.yyy.zzz
PRIORITY:5
SEQUENCE:0
SUMMARY;LANGUAGE=de:einladung
TRANSP:OPAQUE
UID:040000008200E00074C5B7101A82E008000000001053700F4D58D001000000000000000
0100000009F6E7D06A7B0934B8FE97C642C849F96
X-MICROSOFT-CDO-BUSYSTATUS:TENTATIVE
X-MICROSOFT-CDO-IMPORTANCE:1
X-MICROSOFT-CDO-INTENDEDSTATUS:FREE
X-MICROSOFT-DISALLOW-COUNTER:FALSE
X-MS-OLK-AUTOSTARTCHECK:FALSE
X-MS-OLK-CONFTYPE:0
END:VEVENT
END:VCALENDAR

It seems that sogo re-encodes the mail into quoted-printable. When the accepting the invite (from the received email) via the web ui following error message is reported in sogo.log:

Mar 06 20:33:18 sogod [30356]: [ERROR] <0xB70E2F38[SOGoMailObject]:1685> body part index out of bounds(idx=1 vs count=0): {bodyId = ""; description = ""; disposition = {}; encoding = "quoted-printable"; languages = (de); lines = 31; location = ""; md5 = ""; parameterList = {charset = "utf-8"; method = REQUEST; }; size = 870; subtype = calendar; type = text; }

The problem is that sogo fails to decode (quoted-printable) the invite before saving it to the calendar.

I hope this helps to fix the issue.

ludovic

ludovic

2015-05-12 09:54

administrator   ~0008468

https://github.com/inverse-inc/sogo/commit/4826f0155552d56a98712dff1a607a2504b98591

Issue History

Date Modified Username Field Change
2015-03-06 11:47 JinH New Issue
2015-03-07 16:25 tfu Note Added: 0008252
2015-03-17 06:29 Christian Mack Relationship added duplicate of 0003113
2015-05-12 09:54 ludovic Target Version => 2.3.0
2015-05-12 09:54 ludovic Note Added: 0008468
2015-05-12 09:54 ludovic Status new => resolved
2015-05-12 09:54 ludovic Fixed in Version => 2.3.0
2015-05-12 09:54 ludovic Resolution open => fixed
2015-05-12 09:54 ludovic Assigned To => ludovic