View Issue Details

IDProjectCategoryView StatusLast Update
0003080SOGoActiveSyncpublic2015-06-17 15:59
Reportermartinsimovic Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Client] AppleOSiOSOS Version7
Product Version2.2.14 
Fixed in Version2.3.1 
Summary0003080: Meeting invitations not handled properly when EAS is used
Description

On Apple iOS 8, access to sogo configured as EAS account.

When a meeting invitation is received from meeting organiser outside of native SOGo domain (e.g. different SOGo server) time/date of the meeting is always shown as 01:00AM 01.01.2001.

This renders RVSP buttons unusable since we're responding to meeting we have never been invited to (wrong date). An event is also added in wrong place in calendar, causing the whole operation to fail.

Additional Information

SOGo server running on Ubuntu Trusty x_64, version 2.2.14

TagsNo tags attached.

Activities

jensr

jensr

2015-05-13 08:32

reporter   ~0008485

Last edited: 2015-05-13 08:34

View 2 revisions

Applies to all ActiveSync Devices. Entries are displayed correctly in Thunderbird and SOGo Web Access but screwed when using EAS.

Hitting 'Accept' causes the sender server to drop the reply and adds an entry to the attendees calender at the date/time shown.

Attached Screenshot shows the same message on the same device.

Edit: The appointment was created with Outlook/Exchange 2010

jensr

jensr

2015-05-13 08:32

reporter  

2015-05-13_14h27_24.png (77,491 bytes)   
2015-05-13_14h27_24.png (77,491 bytes)   
tfu

tfu

2015-06-02 05:07

reporter   ~0008554

Last edited: 2015-06-02 06:44

View 2 revisions

Can you check with 2.3 whether it is still reproduceable.
https://github.com/inverse-inc/sogo/commit/96b2e0e1f5465627925faa60188c232d67f4e4ae

jensr

jensr

2015-06-17 10:20

reporter   ~0008652

Seems fixed with 2.3 - even though you get two calendar icons on iOS devices (see screenshot).

Tested with:

  • iOS 8.1.1 (iPad)
  • BlackBerry 10.3 (Z3 on BES 12)
  • Windows Phone 8.1 (Nokia Lumia 530)
  • Android 4.3 (HTC One)

Thanks!

jensr

jensr

2015-06-17 10:21

reporter  

2015-06-17_11h03_50.png (23,463 bytes)   
2015-06-17_11h03_50.png (23,463 bytes)   
ludovic

ludovic

2015-06-17 15:59

administrator   ~0008653

Fixed and the dupe is fixed with:

https://github.com/inverse-inc/sogo/commit/3809c002ede0c7aebe1cc0b846362418b87b2a48

Issue History

Date Modified Username Field Change
2015-01-28 05:54 martinsimovic New Issue
2015-03-18 13:58 ludovic Category Apple iPhone OS => ActiveSync
2015-05-13 08:32 jensr Note Added: 0008485
2015-05-13 08:32 jensr File Added: 2015-05-13_14h27_24.png
2015-05-13 08:34 jensr Note Edited: 0008485 View Revisions
2015-06-02 05:07 tfu Note Added: 0008554
2015-06-02 06:44 tfu Note Edited: 0008554 View Revisions
2015-06-17 10:20 jensr Note Added: 0008652
2015-06-17 10:21 jensr File Added: 2015-06-17_11h03_50.png
2015-06-17 15:59 ludovic Note Added: 0008653
2015-06-17 15:59 ludovic Status new => resolved
2015-06-17 15:59 ludovic Fixed in Version => 2.3.1
2015-06-17 15:59 ludovic Resolution open => fixed
2015-06-17 15:59 ludovic Assigned To => ludovic