View Issue Details

IDProjectCategoryView StatusLast Update
0003072SOGo Connectorwith external serverpublic2016-07-22 14:43
Reporterbee Assigned Toludovic  
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version7 (Wheezy)
Product Version31.0.1 
Fixed in Version31.0.4 
Summary0003072: If-Match eTag Issue when making changes without synchronizing before
Description

Hello Guys,

we just realized an serioues issue with the sogo connector.
If you connect an addressbook from davical Server to two different Thunderbird-Clients with any version of sogo connector you will sooner or later run into concurrency issues.

Client A syncs and changes Contact X

  • Server accepts changed
    Client B changed Contact X without sync afterwards
  • Server refuses changes with if-match "Existing resource eTag of xx does not match yy".

Thats a serious issue for the part that sogo does not tell it to the user like "Hey, there have been changes on the server to the contact you are trying to update. Can't update!".
But also for the fact that Client B thinks everything got saved fine and from that point on you got inconsistencys.

Steps To Reproduce
  1. Add same addressbook collection to 2 thunderbirds.
  2. Sync both
  3. Edit the same contact on one side and save it
  4. Edit the same contact on the other side and save it

Client A syncs and changes Contact X
Client B changed Contact X without sync afterwards

  • Server refuses changes with if-match "Existing resource eTag of xx does not match yy".
TagsNo tags attached.

Activities

bee

bee

2015-02-04 10:41

reporter   ~0008135

Last edited: 2015-07-20 10:03

Hello,

it would at least be really helpful to know if the problem can be confirmed.
Or is working as intended? Am i supposed to sync my book everytime i want to change something in the contacts?

Kind regards

ludovic

ludovic

2016-07-21 21:38

administrator   ~0010519

The problem is that SOGo Connector doesn't handle the HTTP/412 error - it should refetch the card from the server when that happens. We'll fix it.

ludovic

ludovic

2016-07-22 14:43

administrator   ~0010522

Fixed with: https://github.com/inverse-inc/sogo-connector.tb31/commit/7595bae1ffa3f390d1fe48bf74c4afdaf75a4207

Please try the nightly xpi:

http://packages.inverse.ca/SOGo/thunderbird/nightly/sogo-connector-31.0.4-7595bae1ff.xpi

Issue History

Date Modified Username Field Change
2015-01-22 10:27 bee New Issue
2015-02-04 10:41 bee Note Added: 0008135
2015-07-20 10:03 bee Note Edited: 0008135
2016-07-12 08:05 ludovic Status new => assigned
2016-07-12 08:05 ludovic Assigned To => ludovic
2016-07-21 21:38 ludovic Note Added: 0010519
2016-07-22 14:43 ludovic Note Added: 0010522
2016-07-22 14:43 ludovic Status assigned => resolved
2016-07-22 14:43 ludovic Fixed in Version => 31.0.4
2016-07-22 14:43 ludovic Resolution open => fixed