View Issue Details

IDProjectCategoryView StatusLast Update
0003058SOGoActiveSyncpublic2015-06-03 08:11
ReporterRaido Assigned Toludovic  
PriorityhighSeveritymajorReproducibilitysometimes
Status resolvedResolutionsuspended 
Platform[Client] MicrosoftOSWindowsOS Version7
Product Version2.2.12 
Fixed in Version2.2.17 
Summary0003058: Some mails wont show up in Outlook
Description

Some mails won't show in Outlook, but they are in webmail.
I can make them to show in Outlook by loging into webmail and marking these letters and right click to theese email and select move to->inbox then Outlook downloads these messages.

Emails that are not showing up, are random. Sometimes 1 a day, someday half mails.

Steps To Reproduce

-

TagsNo tags attached.

Relationships

related to 0003160 resolvedludovic Bug 0003058 is not fixed 

Activities

tfu

tfu

2015-01-15 14:53

reporter   ~0008085

Try to identify the message id which is not showing up in outlook:

open the message with sogo-web and check the URL:
https://server.domain/SOGo/so/user/Mail/0/folderShared/folderMail/1030/popupview
-> e.g. msgid=1030

Search EAS Cache for the message id
sogo-tool -v manage-eas listfolders <userid> <deviceid>

If the id is found in SyncCache (e.g. SyncCache = {1030 = 4711 ....}) the message was touched by sogo's eas code but it somehow didn't reach the client.

Raido

Raido

2015-01-20 03:49

reporter   ~0008096

For some users ActiveSync with Outlook 2013 wont start downloading messages at all, even with new outlook profile. For a while status is "Waiting for a server response" and then changes to "Disconnected from server".

tfu

tfu

2015-01-20 06:08

reporter   ~0008097

What is in sogo.log when the status changes to "Disconnected from server".
How long does it take until "Waiting for a server response" goes to "Disconnected from server"?

Raido

Raido

2015-01-23 06:34

reporter   ~0008106

This sogo log when 1 message did not show up in sent folder in outlook. In webmail letter was in sent folder.

192.168.1.254 - - [23/Jan/2015:13:19:04 GMT] "POST /SOGo/so/ott/Mail/0/folderSent/moveMessages HTTP/1.1" 204 0/41 0.336 - - 1M
Jan 23 13:19:04 sogod [14786]: [ERROR] [we-rm] did not find locale for language: Estonian
2015-01-23 13:19:04.902 sogod[10405] -[WEClientCapabilities initWithRequest:]: Unknown WebClient: user-agent='Outlook/15.0 (15.0.4673.1000; C2R; x86)'
Jan 23 13:19:04 sogod [12318]: [ERROR] [we-rm] did not find locale for language: Estonian
192.168.1.254 - - [23/Jan/2015:13:19:05 GMT] "POST /SOGo/so/ott/Mail/0/folderSent/unseenCount HTTP/1.1" 200 13/0 0.247 - - 20K
192.168.1.254 - - [23/Jan/2015:13:19:05 GMT] "POST /SOGo/so/ott/Mail/0/folderSent/headers HTTP/1.1" 200 617/15 0.244 - - 0

tfu

tfu

2015-01-30 17:25

reporter   ~0008128

Can you try 2.2.15? It contains a fix which changes the sync/ping behavior.
The "Disconnected from server" could be caused by a sync requests which doesn't return immediatly...

Raido

Raido

2015-02-06 02:34

reporter   ~0008147

2.2.15 version did not solve my problem.

tfu

tfu

2015-02-06 06:55

reporter   ~0008149

Please be more chatty ...
Do you still get the "Disconnected from server"?
What do you see in sogo.log when this occurs?
You say "form some users..." - what is the difference to users without problems?

Raido

Raido

2015-03-10 05:19

reporter   ~0008255

I no longer get disconnected from server. I also run version 2.2.16 now. But problem occurs still.

Right now I have a problem with sogo log, so there is very hard to get any information out: http://www.sogo.nu/bugs/view.php?id=3125

tfu

tfu

2015-03-10 17:05

reporter   ~0008258

Do you still have the issue described on 20.1. (For some users ActiveSync with Outlook 2013 wont start downloading messages at all)?

Raido

Raido

2015-03-11 03:54

reporter   ~0008259

This was resolved by another technician in our company, who is at vacation right now. I can provide you a solution to that next week.

Customer said that he sees new messages in webmail, but in order to get them to outlook, he must close and reopen outlook manually. Send/recieve wont bring messages to outlook.

tfu

tfu

2015-03-11 04:35

reporter   ~0008260

So, I assume that the problem mentioned in the initial problem description ( ...select move to->inbox then Outlook downloads these messages...) also doesn't occure any longer.

I would help to have a

tcpdump -i lo -s 0 -w /tmp/dump.pcap tcp and port 20000

when there are message waiting on server but outlook doesn't pick them up.

You can send it directly to me if you don't want to upload.

Raido

Raido

2015-03-16 03:45

reporter   ~0008276

( ...select move to->inbox then Outlook downloads these messages...) This workaround still makes possible to download non-downloaded messages to outlook.

ludovic

ludovic

2015-03-23 17:25

administrator   ~0008353

Potential fix pushed here:

https://github.com/inverse-inc/sogo/commit/cc3652b59b40bcb420d806412277509ac247d85d [^]

Bug suspended for now.

Issue History

Date Modified Username Field Change
2015-01-12 08:49 Raido New Issue
2015-01-15 14:53 tfu Note Added: 0008085
2015-01-20 03:49 Raido Note Added: 0008096
2015-01-20 06:08 tfu Note Added: 0008097
2015-01-23 06:34 Raido Note Added: 0008106
2015-01-30 17:25 tfu Note Added: 0008128
2015-02-06 02:34 Raido Note Added: 0008147
2015-02-06 06:55 tfu Note Added: 0008149
2015-03-10 05:19 Raido Note Added: 0008255
2015-03-10 17:05 tfu Note Added: 0008258
2015-03-11 03:54 Raido Note Added: 0008259
2015-03-11 04:35 tfu Note Added: 0008260
2015-03-16 03:45 Raido Note Added: 0008276
2015-03-23 17:25 ludovic Note Added: 0008353
2015-03-23 17:25 ludovic Status new => resolved
2015-03-23 17:25 ludovic Fixed in Version => 2.2.17
2015-03-23 17:25 ludovic Resolution open => suspended
2015-03-23 17:25 ludovic Assigned To => ludovic
2015-06-03 08:11 Christian Mack Relationship added related to 0003160