View Issue Details

IDProjectCategoryView StatusLast Update
0003008SOGoWeb Calendarpublic2014-12-17 13:59
Reportercodelett Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.2.10 
Target Version2.2.12Fixed in Version2.2.12 
Summary0003008: Calendar reminder immediately shown when target date selected.
Description

When creating calendar entries for future dates that are currently selected in the calendar, than reminders are fired instantly regardless of current time and date.

Steps To Reproduce

Go to web interface.
Go to calendar.
Select a future date where you want to create an appointment (by clicking the date in the calendar view).
Create calender entry for the currently selected date, with reminder 15 minutes ahead.
Submit new entry.

Webinterfaces shows reminder immediately, even if its not the same date or time.

Additional Information

Did not happen before 2.2.10.

TagsNo tags attached.

Activities

codelett

codelett

2014-12-14 06:08

reporter   ~0007835

Last edited: 2014-12-14 06:09

View 2 revisions

Since a few days I am also getting notifications in webcalender that do not fit to the appointments.

For example I have an appointment on February 1st 2015, 12 o'oclock. But reminder is fired on December 14th 2014, 12 o'clock.

Happens only in Webcalender, synched devices do not show these notifications.

ludovic

ludovic

2014-12-16 11:53

administrator   ~0007848

I can't reproduce that.

codelett

codelett

2014-12-16 12:29

reporter   ~0007849

Last edited: 2014-12-16 12:31

View 2 revisions

I just retested, issue is still there. But I found out, that it seems to be dependent on the date.

Creating an appointment today for any date between January 11 and February 4 (2015) ends up with an immediately shown reminder. If I create it on any date outside this range I do not get the reminder directly after creating the entry.

Version is 2.2.11a.

ludovic

ludovic

2014-12-16 14:54

administrator   ~0007855

What do you mean by an "with an immediately shown reminder" ?

In what timezone are you in?

I still can't reproduce this.

codelett

codelett

2014-12-16 15:44

reporter   ~0007856

Last edited: 2014-12-16 15:54

View 3 revisions

I am in timezone Europe/Berlin using German frontend. What I am doing is:

  • it is December 16, 21:15
  • I am opening web calender and create a new appointment
  • target date is January 29, 18:00 (2015)
  • I keep my default reminder which says "remind me 15 minutes before the appointment"
  • I click on save
  • instantly after clicking the save button the reminder window pops up
  • why? Its not 15 minutes before January 29, 18:00

This behaviour is reproducible on my calender. I can also reproduce this on your sogo3 demo account with several languages (German, English, French)! Surprisingly it does not happen on your sogo1 demo account!

What I also see sometimes, but cannot reproduce is that reminders open during normal use when they are not expected. So for example I had an event in my calendar for January 7 17:30 (created somewhere in November) with a reminder set to 15 minutes earlier. This reminder just opened yesterday morning.

codelett

codelett

2014-12-16 16:06

reporter   ~0007857

Strange thing... Created some more events on sogo3 and the reminders did not show up immediately. But after logout and login again reminders showed up for appointments on January 28 and 29.

ludovic

ludovic

2014-12-17 13:33

administrator   ~0007866

Ok, with your example above, I can reproduce it.

ludovic

ludovic

2014-12-17 13:59

administrator   ~0007867

https://github.com/inverse-inc/sogo/commit/cd70bec9faf8f29159eafb3ae1e63ab9d7a76919

Issue History

Date Modified Username Field Change
2014-12-02 02:31 codelett New Issue
2014-12-14 06:08 codelett Note Added: 0007835
2014-12-14 06:09 codelett Note Edited: 0007835 View Revisions
2014-12-16 11:53 ludovic Note Added: 0007848
2014-12-16 12:29 codelett Note Added: 0007849
2014-12-16 12:31 codelett Note Edited: 0007849 View Revisions
2014-12-16 14:54 ludovic Note Added: 0007855
2014-12-16 15:44 codelett Note Added: 0007856
2014-12-16 15:53 codelett Note Edited: 0007856 View Revisions
2014-12-16 15:54 codelett Note Edited: 0007856 View Revisions
2014-12-16 16:06 codelett Note Added: 0007857
2014-12-17 13:33 ludovic Note Added: 0007866
2014-12-17 13:58 ludovic Target Version => 2.2.12
2014-12-17 13:59 ludovic Note Added: 0007867
2014-12-17 13:59 ludovic Status new => resolved
2014-12-17 13:59 ludovic Fixed in Version => 2.2.12
2014-12-17 13:59 ludovic Resolution open => fixed
2014-12-17 13:59 ludovic Assigned To => ludovic