View Issue Details

IDProjectCategoryView StatusLast Update
0002993SOGoBackend Address Bookpublic2015-01-13 15:41
Reportersogo@ebertech.ca Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformBlackberryOS10OS Version10.2
Target Version2.2.14Fixed in Version2.2.14 
Summary0002993: The etag header returned after a create is misspelled
Description

Hi, I've been having a lot of issues with contacts duplicating on my blackberry q10. The weird thing was it wasn't an issue with blackberry since I could sync with other carddav servers. After painstakingly tracing through the requests and responses I finally found what's causing the issue. After a PUT request is made, the response contains an etag, but the header is Etag instead of ETag (lowercase t instead of capital T). I had the proxy intercept and change the t from lowercase to upper case and everything works now. I think this would be a trivial fix and I'm pretty sure the header should be ETag.

Steps To Reproduce

do a PUT to create a new contact
the response as a Etag header

TagsNo tags attached.

Relationships

has duplicate 0002548 resolvedludovic CardDav: duplicate contact added when trying to edit existing one using Blackberry 10 

Activities

sogo@ebertech.ca

sogo@ebertech.ca

2014-11-22 19:30

reporter   ~0007721

Last edited: 2014-11-22 19:31

So, technically according to

http://www.w3.org/Protocols/rfc2616/rfc2616-sec4.html#sec4.2

Each header field consists of a name followed by a colon (":") and the field value. Field names are case-insensitive.

I realize that this is a problem on blackberry's side, but the odds of them fixing this is 0, whereas all other clients seem to (correctly) not care about the casing (since they work).

ludovic

ludovic

2014-11-22 19:35

administrator   ~0007722

No worry, we'll add a bugfix for it. Good catch.

ludovic

ludovic

2015-01-13 15:41

administrator   ~0008070

https://github.com/inverse-inc/sope/commit/bcbe4afed90dbb00cb406e6d02fc590d0d1243a9

Please try the upcoming nightly builds. Update SOPE and SOGo.

Issue History

Date Modified Username Field Change
2014-11-22 17:53 sogo@ebertech.ca New Issue
2014-11-22 19:30 sogo@ebertech.ca Note Added: 0007721
2014-11-22 19:31 sogo@ebertech.ca Note Edited: 0007721
2014-11-22 19:35 ludovic Note Added: 0007722
2014-12-30 14:03 ludovic Target Version => 2.2.13
2014-12-30 14:05 ludovic Target Version 2.2.13 => 2.2.14
2014-12-30 14:06 ludovic Relationship added has duplicate 0002548
2015-01-13 15:41 ludovic Note Added: 0008070
2015-01-13 15:41 ludovic Status new => resolved
2015-01-13 15:41 ludovic Fixed in Version => 2.2.14
2015-01-13 15:41 ludovic Resolution open => fixed
2015-01-13 15:41 ludovic Assigned To => ludovic