View Issue Details

IDProjectCategoryView StatusLast Update
0002949SOGoBackend Mailpublic2016-06-13 13:18
ReporterMarcel Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSUbuntuOS Version14.04 LTS
Product Version2.2.9a 
Fixed in Version2.3.13 
Summary0002949: SOGoSieveFilters in sogo.conf used twice
Description

I know the use of SOGoSieveFilters in the configuration file is not documented. However, being able to set a default value there for all users who have not set any sieve-related parameters yet would greatly simplify
(a) the move from another sieve manager to using SOGo for vacation/forwarding/sorting and
(b) user provisioning procedures.

Right now, all the parameters for SOGo can be set in the configuration file, so on the first SOGo user login, everything is autoconfigured as it should be, except for our systemwide sieve default rules (spam filtering).

Steps To Reproduce

Adding a SOGoSieveFilters parameter to /etc/sogo/sogo.conf results in all the rules being included twice in the sieve filter list:

  • The first time correctly, but
  • the second time with all fields empty
    This happens whenever SOGoSieveFilters is set in /etc/sogo.conf; however, it shows the "correct" entries twice:
  • if there are local Sieve settings, they are shown twice
  • if there are no local sieve settings, the global ones are shown twice

This looks like a minor twist in the settings retrieval logic.

Additional Information

For users with personal sieve settings, the duplication may be permanent (even though "sogo-tool backup", "sogo-tool user-preferences get defaults … SOGoSieveFilters" and the entry in the sogo_user_profile database table look ok and sogod+memcached have been restarted).

TagsNo tags attached.

Activities

francis

francis

2014-10-08 12:56

administrator   ~0007593

You should use sogo-tool to set filters for a user. A filter defined in sogo.conf won't be pushed to the Sieve server.

Marcel

Marcel

2014-10-08 14:49

reporter   ~0007594

I am fully aware of that. But as the IMAP server is already preconfigured with a sieve script, this would be perfect. SOGo only needs to do anything when the first user changes their sieve-related settings. As SOGo does not query the current sieve script, there needs to be a way of telling SOGo what sieve state it should present the user with. This is exactly where a global SOGoSieveFilters setting would be handy.

ludovic

ludovic

2016-06-13 13:18

administrator   ~0010353

Also fixed for 3.1.3.

Related Changesets

sogo: v2 eab6502d

2016-06-13 13:14:55

ludovic

Details Diff
(feat) now possible to set a default Sieve filter (fixes 0002949) Affected Issues
0002949
mod - Documentation/SOGoInstallationGuide.asciidoc Diff File
mod - UI/MainUI/SOGoUserHomePage.m Diff File

sogo: master ae7fefb4

2016-06-13 13:14:55

ludovic

Details Diff
(feat) now possible to set a default Sieve filter (fixes 0002949) Affected Issues
0002949
mod - Documentation/SOGoInstallationGuide.asciidoc Diff File
mod - UI/MainUI/SOGoUserHomePage.m Diff File

Issue History

Date Modified Username Field Change
2014-10-07 11:48 Marcel New Issue
2014-10-08 12:56 francis Note Added: 0007593
2014-10-08 14:49 Marcel Note Added: 0007594
2016-06-13 13:16 ludovic Changeset attached => sogo v2 eab6502d
2016-06-13 13:16 ludovic Assigned To => ludovic
2016-06-13 13:16 ludovic Resolution open => fixed
2016-06-13 13:17 ludovic Changeset attached => sogo master ae7fefb4
2016-06-13 13:18 ludovic Note Added: 0010353
2016-06-13 13:18 ludovic Status new => resolved
2016-06-13 13:18 ludovic Fixed in Version => 2.3.13