View Issue Details

IDProjectCategoryView StatusLast Update
0002940SOGoActiveSyncpublic2014-10-29 14:56
Reporterder.tale Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Client] GoogleOSAndroidOS VersionKit Kat
Product Version2.2.9a 
Target Version2.2.10Fixed in Version2.2.10 
Summary0002940: ActiveSync PING Command sent multiple times per second
Description

I am syncing my Nexus 5 with Android 4.4 and the standard Mail app with my SoGO server via ActiveSync. After the initial sync of all emails the phone starts sending PING commands. This happens multiple times per second (and not only once per few seconds/minutes as a keepalive) which produces a high load on the phone, which depletes the battery after a few hours.

For every PING command sent sogo.log shows following entry:

83.221.34.4 - - [01/Oct/2014:14:28:59 GMT] "POST /SOGo/Microsoft-Server-ActiveSync?Cmd=Ping&User=manuel%40zamora.de&DeviceId=0&DeviceType=Android HTTP/1.1" 200 13/123 0.003 - - 0
2014-10-01 14:28:59.394 sogod[17507] -[WEClientCapabilities initWithRequest:]: Unknown WebClient: user-agent='Android/4.4.4-EAS-2.0'

Steps To Reproduce

Set up a new exchange account on the phone, wait until all mails are synced.

Additional Information

As this is working normally with other ActiveSync backends something must be at fault with the SoGO implementation

TagsNo tags attached.

Activities

ludovic

ludovic

2014-10-01 08:49

administrator   ~0007581

I've just tried and I don't have this issue with my Android 4.4 device.

Take a tcpdump of the traffic on the SOGo server, localhost/port 20000 so I can see the AS payload. Attach it to this ticket.

der.tale

der.tale

2014-10-01 09:19

reporter  

sogo.dump (397,355 bytes)
der.tale

der.tale

2014-10-01 09:20

reporter   ~0007582

Attached a dump with an inital sync, then the PINGs start.

TribesTom

TribesTom

2014-10-07 11:55

reporter   ~0007591

Hello i have the same problem with android 4.4 client.

It's a new installation for test.

All running good expcet this little problem which flood sogo logs and drain my phone battery.

It happen more the 10 times every second.

Log :
2014-10-07 17:50:40.968 sogod[10018] -[WEClientCapabilities initWithRequest:]: Unknown WebClient: user-agent='Android/4.4.4-EAS-2.0'
193.190.182.193, 192.168.100.101 - - [07/Oct/2014:17:50:40 GMT] "POST /SOGo/Microsoft-Server-ActiveSync?Cmd=Ping&User=XXXX&DeviceId=androidc1005440802&DeviceType=Android HTTP/1.1" 200 18/50 0.002 - - 0

Ps: replaced my user for security reason

Thanks

ludovic

ludovic

2014-10-09 14:34

administrator   ~0007598

Try setting:

SOGoMaximumPingInterval = 4;
SOGoInternalSyncInterval = 4;

in /etc/sogo/sogo.conf and tell me if it's better.

der.tale

der.tale

2014-10-09 14:46

reporter   ~0007599

That did help! The PING interval now seems to be 4-5 seconds, corresponding to the new configuration entries. What is a sensible interval duration für the Ping?

Does SOGO use an incremental interval duration, or is it fixed? (like described here: http://technet.microsoft.com/en-us/library/cc182270.aspx)

To "fix"/prevent this problem the SoGO default values should probably be set to something longer than one second.

Thank you!

ludovic

ludovic

2014-10-09 14:49

administrator   ~0007600

We will fix the issue. I've just identified the bug but I'm not in a position to fix it right now. I just wanted to validate my theory.

ludovic

ludovic

2014-10-29 14:56

administrator   ~0007634

https://github.com/inverse-inc/sogo/commit/b5023eeb245c0c0cec40b018af404049119cd4d0

Issue History

Date Modified Username Field Change
2014-10-01 08:37 der.tale New Issue
2014-10-01 08:49 ludovic Note Added: 0007581
2014-10-01 09:19 der.tale File Added: sogo.dump
2014-10-01 09:20 der.tale Note Added: 0007582
2014-10-07 11:55 TribesTom Note Added: 0007591
2014-10-07 12:43 ludovic Target Version => 2.2.10
2014-10-09 14:34 ludovic Note Added: 0007598
2014-10-09 14:46 der.tale Note Added: 0007599
2014-10-09 14:49 ludovic Note Added: 0007600
2014-10-29 14:56 ludovic Note Added: 0007634
2014-10-29 14:56 ludovic Status new => resolved
2014-10-29 14:56 ludovic Fixed in Version => 2.2.10
2014-10-29 14:56 ludovic Resolution open => fixed
2014-10-29 14:56 ludovic Assigned To => ludovic